Velocity not recording correctly

Just got a Digitone Keys that I’m really enjoying. However, I just noticed a weird issue as I try to record a velocity-sensitive part. I was recording a riff of straight 16ths in via live recording with pretty soft velocity. However, for maybe half of the steps, velocity wasn’t parameter-locked for the step, resulting in the 100 velocity default, totally messing up the feel of what I was going for. Some of the velocity recording worked, so I know it’s possible. Any idea why this might be the case?

Edit: to be clear, this is a monophonic part, with one note per step, though I don’t actually have it locked to a single voice (it’s set to the default dynamic voice mode).

That is very weird. Were you in MultiMap mode or anything??
And those particular keys on the keybed itself are normally responsive to various velocities?

1 Like

No multimap mode, and the keys themselves respond normally.

I think I figured out what’s causing it, though. This issue only occurs when the previous note’s length bleeds into the next note. So let’s say I’m playing steady 16th notes, but for some of them, I press a new key before I’ve let up on the previous one. Any note that has a previous note hanging over it does not receive a parameter-locked velocity.

This seems like a serious issue. Has anyone run into this? I’m very familiar with the Elektron sequencer and am aware that it doesn’t act like a standard MIDI recorder (with regard to held notes, etc.). But I don’t understand why this would be happening.


Yes it’s always happened to me and I’ve had to go in and edit the velocitys after.


Yeah, I just tried this out without listening to any audio or anything, so not as controlled and scientifically…but I actually real time recorded a succession of notes and I went back in and found a trig with no locked velocity, but it was immediately following a trig with a very short gate time, not overlapping. Weird.

Regardless. This is not how the device should function and I would consider it a bug unless there’s some obscure reason why this should be thought of as a “feature”.

1 Like

Thanks for checking it out. Submitting a bug report now and will report back when I hear something.


Heard from Elektron support:
“This is a confirmed bug and it has been reported to our developers. We will most likely have a fix for it in a future OS release.”

Hopefully a fix will come soon. I’m kind of amazed the issue wasn’t caught before release…it took me a single day to run into it after receiving the DK.


Hello, I am curious if this bug has been fixed already? thanks