Using Octatrack with Digitone

Actually i could see the notes are being recorded, i can see the steps ‘red’ in the step sequencer, but they won’t play when i hit the play button…

Make sure the track is not muted, even if the track is muted you can still play the keyboard live but the recorded sequence will be muted until you unmute.


Ohh my bad, that’s was the case… Sorry for my noobness :joy:


np, its the only way to learn the machine!


I’m having issues sending program changes from the Octa to Digitone.

Currently i have the Octa as master and both Digitone and Rytm as slave. I program patterns in Digi / Rytm to match the patterns programmed in Octa ; for instance, A4 in Octa would trigger A4 both in Rytm and Digi. So in arrange mode, i have A3 and after, A4.

In Octa’s arrange mode, this works fine with the Rytm. But with Digitone, somehow the program change is being accepted by Digitone ‘delayed’, it will change to A4 after some seconds only. Then the pattern A4 is played by Digitone out of sync.

Is there any configuration i should try on the Digitone to fix that ? If it’s working in Rytm, as far as i know should work on the Digi too right ?

1 Like

file a bug report. all u can do.

they said it was fixed in a recent update but with my emxperiments its not. for some users it seems to work though…

Oh man that’s what i’m afraid of… I was hopping it could be some wrong configuration :frowning:

It could be wrong configuration, I use the digitone and octatrack and don’t have this problem. Make sure your Pattern Length and Pattern Scale match on both machines as this is often where trouble starts.

1 Like

have you tried with advanced patten lenght… the mode where the patterns have different lenghts? for me that is where it stops working. of course ch. len is set to 16 steps.

Well this is weird, but after i turned off all my gear and turned it on again a few hours later, now the program changes are working correctly… Don’t know what happened, i will observe the next days to see if the problem is really fixed. Thank you guys !

1 Like

It works if pattern length and scale are all the same, but not with different pattern lengths, at least not consistently. So that narrows down the issue.
I just keep everything the same, no advanced pattern.

Yes, they are the same, the problem happens only in Digitone, not in Rytm Mk2. Now it happened again, i turned off and on, and worked again… Confused what is causing the issue.

I discovered something new. When the problem happens, actually i don’t need to reboot the Digitone ; if i just stop the Octa and press Stop on the Digitone twice, when i play the Octa again, the Digitone will play correctly. It seems when i press Stop only on the Octa, somehow although the Digi also stops, when i press Play again on Octa, the Digi will start playing out of sync ; i need to press Stop on the Digi twice and press play on the Octa again…

Confusing :stuck_out_tongue:

are you sure youre sending and receiving transport and clock?

for me this problem is also totally random. it worked somethimes, for a short period of time (even with advanced pattern), then again not. whithout me changing any settings in between. usually it doesnt work though.

Was thinking about sequencing the DN with the OT in order to get the MIDI arp and per track timing. I’d love to map the CC controls on the OT to the parameters on the DN for plocking on the OT. Is there a way to get he DN to send it’s synth parameters back to the OT? For example, on the DN, if I set the AB HARM to 20, can I get that knob location sent to the OT so that I can also edit on there? Basically, can the 2 machines talk to each other and stay in sync with the knob motions?

To do this you’d have to configure the DN to a “local off” state meaning the DN’s knobs won’t directly change its internal state but rather send out MIDI instead which hits the OT and then in turn is sent back to DN. This is done by setting the encoder and or other destinations on DN to “ext” instead of “int” or “int+ext”. With midi tracks activated on the OT for the DN’s tracks MIDI channels, when you turn a knob on the DN what will happen is the DN will send MIDI to the OT to update whatever knobs are mapped, and the OT will echo back the data in realtime to then actually change the parameters on the DN… When you turn a knob on the OT it will still control the DN’s knobs as well.

That’s the concept anyway, done this with my Little Phatty and it works fine. DN is more complex though with more going on, don’t have time to brainstorm potential issues but wanted to share the “local off” concept…


I set the DN up the way you suggested. DN is set to int+ext. DN is set for T1 to channel 11 and the OT MIDI track 1 is set to 11. I have the I/O hooked up. The OT can control the DN fine, but DN changes aren’t being mapped back to the OT.

With this type of setup you’d want DN encoder dest set to “ext”. The idea is when you turn a knob on DN it sends the control change to OT so it can register and adjust any mapped knobs and the OT sends it directly back to DN to actually control it. The OT sort of sits in the middle of any parameter changes so that OT knows what’s happening and immediately sends it to DN so that the actual parameter on DN changes, all fast enough that you don’t really notice. “Int+Ext” in this situation would be messy as when you turn a DN knob it will directly change the parameter and well as send it to the OT which bounces it back to DN, basically doubling the signal sent to DN to control a parameter.

To me it seems like your DN wasn’t sending CC’s or at least not to the MIDI out or possibly on the auto channel instead of track channel. Hopefully just some settings to change on DN…

In DN MDI/PORT CONFIG menu you’ll need:
-“OUTPUT TO” set to either MIDI or MIDI+USB
-“OUTPUT CH” set to track channel
-“RECEIVE CC/NRPN” enabled

At least for now I’d also make sure the OT and DN autochannels aren’t the same as the channel(s) being used. There are some configs that could use them but especially to begin/verify working it’s more straight forward to just have the DN track channels match the OT midi channels. Also make sure no OT audio tracks are set to the same channel(s) as if so the audio track will block the midi track from receiving data. Probably make sure no DN midi track channels are set to the same as well.

When you turn a knob that is mapped to whatever DN parameter the DN value should change as is working for you, all it’s doing is sending a CC to the DN and the parameter changes… When you turn a knob on DN it should send midi data to OT where as long as a midi track is set up on the same channel it should echo the data back to DN so the parameter changes. DN knobs that send CC’s that aren’t mapped to any OT midi knobs should just bounce right through OT to change the DN parameter, if a knob is mapped on the OT you should see the value change on the OT knob.

Hopefully it was one of those DN settings that was wrong for you. With those settings it should work.


Hey all, first time posting, so a quick thanks to this this forum for being so useful for an Elektron newbie! I’ve managed to find answers to all of my questions browsing this forum (and the manuals ofc.!), but a couple of things have me stumped a little, so I’ll try and keep it [as] brief [as i can].

Currently running Octatrack and Digitone (latest OSes).

First Thing - Using the Sequencer on the Digitone, Sync and Transport Slaved to OT

Sending clock and transport to Digitone from Octatrack over MIDI, DN set up to receive clock and sync. (Channels for this set to 12 since I read somewhere that Auto isn’t the best).

DN goes back into a Thru machine on the OT.

  1. I find that when I hit play, often the first midi note on the DN sequence doesn’t play. Anyone know why this might be?
  2. When I hit [STOP] on the Octatrack, the Digitone does stop, it pauses. (This means that when I change banks or patterns on the OT, they don’t change on the DN unless I hit stop on the DN too, is this normal?)
  3. When changing patterns on the OT whilst playing, the Digitone doesn’t change patterns at the same time, i.e. there’s always a delay. (I’ve read a lot on this, kept pattern lengths the same etc., but there’s always at least 2 steps delay, or it doesn’t change at all, I’m really stuck with this)

Second Thing - Using OT midi sequencer to DN

So I gave up on the DN being a reliable slave to the OT, and decided to just use it’s sound engine.

  1. I’m playing long(er) midi notes, so the p-lock when I’ve played it in is note length INF - fine fine, so I added a trig to play the same note at velocity 0, expecting this to stop the note when I change the pattern, but it doesn’t. So then I tried the same with LEN at 0. I also tried this on the first note of the next pattern, but that didn’t help either, the last INF note I sent to the DN is held, like, forever! What is this behaviour?

  2. I noticed also that when I have the arpeggiator enabled, if I play a note in chromatic mode (on the OT, sending midi to the DN), the arp holds indefinitely, like I have a sustain pedal or something. I checked all the settings on the THRU machine and there’s no FX or anything that should hold it like that. This doesn’t stop unless I hit double STOP on the DN; playing or stopping the OT doesn’t kill this midi note.

End of nonesense

So, thanks for reading, and thanks for any ideas there might be for what I’m missing here. I know the OT is a complex machine (the DN less so but still quirky), and I’m getting to grips with it, but this seems like it should be a straightforward thing and I’m missing something important. I did also try this stuff with 2 x midi cable between the two for turbo midi, but nothing changed, I dunno if turbo is just for sysex stuff.