USB + Receiving SysEx data via MIDI don't work


A few days ago I noticed that my (recently bought) Digitone doesn’t show up as a USB device anymore - it doesn’t show up at all. There’s no USB connection sound in Windows and no output on Linux in the kernel log or with the lsusb command. I also tried using different cables, which didn’t change anything. As there is exactly nothing happening, it almost seems like a hardware issue.
I also tried wiggling around the USB connector a bit to exclude a cold solder joint or something like that, but that also doesn’t help.
Also, there is no change if I use the USB MIDI or Overbridge mode - the Digitone also doesn’t show up in the Overbridge Engine.

I then wondered and tried doing the thing I wanted to do - copying sounds from my computer to the Digitone via SysEx, that is - via MIDI. This also doesn’t work, but the problem is a bit more refined here.
Receiving MIDI signals like CC, clock information, note information and program changes works fine. Sending the same stuff out of the MIDI out port also works fine. But with SysEx messages, it gets interesting: Receiving doesn’t work, sending does.
When I go ahead and send a sound bank or pattern via a SysEx dump to my MIDI out port, I can see the data stream in a MIDI monitor and, because of that, I can of course save that dump to my computer.
When I want to receive a SysEx dump, there is no reaction from the Digitone at all. From a MIDI monitor, I can clearly see that the data gets sent out - but the Digitone isn’t actually doing something with the data, it just seems like it discards it or something like that. If I go to the “receive anything” mode, the counters don’t rise. And yes, of course I’ve set the “Input from” setting to “MIDI” or “MIDI + USB”.

I then tried to do a factory reset, which didn’t help. After that, I tried reinstalling the current Firmware, 1.21, onto the Digitone again. It was already on it after I bought it, but I thought I could give that a try. Of course I couldn’t use USB, so I had to send the data stream via MIDI - which worked! It’s slow, who would’ve guessed, but the Digitone received every last bit and then reflashed itself. Which… didn’t change anything.

Also, another problem, which is probably unrelated and a bug, if I send SysEx dumps via c6 onto my MIDI interface, it’s instantly done and only sends out a frame / packet or two - even with the 1.2 MB firmware, which is simply not possible to send that fast over a MIDI connection. When sending via MIDI-OX or vice-versa, it surely takes it’s time, but it works.

So, in conclusion:

  • USB connection doesn’t work at all, Digitone doesn’t show up on computers
  • Sending basic MIDI and SysEx works fine
  • Receiving basic MIDI works fine
  • Receiving a firmware update via SysEx over MIDI works fine
  • Receiving a SysEx dump of patterns or sound does not work

I’m having the feel that I’ve got a hardware problem and I have to get my Digitone replaced - which isn’t a problem with my dealer - but it’s still annoying as I love the Digitone in every other aspect.