Updated to 1.40 and lost all project sounds (FIXED WITH 1.40A UPDATE)

Today I finally found the time for updating the A4mk1 to 1.40.
Wanted to revisit some old projects and found that in most (not all) of them my sounds are reset to init sounds. So they are all unusable. All the sound design gone.
I always save the sounds per project.
This feels really sad. Demos since 2014… Sure I probably should have made backups of the sysex, but I’ve gone through many updates and this never happened.

No idea, why this happened :frowning: . Any help appreciated


Ah I hope you can find some way to fix it dude! I need to back up my DT as well.


That sucks! Hope you get it fixed. I need to backup my DN and MD soon, this always scares me.

1 Like

hope this doesn’t happen to more people.
The update was successful. I already played with the new features before I recognized the loss

Sorry to hear about this, I seem to recall a similar post. However, what exactly is initialised, is it sounds within kits or sound pool sounds that have vanished. Are you sure you saved kits before saving those projects. Are the kits gone or maybe the pattern has lost connection to the kits. Had you been hopping between projects successfully before which are now bust ? Once this is clear then it ought to be reported , especially if confirmed

Thanks for commenting

I rarely use kits. I sometimes save my sounds into a soundbank but not necessarily every sound. Usually I create a sound, make a sequence with it and save the projects.
The sounds and pattern are saved within the project. You don‘t have to save it to a kit. At least it always worked with just saving the program.
I relistened to these projects many times for the last few years. And it still worked after several updates until today.

These sounds were not in the soundpool. The drum sounds I had in the pool and that I soundlocked on different steps seem to be still there

:frowning: Sorry bro. Hope it gets worked out.

Did you try Reload + sound?

Forgive me for still being puzzled, but sounds don’t exist in projects. Not in isolation. Only in pool slots. Otherwise sounds are kinda inextricably in kits. If you don’t use kits actively and save them then when a project is saved a kit will be lost. Sounds are in the plus drive or pools per project or kits. Each pattern points to a kit number. There needs to be a bunch of explicitly saved kits to point to, these contain evidence of sounds, but the sounds are not saved as sounds, just a part of a kit. Yet you have been using projects happily, are we on the same page in terms of structure.

1 Like

ok I haven‘t used the A4 for a while but I‘m pretty sure that if you start from a empty kit (you just don’t touch the kit at all) and initialised sound and then edit the init sound (change some parameters) and then just simply save the project, the edited sound will be recalled when you reload the project.

no need to save into a kit, no need to save into plus drive.
It‘s saved with the project.
I‘m pretty sure I always worked this way.

Have to go to bed now. I have a look tomorrow if I‘m completely mistaken.

But I never worried about kits and didn‘t save all my sounds to the plus drive. I‘m sure. And the projects worked all the time

Thanks for the help

1 Like

If true then it is puzzling you have got by, unless there was only one kit per project. The active project has a saved state and a working state, within this there are various levels of temporary and saved. Patterns get written when you jump to a new one but kits can survive that. But a kit that is not deliberately saved will not be covered by a project save. I think there is one scratch project. So it still confused me that you were okay before as it seems you shouldn’t have been.

1 Like

Sorry for you.

I have the impression that some of my previous projects patterns have kind of initialized sounds, hence no more interesting. Not sure if I saved them properly, or used banks I deleted.
Some are apparently as they should, maybe my favourites I saved properly. Not sure.

It would be interesting to know more…

1 Like

I guess you meant default saw wave…

So is it a sound init or kit init problem? (or both)

I rarely save sounds, unless I want them in the soundpool for Multimap. Now I have the impression that I saved the kits of the OK patterns. Can’t check now.

1 Like

Damn, that sucks…
I just follow this guide and never had problems.


So I tried it again I confirm what I wrote above…

that’s the case. I know I have to save the kit if I change to another kit within a project but I rarely do that. Most of the time one kit, one pattern per project. I save the project. For the next song I user another project.

I only save sounds if I think I could use them as presets in other songs. But usually I start from scratch every time.

Yes the default saw wave. Listening to all you melodies with basic saws is a terrible experience…
I have the feeling that all kits reloaded with the update.
Since I never saved the default kit, all sounds defaulted to saw waves.

Ok so I will save the single kit in future.
But the main question is. Why did this happen with an update? And why did this never happen with all the other updates since late 2014?
I always had the latest OS installed.

The new features feel like a weak consolation at the moment…

Anyway. Time to make new tunes I guess.
Can’t imagine that there is a way to go back to an earlier save state in the machine.

Yes. thanks. Only simple saw waves everywhere :persevere:
(which makes a lot of sense here, where the kit was not saved)

possibly because those didn’t incorporate such fundamental changes to the pattern/kit architecture - now e.g. they support Tempo per pattern, this is a fundamental change, the new OS may have to force a re-read and that’s where your not having saved a kit comes into play - it’s no consolation or comfort to know that this is possibly a case of having lucked out before, but the kits do need to be saved within a project before the project is saved, that’s why I wondered if you were rocking single kits (which would have been imho the only conceivable scenario whereby what you described would have made any sense) - Your patterns are loading Kit 1 now (which is an unsaved Kit with default sounds, but it’s the Kit that’s at the heart of this, not the sounds), it’s as simple as that. There is a temporary working state to some aspects of the workflow, you were able to wing this due to your workflow, but if you had ventured towards two patterns using different Kits(sounds) you’d have known much sooner that this wouldn’t work out.

This is a common pitfall amongst other folk assuming kits are saved when a project is, but that’s not what happens, this is down to the fluid way that Kits can straddle patterns seamlessly when edited live. It’s a good system, but needs understanding.

Even saving/exporting your projects would not have helped you here (you really should be doing this for every OSupdate due to the chance of bricking it e.g.) and that’s because if the Kit wasn’t explicitly saved you would simply be saving the default version of that Kit within the project and at that moment the working version of the project would be lost.

This issue would only affect those using your particular workflow who had been unwittingly exploiting the single working kit buffer

I don’t wish to sound like there’s an element of victim blaming here (nothing would hurt me more than losing sounds that I have designed - and that’s why I methodically back those up off the +Drive) but imho there’s nothing fundamentally amiss with the update itself - it’s been unique circumstances (and luck) which have allowed this to work out for you so far - it seems likely that the Elektron devs would know that this reset would occur, but they wouldn’t be expecting anybody to be working solely with unsaved Kits

Of course, some of this analysis could be incorrect, but I just wanted to try to rationalise what has actually caused this crappy outcome for you so that you can be better armed for the future

I’m resolved to better understand some of the little nuances of the ‘working’ buffers


I did and I knew how this works. For my liveset I used several patterns with several kits.
But I didn’t know I have to save the kit if I don’t need different patterns with different kits (which I didn’t have to so far obviously)

it did work out for five years. Even if it’s not common workflow, I couldn’t know that a new update would change that. Especially after going through many major updates without problems.

Anyway thanks for the analysis. I know better now.
I will also use different kits for different patterns more often now since bpm per pattern is possible now. Before I simply rarely needed it.

1 Like

i often encountered the same issue before the update. still haven’t figured what exactly causes that.
just by going through old banks/patterns it turns out that half of them plays on init sounds ¯\_(ツ)_/¯

i just gave up and prefer recording to audio everything i reckon worth it

Your are right of course

Sorry this happened to you. I’m surprised that there aren’t more users reporting this – you surely aren’t the only one not having saved kits, yet having updated.

If unsaved kits revert to default sounds, this obviously should be noted in the update notes :confused:

1 Like