Unable to upgrade Digitone OS using Elektron Transfer

I just bought a new Digitone and can’t upgrade the OS using Elektron Transfer version 1.0.0 for Mac (High Sierra).

With Digitone set in OS Upgrade mode:

  • Selecting Digitone on menu for midi input Transfer says “Couldn’t Connect”
  • Selecting for midi output says “Connection Failed”, after 10 or so seconds

I did all manner of troubleshooting with no luck , but when using Snoise (free 3rd party sysex software) the Digitone received the upgrade no problem.

Am I missing something here, or might Transfer be the problem in this scenario?


1 Like

Don’t think the transfer software is meant for the Digitone at the moment. I had to use C6 for the first OS update.

1 Like

Thanks, seems you’re right. The manual recommends using Transfer but I notice now that only C6 is on the Digitone downloads page.

1 Like

Hi Mr B.,
I’ve been following this for a while, as I had the same problem, but with a PC performing the upgrade.
I found the following works:

  1. Don’t use MIDI USB to upgrade - MIDI-OX, Elektron C6 and Elektron Transfer all failed to connect to my Digitone.
  2. Use a USB to MIDI adapter. I’ll post the link to mine below, but just in case it gets shredded, search for “otraki midi usb” on Amazon. Mine cost £16.99 (April 2020) and worked, after weeks of changing USB ports, cables, software, even PCs, all in vain.
  3. Once you’ve got one of those cables, switch off your Digitone. Hold down the blue FUNC key, and whilst still holding it down, switch your Digitone back on.
  4. Select OS Upgrade (option 4) and you will see the “OS Upgrade Waiting…” screen on the Digitone.
  5. Fire up c6 from the Elektron site. Mine was v1.51 (April 2020).
  6. Click on the Configure button.
  7. In the “MIDI Out” section, click on USB MIDI Interface. Nothing else.
  8. Click on OK.
  9. Click on the Load button.
  10. Select the “Digitone_and_Digitone_Keys_OS1.21.syx” sysex upgrade file for Digitone OS 1.21
  11. Click on Send. You should immediately see the file being transferred at the bottom of the c6 screen, as the green bar progresses and the “Sent” counter rapidly increments.
  12. Wait, and watch the Digitone screen. After a few minutes you should see the progress bar move.
  13. Wait until the upgrade’s finished.
  14. If it doesn’t do it automatically, switch off the Digitone, then back on, and note the OS version in the bottom right corner of the screen as it starts. It should be version 1.21

This was the only solution that worked for me after a huge amount of faffing and swapping out, and the only one where my PC could actually see the Digitone.
All worked well and I now have a functioning, working Digitone with OS V1.21 :slight_smile:
Link to Amazon UK’s site with the lead I used (see search description above if this link gets automatically removed ):

Many thanks to fellow helpful poster, Polite_Society, for putting me on the right track to make this work, hugely appreciated :slight_smile:

Admin: Apologies, this has popped up the preview to the Amazon link. If this is objectionable to you, please can you remove just the link from my post (or remove just the preview, if that’s possible?), as I think this is useful information for numerous people who’ve been battling with Digitone upgrades. I’m not glued to this cable, sure others work too, but wanted to flag it as a working solution that’s not too expensive.
Many thanks ! :slight_smile: