Unable to transfer patterns into Digitone with Sysex

Hi all, I got my Digitone few weeks ago and wanted to import some sounds and patterns that I downloaded online. They mostly come in Sysex format.

I’m using Mac OS Monterrey 12.3.1 in the MacBook Pro (2019, 16-inch).

I have read the Digitone manual a few times on how to transfer sounds and patterns that I downloaded online into my Digitone; it says to use Elektron’s C6 despite the fact it’s not compatible with the newest Mac OS.

I tried using Elektron Transfer, but in the spot where it says “drop files here” I can only drop .dnsnd or .dnprj files here. It just won’t let me drop .syx files.

I also tried Sysex Librarian. I followed the instructions in the Digitone manual about Sysex Receive. It successfully imported the sounds, but not the patterns. Digitone said that it has successfully imported the patterns into Pattern A01-H16, despite the fact that the pattern pack I got contains 12 patterns only, and when I checked, Patterns A01-H16 are still empty.

What should I do now if I want to transfer patterns into my Digitone?

by the way… the Digitone manual says to “use the Elektron TM-1 USB MIDI interface” but it’s discontinued already… the manual was last updated this year in March. will Elektron actually update their software or manual?

I’ve noticed too that this particular screen only works for OS Updates and not for sound / pattern .syx files.

However, if you press the < Digitone 1.32A button in the top left corner and go back to this screen and press go to the SYSEX TRANSFER page:

Then you see the following screen:

Now on your Digitone, go to Settings -> Sysex Dump -> Sysex Receive and choose what you want to receive (Pattern or Sound).

Now press Send in the Transfer app and it should work now.

(And please report to Elektron, as this can be considered a bug)

1 Like

yeah I tried that, still can’t see the pattern. I’ve even tried using an audio interface with MIDI ports on it, still not working. I’ll report that to Elektron as well.

Hmm sounds like something could be wrong with the pattern .syx files you try to import.

Maybe they are made with an older version of the os or something.

Did you try with one you exported yourself?

Okay I’ve just tried exporting my project as a sysex file and then importing via Sysex Librarian. it works! it successfully imported the patterns. so yeah I supposed the sysex file I got was made with an older OS.

I bought the sysex file in question here

1 Like

I’d contact Auvrel for this as it seems like the sysex made with the older OS are not importable with the current os version 1.32A.

Already reported this to Auvrel, he rightfully responded that this is a problem for Elektron, since this is clearly a bug. Report it in the bug section and hope they will fix it.

1 Like

I just figured out that with the following screen in Transfer, .syx files do work if you select more than one:

Hi maerteijn,
I’m having the same problem.
Did you succeed to see and play newly imported patterns?

I can transfer .syx files by multiple file drag and drop as you said, but after the transfer finished I can’t see any imported pattern at all.

Hi @reggirt

I just tried this on my DN. I exported a pattern (and recorded this with Sysex Librarian on my Mac), created a new project and sent the patterns with both the “Dropzone” and the “Sysex transfer page” to the new project. Both methods do work fine.

However, I needed to use the “Record One” functionality of Sysex Librarian so the pattern exported as a Sysex message is exactly one message, and not more. (I think the DN also sends clock messages as Sysex, I should disable the clock when exporting patterns).

Anyhow, I think that the .syx files of the patterns should contain pattern data only for this to work.

Thanks for replying @maerteijn,

Sorry but I can’t import the patterns correctly yet…
Actually I had purchased Auvrel’s preset pack as you did.

After I read your message I did this:
(* I’m a windows user so I use MIDI-OX to transfer SysEx messages)

  1. Send the entire preset SysEx messages to the Digitone’s new project
  2. Exported a pattern SysEx and saved that message as .syx file, one by one
  3. Send the individual pattern .syx file to Digitone

I can see Digitone says “Received pattern A01” but I can’t see a imported pattern on A01.
What’s my misunderstanding?

Thanks in advance!

@reggirt Can you share a .syx file from a pattern you made here? (I think you can attach it to a post). Then I can try to import it on my DN.

@maerteijn
Thank you for your kind words!
Here is my exported pattern file.
A01.syx (23.4 KB)

Hi @reggirt

It looks like your pattern.syx is ok: It’s just one message and it has the right size. But I think the pattern is really empty. Try to export a self created pattern and import that in a new project and see if that works.

Here is a simple pattern I just recorded for you to test with:

A01 lost.syx (23.4 KB)

Thanks @maerteijn, I succeeded to load your pattern on my DN.

And now I noticed that I may have been misunderstanding the situation…
I thought that you have successfully imported Auvrel’s patterns with Elektron Transfer. But it was just my assumption, right?
It seems that we have to wait for Elektron to fix the pattern file compatibility issue between latest and older OS.

I didn’t load the patterns from Auvrel indeed :slight_smile:

But now at least we are sure what the problem is: The older .syx files can’t be imported on newer firmwares, and it has nothing to do with your DN or the Transfer software.

1 Like

Thank you very much for clarifying!
And sorry for bothering you ;D

That worked for me! Thanks!

Hi @KelvinT,

Finally it seems Auvrel’s patterns can be imported into DN on new OS 1.40 !
Much thanks to Elektron guys :smiling_face_with_three_hearts: