Syncing the Digitakt with the Roland SE-02 sequencer

I’ve seen a couple of topics related to this subject, but I’m still figuring out how to do this apparently simple thing.

I want the sequencer of my Roland SE-02 to be triggered by my Digitakt via MIDI.
I’ve looked into the syc/clock settings of the SE-02, but still can’t manage to get the SE-02 internal sequencer running when hitting play at the Digitakt.

So I was wondering if there is someone who also owns both these devices and knows how to set them up for this purpose.

1 Like

I don’t own either device, but try this:

Use a working MIDI cable to connect the Digitakt’s MIDI Out port to the SE-02’s MIDI In port.

In the DT’s Settings menu:

In the MIDI CONFIG > SYNC menu, activate CLOCK SEND.

In the MIDI CONFIG > PORT CONFIG menu, set OUT PORT FUNC to be “MIDI”, and set OUTPUT TO to be “MIDI”.

On the SE-02:
In SEQ SETUP, set Sync to be “MIDI In”. Save the pattern.

1 Like

also make sure roland is receiving on the MIDI Channel the dt is sending.

MIDI channel allocation is not necessary for clock and transport.

well, you’re completely right.

nothing more to say, thanks for correcting me.

1 Like

It works!!
Thanks PeterHanes!

There is one other thing that I’m wondering.
I still have seven MIDI tracks left on the Digitakt.
It seems I cannot set up the other MIDI tracks with different patches from the SE-02. I guess I need a multi timbral synth for this purpose? Or should this work with the SE-02 as well by any chance?

1 Like

Yes.

No.

2 Likes

I thought so, Thanks.

One other thing I noticed: it seems I can’t mute the MIDI tracks while playing. What setting am I missing?

brevity is the heart of levity.

1 Like

Are you still synchronizing the SE-02 sequencer to the OT’s sequencer, or are you now using a different arrangement of your gear?

Just the same arrangement of the gear: So the SE-02 sequencer being triggerd by the DT

In this situation, the MIDI sequencer tracks of the Digitakt are not sequencing the SE-02, so muting the MIDI tracks will make no difference.

What is your audio path for the sound from the SE-02? To mute the SE-02’s sound, you need to do something in the audio path. For example, you can control the level of the SE-02’s output from the MIDI track of the Digitakt.

The audio out from the SE-02 is connected to the L+R stereo input of the Digitakt. (Then the Output from my DT goes into my mixer) Could this be the problem? I can control the volume of the SE-02, but in a live situation it would be ideal to be able to mute/unmute an SE-02 sequence on the selected DT MIDI track.

Another option would be to start/stop the sequence direct from the SE-02 I guess, but I would prefer to be able to do it via the DT’s track mute.

The best way to achieve what you are asking for is to program the notes that you want the SE-02 to play into the DT’s MIDI track instead of into the SE-02’s sequencer.

Yes, that’s a way to achieve it.
I’m still figuring out the best way to perform a live set with these devices, where I can change pre programmed sequences on the fly to make track transitions. But maybe I will get there by programming and saving sequences on the Digitakt. I only got my SE-02 recently, so I still have to experiment a lot with the interaction between the DT and SE-02.

Anyway, thanks for directing me in the right way!

1 Like

I’m facing another problem now with the internal Digitakt sequencer.
Sometimes sounds (no matter if they’re audio samples or MIDI patches) are not played back after entering/recording notes in the step sequencer. I can play the sounds through the chromatic mode, so the sounds themselves shouldn’t be the problem.

What could go wrong here?

Do you have the tracks muted?
Pressing the trig and playing in chromatic mode will still work normally with tracks muted but the sequencer will not sound

1 Like

A unnoticed track mute might have been the problem.
Yesterday I had no problem playing back any sound on the DT.
Thank you!