STROM for iPad


hey so first of all, these connection problems and issues with the pattern generator over wifi are gonna be fixed in the next few days.

Basically my code is not modularized very well and I’ve been working on a new feature for SDS Drop which broke everything and which I got stuck on, so I couldn’t release an update for a while lol… but it’s all done now! Just a bit of testing needs to be done… :sweat_smile:

@dave_angel yeah sounds like some stability/lag issues somewhere in the chain… probably all the issues you were seeing are likely caused by the same thing. May also help to reboot Mac and iPad in my experience!

but yeah most things should be much better with the next update… stay tuned!
also, I’m gonna try and add a thing to the FN /control all feature so that you can hold down any unused performance macro on the Rytm, instead of the FN button in Strom. Can’t guarantee it for the upcoming update, but yeah… good idea with a MIDI input for this, and if it gets a signal from Rytm directly, there’s no need for an external controller :slight_smile:


@void That’s great news!!! I was really worried OB & Strom wouldn’t be able to be used together reliably so very pleased to hear the wifi connection problems, and pattern generation is to be fixed :slight_smile:

I did try rebooting Mac, iPad, Strom, SDS & Ableton but no luck - I’ll wait and see if your fix helps with it, was working fine the other day so hopefully it was just a one off day of bad luck.

With regards to the FN/Control All - ok great!! However I’ve found a workaround that works for me - if you just glance at the iPad so that you can press FN accurately; once it’s held down you don’t have to keep your finger exactly on the FN button on the iPad - so doesn’t require checking you are still holding the screen in the right place for it to remain active :slight_smile:


note you can tap the FN button with 2 fingers to lock it - tap with one finger to release :+1:


@void Great!! Thanks for letting me know!


Hello all!

Recently when tried to use STROM i realised that after some usage the RYTM stops responding to any change or data coming from STROM, must reboot the STROM to make it responsive again but after few tweeks stops responding again…(randomizer / pattern generator whatever i tried.
And when its working it has a lot of delay/lag (for example changes in the kit appear in RYTM some seconds after)

Both RYTM, iPad and STROM are updated so cant figure out the problem


hmm that’s pretty slow… have you tried rebooting your iPad? I’ve had MIDI acting up on mine, and could fix with a reboot.


exactly the same as re booting the iPad, fixes the problem temporarily :slight_smile:


which model iPad are you using?
and which USB adapter? Original Apple or knockoff? The one with lightning charge port (aka the one which came out last year) or the smaller one?


its the iPad 4 with original usb adapter, the small one!
I also tried midi+usb, usb only in the RYTM receive menu, same problem in both :frowning:


dunno what’s causing that… will try and reproduce, but not sure how :thinking:


Same problem here, I’m getting big delays sending kit/patterns changes followed by “not responding” messages after having the app open for a while. Think it only happens after using the pattern generator but not sure. I’m using iPad Air 2 with lightning cable routed through Studiomux.


Hello! Ijust bought a rytm and would like to use strom. Do i need any other kind of cable or just the basic lightning to usb one that i use to connect the ipad to the mac?


That’s the one champ!


you need the apple camera adaptor:

Don’t get a cheap alternative as they can be unreliable


Which is this one here:

Alternatively, you can get SDS drop for Mac and use Strom wirelessly


You use that Lightning to USB adapter with the Rytm’s USB cable, not the lightning charger cable as there’s no way to connect it to the Rytm.

SDS Drop wireless connection sounds like the easiest option by far, but alternatively you can just connect your iPad and Rytm to the Mac with the cables you have and route the midi through midimux (free on app store). Bit annoying to set up every time but it’s free and you can use Overbridge and Strom at the same time.


Ooops yes, sorry, pasted the wrong link!


Oh, I hadn’t thought about that option - have to try it later as Strom does not play nicely with Overbridge when using wireless (at least for me).


Yeah try it out, works pretty well. Latest version of Studiomux broke something so using Midimux for now. You don’t need to route anything in the app, just have the app and server open in the background.

The only thing you should do is disable all the midi ports you’re not using in Midimux, as all the ports show up in Strom as “unknown manufacturer” so need to try lots of combos in the midi settings until you find the right pair.


Just imported most of my sample library to Audioshare and finally started playing with the sampler side of Strom. So cool being able to open any sample from the file browser and send it straight to the Rytm.

Tonight I’ve been exporting some loops from Samplr (favourite app ever) to Strom and sending all the parts to different pads on the Rytm to sequence them. Sounds so good running through the FX, distortion and compressor :heart_eyes: Big up @void, amazing app.