Sample Exceed Avail Memory - Bug?


#1

Hey guys, I’m having a bit of an issue with my Digitakt related to loading longer samples.
The situation is as follows:

  • I load loop A to track 1
  • I load loop B to track 2
  • I attempt to load loop C to track 1 via the REPLACE option, and receive the message “Sample exceed avail memory - Continue Y/N”
  • when checking the sample list it only contains two samples (OFF and loop B)
  • the storage info shows me only two samples are loaded with 43% memory free

Unloading samples has the same effect, they don’t appear in the sample list nor in the memory, but they somehow seem to still reside in the RAM.

Is this a known issue? Your help is much appreciated!


#2

Have you tried unloading samples, saving the project and then reloading it?. I have noticed that samples remain in the project ram list once removed but are gone next time I load the project.


#3

You are correct - unloading only seems to remove samples from the list, but not from the memory. Only loading a project clears the memory. That definitely looks like a bug to me, no?


#4

Its certainly an annoyance but its probably a side effect of the super usefull copy/paste/reload structure and its mutiple save states so I could understand that it may not be a simple task to seperate the two.


#5

I don’t own a DT, but on the RYTM you have the same behavior :frowning:

If you load samples and fill up the RAM, then select ALL and unload, you won’t be able to add anything until you reboot the machine.


#6

Ran into this last night on the DT. Unloaded all samples, tried to load more, hit the error. Had to power-cycle. Unloading from RAM should clear ram, not just the list if I’m understanding correctly. Possibly a bug, or there may be a good, non-obvious, reason for this behavior?