Rytm won't respond to MIDI data on Auto channel in Overbridge mode

I’m trying to get around the Overbridge latency issue to record some live playing into a DAW.

I track in stereo, then I switch to Overbridge with a multi-out to lay down the audio from this MIDI on separate tracks.

I prefer recording with the Auto channel because it shows up in piano roll in a “standard” way – one drum per key. I can record this through Logic’s External Instrument plugin:


Unfortunately the Rytm doesn’t output audio for my recorded notes through the Overbridge plugin.

If I set it up to send MIDI on all the tracks and use TRK CH, I get output in Overbridge mode, but unfortunately this has the effect of recording every note on C-1 but in separate MIDI channels. It’s all but useless for editing the MIDI because it’s just a single-note stream of data with each track on a separate channel:

Is there any way (short of writing a Scripter plugin to route Auto channel notes to their correctly-channeled C-1 note) I can get the Overbridge plugin to respond to notes I recorded on the auto channel?

A Logic Scripter script to translate incoming auto-channel notes on Ch14 (the default) to individual track channels on note C-1 (Midi 36) follows (this works as a workaround, but isn’t ideal):

  Rytm translate auto-channel defaults into Note/C1
  channel equivalents (works only with default track
  channel settings)

function HandleMIDI(event)
  const CHANNEL_AUTO = 14;
  const NOTE_C1 = 36;
  	(event instanceof NoteOn || event instanceof NoteOff) &&
    event.channel == CHANNEL_AUTO	
    event.channel = event.pitch + 1;
    event.pitch = NOTE_C1;