RYTM recieves aftertouch , also if recieve CC/NPRN is set to NO


#1

I had controlled an external synth from Octatrack MIDI sequencer, and the slave was on channel 4. Where the clap on the RYTM is. I did set the RYTM to not receive note messages in midi port config. Also all CC /NRPN are disabled.

I tryed to use the aftertouch controller from a Octatrack midi track, and found that the clap on the RYTM gets more pronounced i.e. he listens still to standard midi messages.


#2

A workaround would be to remove any AT modulation destinations in each track’s sound under Sound -> Sound Settings -> Aftertouch


#3

Thanks, i did search in global /pattern /kit - but not under sound ! That helps.


#4

I’d imagine the CC/NRPN receive setting only applies to stuff outside of note number/velocity/aftertouch?


#5

Aftertouch is a separate kind of channel-wide MIDI message than either Note or CC’s… so I guess neither of those settings filters it out.


#6

I’m currently struggling to figure out the CC value for sending aftertouch modulations to the Rytm. Would anyone care to aid/ enlighten me? The manual is only showing values on the trig page (ie. note/ velocity/ length, etc)


#7

Aftertouch is not a CC, it is its own unique midi message. You’d need a device capable of sending aftertouch, or a processor to remap a cc to aftertouch… Usually it is sent from a keyboard or pad midi controler according to pressure being applied after the key/pad has been struck, and while it is being held down or sustained. OT has a specific knob for aftertouch on its midi tracks, I use that as a fixed/steady mod depth unrelated to pressure…


#8

Oh ok, duly noted. (not sure why I hadn’t realized that.)

I’m using Max and touchout, but it still doesn’t seem to be working for whatever reason. I couldn’t tell you why as I’ve made sure to enable all track channels on the channels page.

More specifically, I’ve got [touchout x 1] to send AT values to port X and channel 1 (should be the BD track on the Rytm), but I’m still getting nothing.


#9

Is your OUTPUT CH setting on the Rytm set to TRK CH?


#10

Sorry for the delay.

It is. Should it be to Auto?


#11

Nah, it should be TRK CH…are you sure Max is correctly sending the AT? Are you in Max For Live or the real Max? I would test to make sure other synths / software / MIDI monitor can see the AT first, then deal with the Rytm.


#12

Hmm. I only have a Rytm (mk2) and A4 (mk2). To clarify, I’m struggling to send and receive track specific CC data as well, but I do have performance macros sending/ receiving on both machines.

I’m on Max 8.0.2.

EDIT/ RE: Midi Monitor – I’ve tried monitoring the incoming data from the Rytm with it to no avail. I haven’t tried with Max.


#13

To send and receive CC’s you need:

OUTPUT TO: USB or MIDI depending on how you are connected
OUTPUT CH: TRK CH
RECEIVE CC / NRPN: ON
PARAM OUTPUT: CC
ENCODER DEST: INT + EXT

If MIDI Monitor does not see a CC coming from the RYTM when you change Filter Frequency, for example, then something is wrong.

You also need to assign AfterTouch to Parameters + Amounts under Sound Settings, else nothing will happen


#14

Alright, so for whatever reason the Rytm’s aftertouch values are only recognized as poly pressure [polyin] in Max, but simply using the same values using [polyout] doesn’t work to apply modulation to the aftertouch meter on the “modulation setup AT” page.

I hooked up an LFO to sweep through values while skimming through all values on channel 1, but still nothing. [touchout] doesn’t work either.


#15

With control all principle, I wanted to use aftertouch for all tracks. So yes, it seems poly aftertouch, hence related to note number, so I can’t use it for all tracks with the same channel, as it would be possible with channel aftertouch.