Roland SP-404 Mk2

Works fine here. Have you updated the firmware? Can you take a photo of your settings?

It works fine for me as well. Maybe there are interférences, as in, floor noise in the inputs?

1 Like

Thanks for that clear answer! :slight_smile:

I’m happy about that because the fatty ones aren’t so tall. So, there is no friction at the base of the knobs with the chassis right?

Did you also replace the encoder?

Nope, just swapped the knobs themselves. No friction, very smooth. They’re just a bit taller than the stock knobs.

See below: left/black knob is stock, white are fatty chromas

6 Likes

Fatty Chroma Caps have and will continue to be the best replacements on the market. I have a drawer full of them due to a past obsession with these devices. :smiley:

8 Likes

Ah even the fatty are taller. OK, not by much, I’ll live with it.

I ordered some, a bit of color. Ordered more for my MB33, time for customization :blush:

By the way, living in Germany, I found that it’s cheaper to order from DJ TECHTOOLS directly, including 9 euros for shipping, than buying locally.

1 Like

I texted DJ Tech Tools, and they instructed me. They also said that the encoder knob is not replaceable with their product.

1 Like

Great thanks. I didn’t order an encoder luckily. Just fatty knobs.

1 Like

I live in the UK and have often spent the large shipping charge to get these knobs delivered from the US as nobody in the UK stocks all the colours. :confused:

My shipping was less than 9 euros, and knobs were 1,95 euros vs 3,10 here.

I disconnected the inputs and it still doesn’t work, just records right away.

Firmware is up to date. I’ve tried every setting from 1-10. Still records right away, doesn’t wait for input.

Weird. Two things I can think about is, wrong count-in setting (happens to all of us) or the level for auto-trig set too low in the settings?

1 Like

Oh so I just messed with the count-in setting, put it to “Count-In Wait” and now it seems to work. I never had to do that before on the 404SX. Thanks!!!

3 Likes

Ah great! I thought “wait” was the default. If you press SHIFT and the corresponding pad (I don’t know how you got to the setting), it cycles through the choices. Pretty easy!

Cool. Yeah. That’s the one.

does anyone know how to reload the factory content (demo songs) that i deleted the first day, but now want back… lol

Woof… this was some serious work to get the guide updated to 0.10. Update available at the usual link NearTao’s Guide to the SP404-mk2 – NearTao's Blog

I got a bit obsessive over the last few days, and read just about every single post in the Elektronauts' SP-404 mk2 thread as well as the Gearspace SP-404 mk2 thread. This is well over 4000 posts to read through, and took me the better part of four or five days to complete. Lot's of good questions, and lots of good answers, but I'm not sure I am up for doing a repeat of that any time soon.

All of this reading has resulted in a lot of really good questions for the mk2 (around twelve pages worth), and I have as much as possible been adding in answers either from forum members or just doing my own research. I would have gotten this out last night, but I figured it was worth spending the time to better organize the questions.

13 Likes

To restore to factory defaults with project 1 populated with samples and patterns:

SHIFT+PAD13 (UTILITY) -> FACTORY -> ALL DATA

Your firmware version will stay at whatever is installed. Please note, this will wipe out any other samples and projects you have on your mk2. So you may need to back that up first if you want to save anything.

3 Likes

Added this to the FAQ section of my guide, answer posted above :smiley:

1 Like