Right Click Not working

I am trying to organize my samples on my digitakt using the transfer app. The manual shows options when you right click a folder or file in the Explore tab of the transfer app but I am not getting anything when I right click. Anyone else having this issue? I’m using a mac running OSX Yosemite.

Hi—I’m having a similar issue with Transfer not recognizing right-click in OS X.
I’m using a model:samples w/ 1.12 OS update and Transfer 1.2.2.9
I’ve tried it on my desktop running 10.14.6 and my laptop running 10.13.6, neither will recognize a right-click (ctrl-click).
I also tried downloading an older version of Transfer (1.1) and still no luck. Any suggestions?

What about command click?

Unfortunately no difference—I tried cmd-click/option-cmd-click/ctrl-option-click/etc and no luck with any of them.

I recommend filing a ticket with Elektron.se support

Well, I dug out an old PC mouse with an actual right-side button and that seems to work just fine. Tried the mac mouse and no dice. Very weird.

Check your Mac setup, system prefs,

You might have had secondary click disabled on the Apple mouse.

I’ll double check, but right-click works fine in every other app. It’s also odd that it wasn’t working on two separate macs running different OSs. Happy to have found a workaround regardless.

1 Like

Don’t get me wrong I love Transfer at this point, I just wish it had an edit/rename feature. I loaded samples excitedly when I was still learning the M:S and didn’t know the workflow and I would love to be able to change the names for more clarity. Minor thing, but still.

It does. Via right click.

(using OS 1.12, with Transfer 1.2.2.9, connected via included micro usb cable)

:eyes::eyes::eyes:
Thank you. I’ll double check to make sure I have the latest update!

So I had everything updated, but my mousepad’s right click feature was not recognized in Transfer - it still worked elsewhere on my computer. I had to plug in a mouse to make it work. Confusing. Thanks for the help.

1 Like

Strange. What OS are you running?

I am using Mojave with an Apple Magic Mouse.

I’ve heard of another user with the issue you report (no right click in Transfer, until they hooked up wired mouse). So this might be a good thing to report to Elektron.se support with a ticket.

10.15.4 Catalina. I’ll definitely report that.

and I’ll check on my MBP 16" that is running Catalina as well.

1 Like

Working fine here on 10.15.4 with Magic Mouse 2

@bpgrand89 Are you certain that secondary click is enabled in System Prefs?(wired 2 button mice override this, I believe)

2 Likes

A neat tool that could help is Karabiner. You can map key combos to all kinds of stuff including a right mouse click.

It’s unfortunate the track pad is not working out however. I wonder if it’s calling a different API.

I’ll try it out tonight or tomorrow but I am still on Mojave (10.14.6)

I was having an issue on Catalina with track pad drag and drop(not in transfer though) and found if I go into more gestures and enable 3 finger drag everything works as it should. Not sure if that’ll help you out but it’s with a try.