Record length changing "randomly"

I hope someone here can enlighten me. I’ll just say quick that I’m a noob on octatrack but quite tech savvie and have delved deep already, however I’m having this oddness occur and it’s doing my head in…

I have 4x Pickup machines, two set to 32 steps record length and two set to 64 steps. other tracks are flex and master, slicing up the buffers recorded on 1-4. I’ll be jamming away looping various bits on different tracks on perhaps a couple of tracks, then the next track i loop onto ignores the length I have set (either 32 or 64 steps) and will loop over something ridiculous like 256 steps or 512, which is a coincidental amount of steps given multiples etc of 16. All my tracks are setup the same so I’m pulling hairs out figuring out why this is as I’d like it to loop how I have set it. This is for Live performance so quite important to solve.

In REC SETUP 1, isn’t your recording RLEN set to MAX?
With MAX, without QREC, recording time can be 1,2,3,4,5,6,7,8,16,32,64,128,256,512,1024…

It should work as intended with 32 or 64 steps values.

Did you set REC SETUP 2 > QREC, QPLAY ?
Set to PLEN or 16, 32…it is useful to keep sequencer tempo.

all pattern lengths are the same for each track too

RLEN set to the amount of steps I want to record (ie, 32 and 64 on different tracks), QREC and QPLAY are both off so I can punch in overdubs without waiting. The odd thing is that sometimes it does what “it says on the tin”, sometimes it doesn’t. It’s usually track 3 that goes wierd but I’m not sure if that’s coincidence as that’s usually the last track I add things to

Check SRC/PLAYBACK page LEN (x1).

Forgive me for my noobism, how do I access SRC/PLAYBACK on Mk1? You think this might be my issue? Also, what am I looking out for? Thanks for the tips by the way!

LEN the loop length multiplier. It shouldbe set to x1.
PLAYBACK* page is the 1st of the 5 parameter pages under the screen.
Pretty sure that’s your issue.


Cheers, I’ll check that out when I get home.

One other thought I had just now, which may/maynot be possible, is that track 7 (Flex) shares the recorder buffer of track 3 (pickup). As they are both using the same buffer, could it be possible that the recorder setup of track 7 could interfere with track 3, which it should “slave” to? Ie, conflicting setups? I’ve not looked but perhaps that could be possible, or are elektron cleverer than missing that?


Another possibility, I don’t think that’s you did but good to know :
Pressing MIDI button or TRACK+MIDI can multiply the recorded loop.

Once a loop has been recorded it can be doubled by either pressing [MIDI] while in the RECORDING SETUP menus, or by pressing [TRACK] + [MIDI] at any time. Note that this operation makes a copy of the loop at that specific moment, so it is recommended not to do this while overdubbing.

These shortcuts are great, though occassionally when operating a little kack handed, things are pressed that we know not. Is expected with something so immense though. PS, I think I’m on the same page as you regards LEN, all are set to x1, I’ve also tried them as off and got the same results. I’ll have a good play this eve, hopefully I can get to the bottom of it and make my set a bit more reliable/sturdy, which is why I sacked off Ableton and bought this beauty

Check if LEN is not plocked to scenes. You can mute / disable scenes with Fn + Scene button.

If you don’t find, New Project! It works with default settings.

OK, thanks for your help, I took it all on board and had a play last night. Problem solved! After having a good look around I saw that out of the 4 pickup machines, one of them (the one giving me problems) had length turned on. From my current understanding, the length parameter allows octatrack to change tempo based on the loop you create, and multiples (X1,X2, X3 etc) are either double, triple, the original loop.

As the machine is already running when I create loops, I think there’s a bit of a “glitch” that tries to do some sort of tempo sync, but as the machine is already on, it goes a bit bonkers.

I found this in another thread, and was very similar in the way I was getting different lengths when making loops;

> " 2: Tempo recalc on the other hand takes the next coming value on a 16/32/64/128/256/512 etc grid as a reference.
**> **
> Example: with master track =64, a PU recording stop action at step 135 will stop recording at step 192 and tempo will be recalculated as if the recording was 256 steps long as shown in the video I posted above (mind this: it will not choose 128 which is closer to 135 than 256!!).
**> **
> In other words, if we want quantized PU recordings, of an undefined lenght, that do not change the tempo, we only have the choice of 64/128/256/512 etc amount of steps but we need to initiate a stop action during the last master track cycle . (BTW Track scale doesn’t matter, only Master Track scale does).
**> **
> For master track =64:
> target=64: action stop anywhere will do
> target=128: action stop between 64 and 128
> target=256: action stop between 192 and 256
> target=512: action stop between 448 and 512
> target=1024: action stop between 960 and 1024
**> **
> Hence, a fully quantized Pickup recording of 96, 192 or 320 beats is not possible.
**> **
> This is not a bug, but I qualify this as a design flaw: we have two different reference grids, AND a weird rounding choice has been made."

Thanks for jumping on this though, this is a super beast to get into so great that it has a brilliant community that are keen on helping each other out!


1 Like


1 Like

and I hang my head in shame… Must have been a long night!

1 Like

No shame. Not a very obvious / noticeable error. :slight_smile:

Hmmm, well I set everything up again last night and was having exactly the same problem. Unfortunately it seems the odd recording lengths are random, though I have an incling as to why, though I don’t know how to solve this. (Yes I’ve had my head in the manual for at least an hour!)

I’m aware that pickup machines can be slave or master, and this is indicated by a dot next to the P symbol. The dot is towards the bottom of the P, indicating it is slave. The weird thing is that I have no idea how to remove it. I’ve tried creating a new project from scratch and putting pickups on different tracks, in different orders (ie track 3 first, track 1 first, etc). Everytime without fail, track three becomes slave and non of the others do. I think this means that my pickup machine on track 3 will adjust to the track, hence the odd lengths. Maybe there is a hidden menu somewhere that I am missing? Turning “LEN” off or on makes no difference.

The main thing that is different is that when I create fresh loops on any other the other tracks, the record counter increases on the right hand side (starts at —/--- and increases to i.e 032/032, to the set length). But when I activate recording on track 3, the length in predeterminned as 256 or 512, like this, —/512, meaning it will record all that time, even if I set the record length in the setup.

Sorry if thats a mouthful but I want to try and make it clear what is going on.

Hopefully someone can help?

So track 3 is set to LEN=x1?
Check if LEN is not plocked to a scene, by pressing scenes.

Did you reseted track 3 length by stopping the Pickup?

Yes I’ve done all that, and I also make sure I “clear slot” on all machines in case there is some strange data confusing things. I’ve even re-created my layout in a fresh project and the same thing happens. Changing LEN does not change things in terms of this issue, and it’s always track 3 that goes bonkers. I’d thought the other day that LEN was the issue, now I’ve no idea.

If I start my track by recording to track 3 first, it behaves ok and counters up the way it should, (and other tracks do not produce this “error”.) I’d rather know what is going on so I can avoid problems when performing Live, as if I come to record a 64 step loop and now have to improvise 512 steps before it loops, thats a bit crap.

Hey, thanks for your input by the way!

Note the wee dot on pickup 3 and also the counter that says 007. ( took the pic just at the right moment). When a loop creates from scratch and works, the 007 part increases until it reaches the length i set ( then loops). When it glitches, the 007 side of it stays at 512 whilst the left hand side counts up. This is the strangeness in action

ps, yes I’m aware I’ve track 4 selected here but you get the idea