Prophet... new vs. used


#21

I know this, but it will not do any harm whatsoever!

I would only recommend to do this in first week to make sure all the voice cards are good and calibration completes. If there is a problem card then calibration will hang.


#22

thanks for the tips!


#23

Split the difference and get a non-buggy Rev-2 8v and one or two AS-1’s.


#24

What’s the known bugs for the Rev 2? Is it only some Rev 2 that have these bugs or is these bugs present on every Rev 2?


#25

That was more to do with early firmware, but I have to admit I returned my first one (one of the first batch) due to two mechanically defective pots. If you get a 2nd hand Rev2 be sure to check it’s firmware is the current one, and ask the seller about values jumping when knobs aren’t being touched (look for a jittery value randomly appears in the display). Also, step through each voice (8/16) for each wave type and if any are off, run the calibration. If large variations in pitch or volume are still there, update the firmware and test again; otherwise don’t buy. Note, OSC1 does bleed a little even when off, it’s normal, but it’s way low.

My new one has been fault free, and perfect since the firmware updates, mid 2018. One of the best synths I’ve ever owned.
And the Rev2 is Not a menu diving synth. Just isn’t. It has more mod options, that’s all.


#26

DSI support have written to me for both the Prophet-6 and Rev2 on over calibration. It’s true that we can go too far by doing it too often and it becomes detrimental. That’s why they sometimes recommend erasing the calibration table and starting again.

The trick to calibration the Rev2 is to let it warm up for a normal time, then switch it off for half a minute. Switch on and run the calibration within a minute, and it’ll work. Weird but works.


#27

Thanks so much for all your feedback and info! This is really valuable. Really appreciated.


#28

Still sticking to my thoughts about calibration. Spent quite some time going back and forth between DSI support in San Fran’ Calibration when done (at reasonable intervals) sometimes hung on a number ‘L4’ for instance.Turned out that indeed the resonant filter part of voice card 4 had failed. Low pass Resonance had no affect on voice 4 when cycling through notes. All other cards were fine.
It was not until i realised that resonance was not functioning on single voice that the failing calibration forced me to delve deeper(until then i thought it was perhaps a strange firmware glitch or something)

Ever since the card was replaced, calibration worked fine. And more importantly every voice worked as intended including all filter.

DSI reliably informed me that occasionaly (but still rarely) voice cards might fail, or have a problem. Indeed this is what happened in my case.

Not once did DSI say to me anything about over calibration. And in my case encouraged me to re run calibration many times in quite a short time frame.

Re-seating cards was also part of the instructed fault finding from DSI, but in my case did not solve (only new card did)

Just a heads up to test any (especially analogue) synth you get very, very carefully in all aspects during first week or during return window.


#29

Sorry if I sounded disagreeable. I reread the emails and what they meant was that the calibration table that we fill on one firmware version, may not agree with the newer firmware and continuous calibration won’t improve the tuning because it’s mixing the old and new values. So, they instructed me to wipe the calibration table and start again (as you mentioned) by doing it often for the first week and in any new environment.

That method I mentioned above wasn’t from DSI, but from another keyboardist. My calibration would often stall, but the method has worked every time since so I thought it was worth mentioning.


#30

if anybody cares, i bought mine brand new and it came with the Sequential branding, latest firmware, and as far as i can tell 100% bug free. i’ve yet to play with every feature, but yeah. there’s that. thanks for everybody’s thoughts! VERY VERY happy with this instrument. sooooo much fun.


#31

I bought a used Prophet 6 from Ebay lately and had a bad experience. 4 buttons would not work and it did very strange things while operating once every while.
I wrote support and got the answer below. I did it as suggested and thankfully it works normal now.

Email from Sequential:

"The issues you described will like be resolved after reseating the ribbon cable which runs between the front panel and main PC board. The process to do so is easy and requires no more than a screwdriver to perform.

The instructions are as follows:

  1. Unscrew and remove the 4 screws on each wood end. Remove the 2 screws that were hidden by the wood ends on each side of the module along with 4 screws along the back lip of the synth.
  2. Place a piece of soft material behind the Prophet (bubblewrap, towel, blanket, etc…).
  3. Lift the front panel off of the Prophet and rest it face down on the soft material.
  4. You will see a flat wide ribbon cable running between the panel board and the main board. The ribbon cable connector has locking tabs on either side. Release the cable by pressing outward and down on both tabs simultaneously.
  5. Disconnect both sides of the ribbon cable and then reseat the cable in the connector. Press down on the center of the ribbon cable until the locking tabs click into place.
  6. Reassemble the Prophet in the reverse order of disassembly.

Once you have reseated the ribbon cable, please check whether the synth begins to operate as expected again."


#32

Had my Prophet 6 for near 3 years… no faults or bugs ever. Care and maintenance?

I’ve pressed the calibration buttons a few times when the weathers changed or I’ve moved house.

Things built like a tank.


#33

Sequential told me the following why this can happen:

“There is nothing more to check in this regard, the problems you noted were due to the ribbon cable not being well seated. We do see this occasionally and specifically with instruments that have been shipped or used on the road. I would say that nothing else is physically wrong with the synth.”


#34

I had the same with my Rytm

Opened up a disconnected/reconnected the ribbon… happens with euro modules too.


#35

Interesting. In all my 15 years of trading I have never had something similar with anything.