Problem: Pickup Machines Individual Length?

I’d like to record individual length per track w pickup machines but I have some trouble with it.

when I create a new project > select pickup machine > set one2 as record mode and RLEN to max > length in track menu is set to off

the recording is quantized in a strange way. like very short ones are calculated to 16 steps and everything above is adjusted to 32.

there is no other recording, sequence or whatever going on.

so how can I make use of the pickup machine in a creative way to have indivdual length per track??

thanks

so when I have pickup machine assigned to a track (with one2), hit AB to start recording and want to stop at step 11 with CD (to stop), the track is automatically stretched to 16 steps.

where can I turn off this behavior and let it record in a free mode per track?

no one?

help, I wanna jam

Best is to make a master loop first, with fixed RLEN. Use QREC is you want to match sequencer’s tempo.

After you can have different lenghts with other Pickups.
Check QREC and QPLAY settings (for quantize, in REC SETUP 2).

Recorders + FLEX machines are more flexible, but they have other caveats.

1 Like

thank you for stepping in here.

I get your idea but I am not sure if that’s the solution. what I want to do is to use the ot as a looper only, so there is no sequence involved at all. I just want to loop on the fly.

but even my first recorded loop on track 1 on a new project is adjusted to a specific length (8 or 16 or 32 or 64) instead of being exactly the length that I choose by stopping the loop (hit CD).

RLEN is set to MAX, QREC and QPLAY both are set to off for all pickup machines on the 8 tracks.

this is very confusing and disappointing. I mean the approach might be a helpful feature but I’d like to see it as an option, not as the default state.

any other idea? can others redo the scenario and confirm the behavior?

So I made some tests again, being used to record multiples of 16.
So yes, multiples of 16 is Pickups référence fir the first loop. Doesn’t seem a problem with 1 track, or if you use multiples of that length on other tracks. without syncing to the sequencer, your loops can be 11x16th even if 16 is written.

The problem is if you don’t use multiples on other tracks, the sound is timestreched! :scream:
I forgot that catastrophic behavior you can’t disable.

To sum up : use multiples, or use Recorders + FLEX, or buy a real looper allowing different lengths (RC505 for instance).

2 Likes

Second that. One you get past the initial hacky feel of doing it it makes the OT a better looper.

1 Like

Yep. With REC/FLEX, possible to overdub, to disable timestretch, add plocks, no tempo change…

As Pickups came after an update, they should be the hack, no ? :content:
OT coming from MD UW, I think Rec/Flex is the normal way. But yes it feels hacky compared to a regular looper.

Main problem with REC/FLEX : starting the loop just after the end of the recording if you want different lengths.
That needs a sort of midi hack.
Doable with a midi device sending 2 messages, or adding a midi processor. Doable with midi plays free tracks and midi loopback.

Every once in a while if I’m using multiple pickup machines, after I’ve recorded a loop in the master, the next PUM I record on will record backward. The audio won’t be backward (I guess technically maybe it is, I don’t know) but the step count on the min page will run backward and the one time I checked the REC1 page the record and play indicators were moving in opposite directions. Has happened 5 or 6 times and I’m still not sure what’s causing it (and no, it’s not the direction parameter or anything like that). It doesn’t actually cause any problems so I haven’t tried to figure it out, it’s just a weird thing I’ve noticed.

Not helpful, but there it is.

1 Like

Yes. I looked for the thread on that from before… I think I found a way of hitting buttons that it was practically immediate

Okay found it:

Midi-routed would still be the pro route for sure. Hacky is good :slight_smile:

1 Like

There is a way to make your first PU loop any length you can dial into the rlen, and have subsequent PU machines be of individual lengths, without changing the tempo or timestretching.

I will get back to you on this because I don’t remember the procedure exactly and can’t check it before some time tomorrow.

1 Like

Please! Curious about it.
I couldn’t find anything reliable with PU yet, if you’re out of power of 2 numbers (1,2,4,16,32,64…steps). Tempo change or wrong timestretch…

Sorry forgot about this for a bit. Here’s a video that shows how it can be done. The caveats iirc are you need to have the sequencer running and you must specify in advance how many steps each recording will be.

3 Likes

Ok thanks but it doesn’t proove it works musically, and I don’t think that anybody doing live looping would want to set their loop previously with RLEN. And they usually want to define tempo with the first loop (not my case, I prefer to keep an existing tempo reference).

Secondly, from what I tested yesterday, with those lengths, new loops are timestretched. Doesn’t work. I’ll probably edit my post to precise/confirm caveats.

FLEX.

If it works musically or not is up to the user. I’m just showing you what I promised. They are not timestretched.

Ah ok. But quantized to PLEN? So you can’t record when you want?
Or maybe with a 2 steps pattern length…

I think you can do it unquantized but this is the way I prefer because I can “arm” the recording with one press and know it will begin on a beat and record for however many steps I told it to.

Not everything might have to be exactly like in the example. I’m just saying it’s a way.

1 Like

A way, but not the way regular loopers work, for sure. :content:

Thanks again, I’ll make some tests, maybe tonight.

Personally, I may use a Pickup to record a loop with pattern length RLEN and QREC, for overdub.
Other loops with REC/FLEX. Sending 2 notes from a midi controller : C2-G2 note (Tracks 1-8) + C4 (Combo Rec) with ONE2 mode, you can record any length, when you want. I prefer to quantize to 1 or 2 steps.

@JSZ I made some tests, so yes it doesn’t change tempo or use timestretch if you define the loop length with RLEN, using ONE, even with QREC off.

Btw I’m surprised you chose HOLD, which seem to work with QREC on, but not off.

I also set OP to GAIN instead of DUB to avoid overdub, because of the ONE mode.

Well, interesting, still not sure it will change my preference for REC/FLEX.

The reason for this is that afaik the one press solution to start and stop the recording quantized only works with hold. It’s been a long time since I settled on this method and I don’t remember why exactly.

1 Like