PolyPhase - Generative Sequencer (iOS)


Nice work so far. Here’s a quick little jam using it to drive GrooveBox on iPad. Looking forward to getting more familiar with the app:


New beta is out, delete the old app first.


Another beta is out, delete the old version.

It includes individual interfaces per Track, more scales, more chords, Master Track range limiter, a toggle to hide Track Properties, improved MIDI, improved note generation algorithms, and improved randomization functions.


I released 1.0: https://itunes.apple.com/us/app/polyphase/id1440617668?ls=1&mt=8

It might take some time to propagate to all of Apple’s servers. I will leave the Beta up until Monday. When you do install, I would delete the Beta first.


Awesome. Congrats. Bought and used here:

And here:

Love this app…thanks for creating it :pray:t3::two_hearts:


Video showing some random modulation coming from the Ribn app:


It seems the link is broke?

  • BTW I am a happy customer.


Some people have problems with streamable embedding: “https://streamable.com/oqfjc


Hmm, I was testing it and updated my iPad to iOS 12, the app no longer shows in TestFlight for some strange reason. I can’t rejoin the beta too :confused:


The Beta is over as it’s now out on the App Store: https://itunes.apple.com/us/app/polyphase/id1440617668?ls=1&mt=8


I’m planning on using this to manipulate the Model.
I’ll buy later when I have my iPad :+1:t3:


Ah, good. I thought it was due to iOS 12 haha.

Just purchased the app :sunglasses:

Ran into a little bug; when sending clock to other apps like Ruismaker the bpm is doubled. 120 becomes 240 in Ruismaker, PolyPhase bpm stays 120. Great fun but not as it should be I think :stuck_out_tongue:

Ableton Link support would also be sweet, maybe it’s in there but I haven’t found it yet.


If you are sending clock to other apps, make sure the other app isn’t generating it’s own clock. Also if you are receiving clock from other apps, make sure PolyPhase’s clock generation is OFF. Else, you will get double the clock ticks. Let me know if you fixed it. If not, which version of Ruisemaker are you using so I can buy it and test?

Link support is not available yet, I am working on other things before that. I know everyone is really wanting that feature, but I am using the MIDIBUS framework for MIDI and I am waiting to hear back from it’s developer.


I’m not sending any clock from Ruismaker. The only options in the midi config enabled are clock receive and start/stop receive. Sending clock from AUM to Ruismaker works ok.

Some other apps also get double the bpm, like Korg Wave. Some apps are not seen at all even after refreshing the devices. Like DM2 isn’t seen by the app, but DM2 sees Polyphase fine.

I might do some more testing later with more apps just wanted to let you know these issues. I guess easy to solve by not using PolyPhase to generate the clock for the time being.

Another little thing is that I’m unable to turn the welcome message off.

  1. I added an option to disable the Help Menu on startup for the next update

  2. Which version of Ruismaker? There are multiple in the AppStore

  3. I downloaded DM2 and PolyPhase lists it’s interfaces just fine…maybe hit “Refresh Interfaces” at the bottom? For DM2, because it does not have it’s own Clock Input Port, it’s listening on the “PolyPhase” port…so in PolyPhase you don’t have to select anything under “Clock Send”. I am able to send Clock and change the tempo just fine. I can’t find a place to specify which MIDI Notes trigger the DM2 pads though.


Very odd.

I have DM2 listed and selected to send clock to and in DM2 it’s showing now. This is after closing both apps and opening DM2 first. The tempo isn’t changing though. The tempo blip is moving at the correct tempo and highlighted but not doing anything. Bpm is set to 120 on PolyPhase, DM2 remains at whatever I changed it to to test.

Both Ruismaker and Ruismaker FM double the tempo. And Korg Wave and maybe others too. I wish I would’ve tested before upgrading. I had the beta installed for a week or so but decided to move to iOS 12 first.


It’s really weird. I’m pretty at home with iOS stuff and haven’t has these kind of weird issues before other then when I was testing Modstep a long time ago. If there’s anything I can do to help sort these things out let me know.

I will have time tonight to try all my apps :sweat_smile:


That looks fine, the BPM won’t update until you hit Play inside of PolyPhase.

If you hit Play in DM2, you can freely change it’s BPM as it assumes it’s using it’s internal clock.


Cheers, I will try from scratch tonight after food and some strong coffee.

Very nice app though. Already had a lot of fun messing about and with the Euclidian stuff on top to sequence some drum synths along with other synths it will be good fun.

I wonder how crazy things can get if we combine your app with something like ChordFlow or Fugue Machine :smiley:

  1. To trigger the pads in DM2 you will need to enter MIDI Learn mode and assign the output notes from PolyPhase to each Pad.

  2. Ruismaker FM is also listening to ALL Clock inputs (bad)…to use it with PolyPhase, don’t select any Clock Sends, as it already “hears” the PolyPhase clock. I am getting it to work fine like that. If you do select “Ruismaker FM MIDI” under Clock Send, you will get double ticks!

I’m going to add some text under the Help Menu that explains some of these issues


That is bad indeed, specially when the end user has no access to change the behaviour. I didn’t even know those apps listen to anything when nothing is selected. It should be save to assume nothing is happening when nothing is selected but like you said that isn’t the case.

Thanks for putting up with me :smile:

Yeah no worries about triggering notes, I was more playing around with a few stand alone apps trying to quickly sync it all up. I’m sure it will be much smoother when done from AUM or Auria or something.