Poly measure issue with master LEN/chng


#1

im trying to get poly rhythmic stuff going but im having a program change issue.
if i set the len to inf and the chng to 64 on the a4 and go to change banks on the OT(MASTER) instead of the upcoming bank being qued as usual when i select an upcoming bank on the ot it wait’s a full cycle of the ot completing its sequence before changing. for example if the ot is on 2/4 on the sequencer and i select a new bank the a4 wont change til the ot comes back to 1/4 then it will que the change but it wont happen until another full 4/4 cycles around meanwhile all my other program changes will have already happened on the rtym and ot before the a4 catches up to the change.

hope im putting this in a way that makes sense

any ideas what im doing wrong? this also applies to my rytm.

it works fine with chng OFF and len at 64 with the machines changing programs but it screws up the poly stuff by restarting the measures at 64 steps etc which i would love to avoid


#2

Chng isn’t working on AR in advanced mode and long len either…
I think it works for manual sequential change on the device, but not in chains or with external pc, maybe not in song mode either…

Please file a bug report…


Scale Menu LEN=Inf/ CHNG=64 why won't the patterns change when chained?
#4

this is a known issue, i posted about it and got no good answers. there are several threads about it. from what i have gathered, elektron is aware of it and it is a conscious design choice, inherent to how the machines handle prog change messages. the workaround is to use song mode on all machines (so that they change in sync rather than change based on prog ch messages from OT). unfortunately it makes it impossible to do a live jam and switch out of a polyrhtymic pattern in sync. a real bummer for those of us who love polyrhythms. the other potential workaround (that i havent tried) is to have the machine that is running polyrhythms be the master. but if you’re like me, you’ve got poly stuff going on on all the machines at different points.

other than that, the only solution is to plan for the one pattern’s worth of lag and play it into the jam


#5

Hardware workaround that works with OT :
With a midi processor you can send Stop+Start messages just after the PChange.
Worked with Event Processor plus, should work with RK002, Bomebox, etc…


#6

On AR you can’t use a chain with patterns using advanced mode high len, it says you can directly in the manual and you use chng, it doesn’t work as stated in the manual…


#7

wow you are right. that really REALLY sucks. it means polyrhythms are completely unusable!!! unless you stay on one pattern the entire time. not good! has anyone from elektron addressed this??


#8

It works in manual sequential change but that might be it, not with chains, not external pc, I thought it didn’t even work in song mode, but it was a while ago when I tested and need to reinvestigate to say for sure…

I’m holdin em on chains though, says right here:

Still need to file the report, I’ve had a lot of stuff going on lately…


#9

i mean chng kind of works, opposed to an inf len and chng at 0 that would never change it actually will change after 64 if chng is set there, its just the count down doesn’t start til the sequencer gets back to 1/4.:joy: if only it qued starting with the step you were on it would fix it. ill file a report. i need to try manual sequential change i guess


#10

yes it works but only if you cue a pattern. it doesn’t work at all if you chain 2 patterns together, or in song mode.

so, if you make a song, and one of the patterns has master set to INF and CHNG set to 64, the song will simply get stuck on that pattern and repeat indefinitely, and never move on.

the manual explicitly states that the CHNG parameter is meant to work with cueing AND chaining:

Capture

this is currently not functioning as described. latest version of the manual, updated March 8, 2018 i believe.