Pickup machines and auto bpm changes

is there a way to stop a newly recorded pickup machine from changing the bpm of the current set?
basically taking away it’s designation as a master track.

also, what’s with not being able to turn off time stretching for the pickup machines?
it seems weird that you can’t.

hopefully that can be fixed with the next OS update.

thanks

1 Like

One kludge would be to first record a master pickup using a simple kick or metronome pattern and RLEN set to 16, 32 or whatever. Record it from a flex machine running at your project’s BPM. Once you have a master in time, you can use slave pickup machines to record and they should lock to the project BPM since the master has set it already.

2 Likes

I had exactly the same problem a couple of days ago (new OT user here). My solution was to turn on quantize recording and playback.

Go to the recording setup 2 (FUNC + REC CD) and change the values for QREC and QPLAY. For me, the best use is PLEN. This way the recording will start and stop in sync with the tempo and, for that reason, it will not change.

2 Likes

thanks for the replies, i guess i should have explained my problem a little better…

the big thing is that i’m using the octatrack as an ambient experimentation tool so i’m not pre-programing pattern lengths or beginning with any pre-recorded material.

the octatrack’s pickup machines are perfect for creating these asynchronous loops except if i stop the loop that was the master loop and record a new one then it recalculates the BPM and time stretches everything which sounds awful and super artifacty because sometimes the calculated BPMs are wildly different than the previously calculated BPM.

the way i see it is there would be four possible solutions:

  1. find a way to turn off auto time stretching on the pickup machines (which for some reason is not an option… unlike the flex and static machines)

  2. find a way to disable the master/slave relationship between pickup machines and the automatic BPM calculations (which i haven’t found a way to do yet)

  3. never stop the master loop so that a new bpm is never recalculated.

  4. something brilliant that i have yet to discover.

any help would be greatly appreciated.

I thought I found the answer in the manual but it says that timestretching cannot be turned off for pickup machines.

I guess you could try oldgearguy’s idea of doing the sampling in a Flex machine track instead of sampling directly into the pickup machine track. You would set the SRC of the pickup machine track to the recorder buffer of the Flex machine track.

This way you can turn off timestretching and BPM setting in the Flex machine track, then the pickup machine track just loops off of the Flex machine output. Because the pickup machine is just looping the Flex machine output, it should in theory retain the same BPM of the Flex machine.

Anders Bergdahl uses this idea on some of his Soundcloud tracks. I think this is one of them:

Based on some of my recent discoveries about pickup machines, I think you could do it by pre-setting some things in the pickup machines like RLEN, and then using Recorder trigs in the pickup machines to keep the BPMs fixed.

I have some more ideas how these thigns can be better managed, but I really need to sit down in front of the OT and try a few things out. I may have more info to report tomorrow.

1 Like

thanks, i’d love to hear what you come up with.

thanks, i’d love to hear what you come up with.[/quote]
I’ve been playing with pickup machines and setting recording trigs some more. If you’re not concerned with overdubbing, you can use 1 shot trigs and HOLD Trig type to control record/playback without messing up the tempo. Any other trigger mode (one, one2) goes from recording to overdub after RLEN is recorded even though the one-shot trigger is not rearmed.
You can still use this if you take it out of overdub mode from the Pickup menu and switch it to gain. Also, if you have a very sparse/minimal source you can handle the overdubbing for a longer time before it turns into white noise. You can also force dropping out by manipulating the pitch control.
Playing with recording trigs and pickup machines, I never had it change the BPM on me.

1 Like

This is conceptually soooo true!
Thx for pointing this out so clearly…OneShotRec + Hold … :+1:
Funny that I was using (for the few times i’ve tried Pickup machine) HOLD mode, triggering recording manually…so the BPM from the Pickup master was always changing the BPM… :sob: >> :stuck_out_tongue_winking_eye:

A couple more thoughts, since I was playing around with Pickup machines this morning.

If you use record triggers with Pickup machines, remember that you can hold down the trigger and select which input(s) to use.

So, if you have an installation with an Octatrack, you could (for example) set RLEN to 64, set your pattern to 64 steps, then put a one-shot trigger on step 1 recording from AB and a one-shot trigger on step 33 recording from CD. When a one-shot trigger is hit, it disables all other one-shots on that track. This way, you can decide whether to record from AB or CD simply by rearming the track at the appropriate time. Setting them 32 steps apart gives you more than enough time to do that.

Another thing - any change to Pitch causes Pickup machines to drop out of overdub. You can use that in 2 ways – scenes (see below) or create an LFO shape that is all zero except for one step that is at max. Assign that LFO to Pitch with a very slow rate. Now you can introduce semi-random dropout by simply adjusting the depth and waiting for the LFO to kick it out with a brief pitch change.

Also - remember that Scenes work with Pickup machines. I had a grand time today simply locking Pitch and Direction to a scene and then flipping the slider around while I was playing a loop, then going back into overdub to grab some more audio and then flipping through the scene changes.

You can also use the scene change to introduce the LFO change from above.

Finally - I had a setup with one OT feeding the inputs of a second OT running a pickup machine. The Pickup OT outs were sent to a mixer. I use the pre-fade aux sends on the mixer to dump that output to a pitch shifter/delay box and brought the effected outputs back to the board. I turned down the Pickup OT outs so I only heard the effected signal. Then I messed with changing samples on the 1st OT while it was playing and going into and out of overdub on the Pickup OT and playing with the delay and pitch settings on the FX box. It’s amazing how quickly an hour can go by.

The downside to using Pickup machines is that if you don’t capture the audio while it’s happening, it’s virtually certain that you’ll never be able to exactly recreate it again. The good news is that there are an infinite supply of cool sounds to be discovered.

I’ve been playing with the “granular” project I received from Anders Bergdahl, slowly deciphering it bit by bit.

I found that as long as I started the sequencer first, it is indeed possible to loop to my heart’s content without changing the BPM -if the pickup machine was sampling with SRC set to the output of a flex machine. I think you cannot set the the pickup machine inputs to any of the analog inputs, but I could be wrong.

Thanks oldgearguy for the various tips/tricks/observations!

1 Like

When I use PUM (PickUp Machine) as a Master track, usually I sync the tempo of the sequencer with the tempo of the PUM:

press [TRACK] (of the PUM) + [TEMPO] = sync sequencer with PUM.

  • In the manual : 9.3.2 SEQUENCER TO PICKUP SYNC

Then the PUM don’t follow the BMP of the sequencer, however the sequencer follows PUM’s tempo.
And this has another effect, that the PUM will not have timestretching, because the BMP of the sequencing will be the same as the PUM and you can hear your PUM loop without timestretch, and the sequencer go to the same BMP of the loop (PUM).

:wink:

Keep in mind the OP did not want the sequencer BPM to be changed by the pickup machine. This is clearly stated in his post:

is there a way to stop a newly recorded pickup machine from changing the bpm of the current set?

I’m sure some people like having the pickup machine adjust the BPM. But it is also useful to know of a workaround if this is not desired.

3 Likes

Sometimes i think its good to follow up in a thread for others searches.

Here’s a more current answer that works for my needs:

2 Likes

Sorry, I was wrong.
If you record lengths out of 1,2,4,8,16 etc it doesn’t work. :grimacing:
I mean, concerning Pickups.

If you record 12 or 24 steps for instance, it can fuck up the tempo.

If the length is defined before without anticipated slop, no tempo change.
Sorry I don’t remember who pointed this out, wasn’t me.
Anyway, also depend on first recording.

Anyway, hopping a simple/logical Looper mode one day!

2 Likes

Are you referring to the QREC lengths?

Im using QREC at rlen and thats working aok…i didnt try a bunch of stuff though…and it was vocals…

Honestly i dont really understand what the 1,2,…256 even means (you dont have to explain it :slight_smile: :grinning:

Recording length.
Ex : With QREC set to 4 steps, if you record 12 steps it changes tempo.
Annoying.