Overbridge weird sync issue with external instrument synth in ableton

Wonder if anyone can help me out with a weird issue I’m having with Overbridge.

So using the Rtym & A4 I can record to audio perfectly in sync which is great. perfect actually.
So Recently I bought a Minilogue xd, had a play around, record to audio perfectly in sync (Great)

Now the problem begins if I have Overbridge and say the rtym open the minilogue will record the audio signal out of sync, not late but it’s coming in early. If I turn delay compensation it comes in late (but then I can’t compensate of course)

If I delete overbridge from my project the korg records in sync again.

Any ideas?
I was supposed to spend the day making music but instead I’ve been pulling my hair out over this syn issue that seems to be being caused by overbridge.

Thanks in advance

I just got the Rytm & Four and I experienced the same issues,
Finally got it sorted out, think it’s because overbridge is like a different soundcard.
and your soundcard for your synths are different.
I set the synth to -100 ms delay in midi options and have delay compensation on and reduced delay when monitoring on and it seems to be working good now,
Sending midi to the Rytm or A4 I’m setting-100 on the track and it syncs…

Just make sure to adjust delay compensation it in the options menu.
if you do it on a track it will affect the FX like delay/sidechain etc

Thank you so much think I’ve figured it out from your comment.
I didn’t think about overbridge acting like a soundcard so that is where I went wrong.

Hi Nareen, I just spent several hours trying to work this out, i had such intermittent and evolving timing issues I was about to lose my mind and pack it all in haha

I too found that while Overbridge was in the arrangement that it impacted the timing of Ableton Link and Bluetooth MIDI. Soloing against the metronome seemed to work ok, but when I hit play all hell broke loose in terms of timing. Removing Overbridge immediately resolved the issue.

So now I have just setup my RYTM as MIDI only, not ideal for me, but its working and I can adjust the timing in Preferences and it stays stable. Adjusting timing in preferences or the track with Overbridge in an arrangement was not stable for me.

Also as of last night I don’t use Ableton Link as the timing wasn’t tight enough for me and I could not adjust the midi clock unless I had an input device (in my case now, bluetooth midi). I hope things get better, easier…

I can at last make some music now.