Overbridge latency in Ableton Live

Correction. Ableton delays everything else. Not OB.

I’m fairly new to OB and I’m very dissapointed by the latency issue, especially that I’ve spent money for upgrading to Win10 and new soundcard (because the old one has no driver support for Win10) to be able to use OB2.

My use case is Ableton to record live jam separate audio tracks from Digitone and Analog FourMK1 via OB and some instruments via external audio input to the soundcard. Over 30ms of latency makes me not possible to play instruments in time, or do some finger-druming-like things or short live additions to sequences :(. I thought I could make workaround if the DAW does not have to be synced with OB, but just purely record the stream. But there is another obstacle: I can’t clock my Digitone nor A4 via MIDI if I’m in OB mode.

Is there any way to make DN and A4 syncable from other hw clock via MIDI, while audio streams of separate tracks are only streamed and then recorded in DAW?

In Ableton, turn on “Reduced Latency When Monitoring.” That should help you. Google it, and it will explain the details.

1 Like

I had it turned on.
BTW: I managed with syncing via MIDI in OB mode, when turned sync off under OB.
I still need to compensate A4 OB track by 30ms to get it in sync with audio in monitored from DAW. There has been also a moment I had to go over 60ms.
But one thing is confusing :crazy_face: When turned monitoring off on audio in track and run audio directly on mixer to the speaker, I have kick from A4 OB and kick from other gear running directly to speakers in sync :crazy_face: - I would expect the one from A4 OB even more delayed to the direct audio. Of course this is good, but confused me totally - can anyone help to understand?

I don’t know your particular set-up, but I do know that trying to “sync” Ableton or most any DAW will give you latency. The reason is that when monitoring the audio going into the DAW, there is a millisecond amount of time for the audio to go into the application, for the application to then process that audio and then the application to send it out…There is really no work around to that, besides a sync box like a ERM Multi clock, where it actually sort of mechanically, externally syncs your DAW. Actually, I’ve heard a rumor that Ableton at some point is working on audio sync.
This is my unprofessional theory. The only way I have gotten to record audio into a DAW in sync, is to just record each individual part, using the setting in my DAW which starts the sequencer just a 14ms late (midi clock offset in Bitwig), so that the recording is perfectly recorded at the BPM Bitwig recorded it’s at. But, if I wanted to play what I recorded back, it will not be in sync with my gear, only the next recording I do.

So, basically, it’s not OB, it’s science and time (And software developers not realizing how many people want something). I’ve heard great things about RME drivers. I’ve heard great things about ERM Multi Clock…But, to be honest, if you search this forum for Ableton sync, you will see 100’s of posts about this very topic, and not many conclusion’s.

1 Like
1 Like

Thanks thoughtstarZ .

I know more or less the technical background for latency in general (serial data processing in, processing out, drivers along the way, etc etc.)
I was suprised that a signal going directly from Octratrack to speakers (without passing it through DAW) is in sync with signal going from A4 via USB to DAW and then from DAW to speakers, which I’d expected to be delayed :).

BTW: there is a method to record into DAW without latency, this video explains: How to Record Without Latency in Ableton Live - YouTube so you don’t need to shift the midi when recording, or compensate after recording :slight_smile:

If ur seeing 60ms on ableton with “reduce latency” active, you need a better computer.
Also remember to set the plugin buffer size in overbridge control panel

Hi Overbridge Users! I recently started using Overbridge under Ableton 11 and everything seems to work as expected so far. There is one thing I’m trying to optimize: All audio tracks recorded via Overbridge are a tiny bit too early, i.e. I need to shift all tracks back some fraction of a millisecond. My regular audio tracks (recorded via physical audio inputs) are perfectly on beat. Can you help me, at what stage/by which function I can introduce the delay for the Overbridge tracks? Thanks! :slight_smile:

Posting to follow this thread. Same issue here. In Ableton my overbridge audio is approx 0.4 ms too early. Direct audio is spot on (using ext instrument device with hw latency adjusted). 0.4 ms is not enough to be distracting, however if anyone knows a way to delay the OB audio, I’d be interested.

I’m puzzled by the same problem:

This is what works for me:

To achieve perfect sync I have to take the latency in number of samples from my audio interface and subtract this from the the latency (number of samples) from the Overbridge plugin and the type the end result into all other tracks than where I have the Overbridge plugin.

Please report back if it works for you as well :slight_smile:

It sounds like the Ob plugin is reporting the wrong latency to ableton. This happens to me with hardware when i have plugins running that don’t properly report.

1 Like

What I‘ve tried so far: I tried the individual track delays in Ableton, however this has no effect on OB whatsoever I try.

Then I tried changing the buffer size of OB. Here I find that with 64 samples, OB tracks are a bit too late. with all other sample sizes, tracks are too early.

Latency compensation under Ableton is active, without it the OB tracks are completely off beat.

Sorry i wasn’t clear. :slight_smile: Yes, that’s what happens. But the sequencer gets the proper latency time from the OB plugin, which in turn looks for the latency of your OB devices.

I had the whole thing running perfectly with my Digitakt prior the last Overbridge update, now I have about 50-60ms latency and Digitakt lagging behind the Ableton clock :frowning:

nothing has changed in my setup, this just happened with Overbridge



Same here, unusable…


Thought I was tripping. Same for me.
Also applying track delay doesn’t solve the problem, as my digitakt goes completely out of sync occasionally.

Same issue here. Have had it working flawlessly for years and now it’s unfortunately pretty much unusable…

1 Like

I’m trying to get an understanding of the Overbridge latency situation in Ableton, hoping someone can help explain it.

Right now I have as basic a setup as possible… my Macbook Pro running Ableton Live 11.1 and my Analog Four mk2 connected to it via USB.

I have A4 Overbridge VST open in Ableton and have created 5 audio tracks running off it (T1-T4 plus FX on master) and I’m doing all the sequencing in Ableton.

When I record the OB output to a ‘clean’ audio track in Ableton, it’s showing around 31ms latency consistently. I have Delay Compensation checked.

All I want to do is be able to use other Ableton sources (drums/softsynths, etc) with the A4 and have them in time with each other.

Is this not currently possible? There’s no way to remove the OB latency?

The only real way is to NOT use the A4’s USB for audio and use its analog outputs? (so only use the OB plugin for midi control, not audio?)

What are your settings in Ableton? Do you have plugin delay compensation on for example? Also what buffer are you at?

When recording to audio do you have Ableton monitoring off or on? Also what are your settings in OB?

I had this going with my A4 but I have not recorded into the DAW yet with it, due to needing to finish a few tracks that don’t use it on. I want to dive in deeper. The sync from my MB pro to the A4 appears to be super tight though, I need to test it out. The BPM doesn’t waiver at all. Never seen anything like it, even using an ERM in the past.

In the past when I recorded into the PC I was able to get very low latency recording my AR in by taking note of all the settings I mentioned.

Also another thing - do you have any other plugins running in your project or is it blank besides OB? I got screwed a few times by having plugins open that don’t accurately report their latency to Ableton. That can be a killer.