Overbridge and midi issues


#1

Hey - maybe somebody knows something about this an can help me!

The problem is that when I try to play the A4 with a midi keyboard, whatever midi channel I use it only plays track 1. The midi channel settings are as default - channel 1: track 1, channel 2: track 2, etc, channel 8: perf, channel 9 auto. I have 5 tracks in ableton - one midi track with the overbridge VST on it and four audio tracks with each of the A4 tracks as inputs. When I play a pattern with all tracks, it works fine - I am getting audio from each track. When I play the keyboard on the A4 it also works fine and sends the right audio to the right track.

But if I set the track with overbridge on it to have the midi inputs “A-Pro - All Channels” when I change midi channels on the A-Pro the A4 will play just track 1 on every midi channel (even 10-16 which are not assigned to anything at all).

I’m using a Roland A-800 Pro and it is sending midi on all channels correctly as I’ve tested with other tracks in Ableton.

I don’t know if this is relevant but I had problems getting the OS onto the A4 using C6 - it took several goes before it recognised and sent the update. I’ve also had more general issues with sound in Overbridge - it sometimes makes a very loud noise and sometimes distorts the pattern a lot - this happens when I do not start everything up in a particular order. I have tried re-updating the OS but it made no difference. Any help or advice anyone can give would be much appreciated!


#2

try instead of having midi in to the OB track, having a separate track which controls the midi in and midi to settings (instead of setting midi in on the same track as your overbridge plugin).

have the midi in set to whatever your midi keyboard is sending, then for the output send to “elektron analog four” and channel 1 2 3 4 or 9 for example. dont send it to the “overbridge” option.

this is how i do it (in ableton)and it works great. the tracks i have:
-overbridge vst (monitor turned off so this is not heard)
-track 1 (audio from OB)
-track 2 (audio from OB)
-track 3 (audio from OB)
-track 4 (audio from OB)
-main L/R (audio from OB)
-midi track (midi keyboard in and through to "elektron analog four NOT overbridge). and in this track i just have the output channel at 9 so it plays whatever track is selected on the A4.


#3

Thanks! I’ll try this as soon as I get home


#4

Thanks a million - it worked!


#5

Is anyone else finding that everything gets glitchy as hell using auto channel via midi - I know it was recommended not to have the Elektron midi port open in Live when using overbridge, but it’s the only way to get everything working - I have all my channels set up in an instrument rack and it works pretty much perfectly except when I’m playing live via the auto channel. The glitches aren’t a deal breaker, but still an annoyance when trying to jam solos.


#6

Sorry if I resurrect such an old topic…
With overbridge beta 2 I can’t no longer see the a4 MIDI device if "overbridge mode " is selected on the machine. So, I can play just track 1 on the a4. Did I missed anything?


#7

You’d probably be better off asking this question in the OB 2.0 public beta section of the forum.