OT LFO & pattern change issue

Hello fellow Elektronauts – I’m going to do my level best to describe a very strange issue I ran into last week with my Octatrack MKII. Perhaps some of you OT wizards out there will have some ideas. First, here’s the setup:

  • OT MKII (providing tempo and transport control)
  • Digitone
  • Analog Rytm MKII
  • Analog 4 MKII

All boxes are running the latest OS’s. The AR’s and A4’s audio outputs are running in to the OT inputs A&B, C&D respectively.

I’m working on a four song EP, and have it set up so that on the OT, each Pattern (1-4) is a different song, and each Pattern is using a different Part (Pattern 1 uses Part 1, Pattern 2 uses Part 2, etc.). I’ve been working on these songs for a while without any trouble until last week. It appears that for some reason, the LFO settings for Track 5 on Pattern 1 are being transferred to the same track on Pattern 2, even though the Patterns use different Parts. Weirder still is that the LFO settings for Track 5 in Pattern 2 appear to be correct in the menu, but do not correspond with what’s being heard at all – specifically, the LFO settings show LFO 1 as a random waveform applied to the Start parameter of the sample in that track with the Trig parameter set to Trig, but what’s heard is a free-running triangle wave applied to the Pitch. ???

In the Project -> Control -> Sequencer menu, the “LFO auto change” option is checked. I’ve also noticed that changing from Pattern 3 to Pattern 2 does not cause the problem – only changing from Pattern 1 to Pattern 2 does. The workaround so far has been to reload the Part immediately after changing to Pattern 2, but that only works in this case because the arrangement of the song has Track 5’s XVOL setting off for the active Scene when I first make the switch from Pattern 1 to Pattern 2. Given this arrangement, I have a chance to reload the Part, but I’m still baffled by what’s going on, and why it only started being a problem last week.

I hope this makes sense – it’s a challenging one to explain. If I can provide any clarification let me know, and thanks in advance!

1 Like

Anybody? :smile: Here’s another fun detail: sometimes it doesn’t happen! I was playing the other night and forgot to reload Part 2, and everything was fine. Did it again last night, and I was back in unintentional pitch-mod city all over again.

When switching parts (in most cases?) a trig is required to activate the new settings for a track. So when you have different parts assigned to patterns make sure there is a trig on step 1 of each track.


This is default LFO mapping - check no scene locks, and check no incoming midi is increasing LFO depth parameter.

1 Like

I bet for this…

1 Like

Not all the tracks are used for Pattern 2, but those that are all have trigs on step 1 (including Track 5, which is where the issue is).

In my present set-up, I don’t have MIDI coming in to the OT – I have my Novation BSII plugged into the MIDI In jack, but it isn’t even turned on for this particular set of grooves. Part of what’s crazy is that the LFO parameters for Track 5 show the intended shapes, depths, and destinations, but the default LFO mapping is what’s heard.

Many thanks for the feedback!


Save project, then reload.

Yea, tried that, too – sorry, I should have included that in the original post. I made multiple attempts to save the project, save to a new project, step back through earlier iterations and resave, etc. – no dice.