OT and Launch Control XL issues (Catch Mode?)


#21

Hey Steve,

No problem.

The 1.1b3 installer from the Novation beta site is actually only for the Launch Control (not the XL) so that’s why it won’t work. If you have tried to send the 1.1b3 file to LCXL I suppose that could cause a problem although I cannot say for sure. I would recommend re-updating LCXL with the correct 1.2 updater from novationmusic.com (running this installer will also verify if the version is still at version 59 - which is correct and also working fine here).

I’ve checked out on the Bomebox MIDI router page too and I’m seeing ‘USB 1 Launch Control XL [1]’ and ‘USB Launch Control XL [2]’ in all my relevant slots but I’m not seeing LC 1,2 or USB LC etc. at all. ‘LC’ would suggest a Launch Control rather than Launch Control XL too. I maybe mistaken but I believe both the Launch Control products have a couple of USB IDs which are set-up to be; the Script templates ID (for Ableton etc), the HUI control ID and the MIDI controller ID. But the Bomebox is a very comprehensive MIDI utility so these different IDs should not have any detrimental effect. Although I have no idea about the ‘pending’ stuff… sorry.

You mentioned a different power source in your response… and say it has made a difference with the LEDs what was that difference? are the LEDs staying on now?
Another thing you could try is reseting the Bomebox back to factory default and if needed maybe updating the firmware on it too, I think you may need to contact Bomes to get that though. The Factory default routings should connect the USB MIDI to the DINs automatically.

If you are still struggling PM me and we can try to sort it that way.

Fingers Crossed!
-CALC-


#22

So I have managed to solve the problem thanks to good people on this Forum and Florian at Bome. It was indeed a power issue. Often a phone charger is not enough, It needs to be a power source of 2A at least. Problem solved. Happy Days.
Thanks heaps


#23

Hi @Calc and anyone else who can help, can you offer any advice as to whether this product from hobbytronics might supply enough power to the XL to have it work with the octatrack?
Thanks for any guidance.


#24

this probably doesn’t help you but, i believe that the faderfox boxes like the UC4 have ‘catch mode’ on their encoders/faders. you would need to double-check me though, not 100% sure. i do know that you do not need a USB host for them though which is great in and of itself!!!


#25

Thanks for the suggestion, I’m open to ideas any ideas for controlling the octatrack for a total price £160 or preferably much lower. I’ve got the launch control XL which does seem like a pretty ideal interface (PAID £80) and tried to make my own midi USB host with arduino stuff (£15 as opposed to the Kenton £80 something) which works with some gear but seemingly isn’t providing enough power to the XL. Any low cost solutions?

I’m also trying to suss out how to control amp volume on multiple tracks at once like the oktakontrol can.

Cheers in advance elektronauts x


#26

Hey Wannop,
Apologies but I can’t really vouch for these having never tried one.
I do know a few few USB host to Midi Converters can be a little fussier than others. The arduino based ones seem like a good option and I can’t imagine a particular reason why this shouldn’t be just fine… it’s a great price too.


#27

I’ve made some great progress on my Raspberry Pi + Launch Control XL. You can check it out over here:


#28

Hello there.
I’m using the LCXL with my DT. I previously had a MIDIMIX, but was attracted to the LCXL by the larger knobs, template changing (which I have yet to start work on) and the pads that can be made to toggle LED states - oh, wait, you can’t configure the LEDs from the official editor, so an integral part of the controller (for me, at least) is borked. Fun.

I’m currently in a sysex swamp trying to deal with Bome’s SendSX (which crashes) and MIDI-OX (which is ultra complex) in order to get the top row of buttons, those with the heading ‘Track Focus’, to toggle their LED lights along with the mute state (CC#94).

I can send the correct sysex to the controller to allow the LED toggle functionality by using one of the aforementioned sysex editors, but the .syx file does not open in the official LCXL editor, nor is the file stored in the controller itself. The result being that I cannot test/ use the functionality as it disappears the instant I unplug it from my PC.

Has anyone had any luck with toggling LED buttons?
Thanks in advance for any advice.


#29

Hi there,

Did you end up buying one of these?

I bought one but I’m not having any luck so far with it.

That said I tried using the LCXL via Ableton and that does not seem to be controlling any of the Octatracks setting via midi there either.

I have the latest firmware on the LCXL and I believe I have setup the templates, but maybe I have not set it up correctly regards the templates.

Anyone else experiencing the same issues?


#30

I did and had fun at home with it for a couple times but then I sold it as I didn’t find the lcxl particularly useful for my usual workflow at the time. The hobbytronics worked as far as transmitting the right data according to the octatrack/lcxl configuration I think - so yeah maybe double check the setup in the lcxl editor to check it matches the midi cc numbers in the octa manual.


#31

Sounds like a wrong channel or wrong cable, something like that.
Have you tried using the lcxl to control only ableton directly over usb?


#32

hey man, im also going to be dealing with this issue soon when my launch control xl gets here. have you made any progress in getting the lights to work on the pads? it would be super cool to have this function! im planning on using it with my digitakt and iconnectivity mio4 as a host.


#33

Hello.
Bad news I’m afraid as I have contacted both Novation and Elektron with the result being that without reprogramming the device the LCXL is attached to, it won’t be possible to get visual feedback from the pads.
Elektron said that the DT is not programmed to send out (the required) MIDI messages when muting - I guess they were only thinking about the light on their own devices; which is understandable, but a pity nonetheless.

Hope things work out for you.


#34

well that’s a bummer. thanks for leading the march on that one, I read through your line of advancement, it was a battle well fought haha. either way I think the lcxl is going to be pretty awesome with the digitakt. ive been thinking about other ways to get visual representation of muted tracks, maybe an external touch sensitive led setup that sat on top of the pads that clicked on when I pushed the pads haha. if that becomes a reality ill post my setup!


#35

Yea, despite the lack of visual feedback, it works very well.
I would say that I don’t find the template changing facility all that useful though, as it can mess up my parameters if I’m not careful.
I see it more as a live/ jam usage thing. Might even be good to get another for more twistage goodness :slight_smile:


#36

retrokit.com has an intelligent midi cable with a microprocessor, you can order it programed for the digitakt and claim you can also reprogram it to your own configuration. i am not skilled in this type of work so im not sure of the possibilities with a smart midi cable. do you think it coud be used to send the midi code for pad light on the LCXL?


#37

#38

Yea, I am aware of that cable.
It would be wrong of me to rule out any possibility that uses solutions other than the two devices, a regular MIDI USB interface and a standard MIDI cable. So it’s possible that something could be done, but from what I understand, it would only be one way - the LCXL would have to have exclusive control over the muting; things might get confusing if you also used the DT for muting purposes.
This would also go for the BOME box - it may be possible, but prohibitively expensive if this is going to be the primary reason you purchase it.

I came to the conclusion that there is just isn’t a non-custom solution to the problem for which I was willing to pay. After all, you can just about make out which tracks are muted on the DT itself (although I find the lights confusing and annoyingly inconsistent).

It’s a pity that they disabled the Pattern mute CC instead of leaving it in the OS as an option, but that’s just me venting, as is my want.


#39

Ok that makes sense, I also saw on their page it can cause communication problems with the host box when sending codes through. Way over my head to be hones haha, I just now got overbridge to work and I’m estatic! I read your discussion with bome box, I couldn’t justify paying that to make some lights togle.

The muting in DT is not bad, but the way I use muting is typically when I’m recording the track and simultaneously tweaking the knobs. Switching back and forth between those functions gets a little wild, I’d set a land speed record if I did everything on time.

Thanks for exploring the possibilities of the LCXL for us all, now we know!


#40

You’re welcome.