Octatrack OS Bug Reports

Reproduced with a new project, a bit simplier :

  • Pattern 1 with part 1, static sample 1, save part

  • Pattern 2 with part 2, static sample 1, pitch 12, save part

  • Play patt 1, tweak pitch - 12

  • Queue and play patt 2, stop

  • Patt 1, reload part 1

  • Patt 2, play : part 2 is not loaded

Not possible to reload it. Pitch shown is +12 but you can’t hear it. Seems related to part 1 reload
after a part 2 played then stopped.
Doesn’t seem to happen without stop.
Same behavior with Flex.

Very quick way :

  • Play Patt 2 (saved part 2)
  • Stop
  • Tweak Patt 1 (saved part 1)
  • Reload part 1
  • Play Patt 2 : no part 2 loading.

Never stop OT ! :grimacing:

5 Likes

Ok, so it seems to be related to part reloading. The tweaks may not affect the issue.

Would you mind to report it on support? I’ve already added my way of reproducing the issue to my support request, but more voice more noise :smiley:

Hi
Anybody come across this problem. 1.30C

I reserved all memory for track 1. I recorded about a 4 minute jam. When I went to save and assign my jam the octatrck just froze on [SAVING SAMPLE]

possible bug ??

I often save long recordings without problems.
1.30B. I use Dynamic Recorders setting.
It can be a card problem.

Spotted a quirky/buggy behavior in 1.30C mkI with pretty long living project which i use to sketch ideas and for everyday studio routines.

So i had a part in bankB wich i copy/pasted to bankC pattern1. This part featured AKWF flex waveform on channel1. When i tried to load another sample from AKWF folder and it’s subfolders sample remained the same. When i tried to load another samples from same subfolder they sounded similar spectral-wise but with different amplitudes. When i loaded samples from totally different folders everything was ok.

It was my precious studio time so i didn’t tried to reproduce this :slight_smile:

7 posts were merged into an existing topic: Changing the ‘active’ Track on an Octatrack from a MIDI controller

Sorry about my noobiness - I should of put my thread here really…

I couldn’t access a bank that I hadn’t saved the night before.
Power cycled restored the bank but I lost some triggs and changes I’d made after I last saved.

In case it helps always press stop and wait for the card light to turn steady half bright green before power down. If it is red, yellow, or full bright green blinking it means there is info to be written to the card. This happens if your maneuvering through banks and making changes without stopping…

You say after you last saved? If you haven’t made more changes your worried about you can try reload project and see what happens…

2 Likes

Hey thanks for that help @Open_Mike will be aware of that.
I assume it was since I last saved but can’t remember. I was a little freaked last night and didn’t want to reload. Couldn’t replicate my missing trigs to well any way so I’ll see what it does today and try what you said. Thanks.

1 Like

You could save the current project as new, and then go back to the other one and try reload…

1 Like

And it’s still a serious bug… no fix for about 7 months at least.

1 Like

Out of curiosity what happens if you double stop in between step 8 and step 9? After you switch to C02 but before you press play?

1 Like

Not happy to announce I found a really anoying bug : Midi tracks records CCs from the corresponding Audio track channel.
MKI, 1.30B. Please confirm.

How to reproduce it :

  • New project
  • Select Midi T1 (no channel or 9-16)
  • Live rec
  • Use a controller sending CCs between 16 and 45, on channel 1, plugged in OT midi in

It shouldn’t record, but it does. It records trigless trigs with plocks on corresponding parameters (Ex CC16 is Note), hence put a mess in the sequence.

Same for Midi T2 and channel 2, Midi T3 and channel 3, etc…(it corresponds to default Audio tracks channels).

If I change Audio tracks channels, and set corresponding channel on the controller, it will record on that channel.

Same behavior with CC DIRECT CONNECT deactivated, or Auto Channel set to off.

5 Likes

I can confirm. MK1, 1.30C.
Followed your directions: New project, Select Midi T1, Controller transmit on Ch1, using a fader sending CC16, live rec and moving the fader produces trigless trigs (green) with NOTE Plocked.

3 Likes

@sezare56 - That is a strange bug you discovered there

So at first I tried this as you described. The MIDI NOTE SETUP page was set to OFF, the Track ‘tab’ (?) on the left of the screen had an X.

But then I changed MIDI T1 and set CHAN to 3. Midi controller still transmitting Channel 1 and CC16. It still records.

1 Like

Thanks a lot for confirming!

Yes. I was using channel 9 on the midi track when I realised that. Previous post edited.

Was your Audio Track 3 channel set to Off?
Theorically a midi track can’t receive midi if its channel is the same as an Audio Track.

I was using all default settings except what I mentioned. So I’m pretty sure that means Audio T3 would be using MIDI channel 3.

1 Like

Ok thanks, now I’m thinking about the problematic situations, and how to use it as an hack! :slight_smile:

2 Likes

Tested again, even with a Midi track with the same channel as an Audio track it records in live rec, but also if you hold a trig.

So it is problematic with midi loopback if you send 16-45 CCs. @pinup57, beware of that!
Carefully use midi track 1 to control audio track 1.

2 Likes

Confirmed on 1.30D mkII as well, as you say it only seems to record if controller is set to midi ch1.

I just did the test using a blank project with default settings.

2 Likes