OB & DT firmware install/run issues

Take a look in the bottom right (maybe left) corner, when you’re switching it on, and you’ll see the os.

I just did that all it says is “c” on the left and “1.10” on the right.

And what was the os you wanted to install?

Well I’m alittle lost here sorry for being a noob. So far I’ve downloaded everything correctly. I believe the firmware update was installed properly since it says 1.10 which is the newest one on Elektrons site. However it keeps freezing on the DT. I’m getting sound into my computer but only when I open my daw which is garage band for now. For some reason when I open Overbridge it’s saying No device selected! I clicked the drop down menu but there’s no device there. Correct me if I’m wrong but can’t you play the Digitakt without having a daw open? If I only have Overbridge up shouldn’t I still here what I’m playing?

Ok I somehow got everything connected. So the DT is responding to Overbridge however I don’t hear any sound when I hit anything.

You need to download the public beta firmware from Elektronauts.


Also make sure you are on the Overbridge 2 beta.

Also make sure on the DT in USB settings it is set to Overbridge mode.

All the links and info are in that above link.

Yea I downloaded the right one it said Overbridge 2.0 public beta and I set it to Overbridge mode.

Can someone answer this, should I be hearing my Digitakt with just Overbridge up or do I need a daw also to hear it?

It unfroze? Think you should be hearing it. Tracks have samples and are not muted accidentaly? Im not seeing it now - but there are some set up things in the options menu right?

The only way I can here the DT is if I have my daw open. If I close my daw I lose all sound.

I can just open the DT plugin standalone and hear sound. Hard to say really, why u cant…

Beats me, it’s showing signal when I hit play but no music is coming out. I have everything connected right I think, I have the output of the DT connected to the inputs of my interface. And the dt usb plugged into my Mac. Unless there’s some setting that’s not enabled somewhere…

Hmm - do u want to run it like that - and do you have USB connected as well? U should try just having the USB connected and see if you hear anything then…

Is audio coming from the outputs as normal when not in overbridge mode?

Just tried switching off Overbridge mode still no sound. I also tried it with just the usb cable still no sound. Do I even need 1/4 cables, can’t I just use the usb cable? Does it support midi and audio?

Sorry, i read too fast. The above question is good start.

With ob no need for 1/4 cables. Dont switch of ob mode - run the plugin standalone with DT in Ob mode…

Usb does support midi and audio.

Was everything working as it should on the stock firmware? Audio from the main outs?

If so this is firmware issue