My T2 is not doing any sound, help!

Hi! i just got my digitone around a month ago. Since the first day I saw the same issue, but since I wasnt understanding fully the Digitone, I just did a Format and it worked again.

Today Im seeing the same issue with the Syn2. For make it partially work, Im adding some of the AMP functions like Chorus, Reberb or Delay.

So, if im adding one of those AMPS effects, the Syn2 can be heard. If not, it looks like is muted.

I did a memory format again by 2nd time, and it worked. But when I was loading the bank sounds fom Digitone, it stopped working again.

This is happening also with the Sounds from the bank sounds. The T1, T3 and T4 are working great, but the T2 is not.

Does anyone has the same problem?

Thank you.

Did you accidentally mute T2? Tried pushing FUNC + T2 a couple of times?

1 Like

Yes is global Mute ON?

this to me sounds like global audio routing is set to not send T2 audio to master, while sending it to effects.

Press cogwheel, scroll down, go into audio routing.
When you enter it - green lights on FX and Tracks indicate that they go to master out.
Red lights - they dont. So if your T2 glows red, press it to make it green.


Man, youre the master on this! thank you so much for your help!

1 Like