MPC Live & MPC X


#5258

Did you try with a few longer samples ? I think it might make the process more obvious since saving those would take longer :thinking:

EDIT: or maybe it has to do with the actions you perform ? Maybe changing program properties might change things ? Just thinking out loud here :wink:


#5259

Judging from how much time the project takes to load, I’m pretty sure saving it as a new project would take alot longer than 0.5 seconds, so I believe there is ample sample data present.

Perhaps one needs to edit the samples, by resetting sample start/end points or similar? I’ll see if I can try a few more things later on.

In the meantime, I urge anyone to try reproducing this long resaving issue on their MPCs. If the issue is not super specific to certain conditions, we might be able to catch it.


#5260

That could be a technically separate issue, which will need dealing with separately anyhow.


#5261

Could be disk specific…?


#5262

Just tried the following:

  1. Made a new project, loaded a bunch of long samples
  2. Saving the project takes a long time
  3. Turned off the MPC and turned it back on, load time of samples is quite short
  4. Edited semitone in Program Edit for each sample
  5. Saving the project is instantaneous

Samples taken from attached SSD, project saved on it too. Disk is a Vertex 450 256Go (pretty old). Tested on 2.4. @tsutek, which version are you on ? I may have to test this on 2.5 as well, since a change related to saving/loading operations was made:

Saving & Loading
• Standalone no longer crashes when loading high-memory projects

@JohntheSavage, I noticed this issue only a few times and my music making sessions are usually pretty long so it would be hard for me to pinpoint a specific cause but you seem more organized so, any ideas ? :slight_smile:


#5263

I think it’s worth mentioning what manufacturer & model of SSD everyone’s using. It’s always possible that this may be more of a problem with disks and/or their controllers. Could also be cache related.

Can’t actually remember what I put in mine though. Had one which came out of a defunct PC, but it’s still a not-too-bad Samsung or Crucial 256GB SSD.


#5264

Im on 2.5


#5265

Yes, when this first happened to me, I was working from a 32-gig SanDisk Ultra SD card (80 MB/s). Naturally, my first instinct was to blame the card, so I installed a 250-gig Samsung 860 Evo SSD. The gratuitous saving issue happens on both storage devices.

The only possible explanation I can come up with there is, perhaps it depends on which parameters have been changed…?

I started this project on 2.4 (upon purchase of my MPC) and I’m now on 2.5. This behaviour has persisted through both operating systems, despite the fact that I have saved the project anew, with fresh samples, to a different location, under a different name, etc.

The fact that you are also working from an external drive, and haven’t been able to consistently reproduce the issue, blows a theory I’ve been crafting that maybe the problem simply doesn’t occur for people using the MPC’s proprietary drive. Anyway…

I don’t know, lads, I’ve been involved in the development of a lot of new tech over the years, hunted down a thousand bugs in that time, but I’m at a loss here. All I know is, it’s very predictable behaviour on my MPC. I can reproduce the issue faithfully. That said, admittedly there are a lot of variables to consider here.

At any rate, I appreciate you guys taking this to task with me!

Cheers!


#5266

I’m not on GS, MW, or the Akai forum; but if any of you want to quote me there, or if you happen to have a direct line to Dan or whomever, feel free to copy and paste anything I’ve written here, and keep me posted. In the meantime, I will stick with the “customer service” route, and see if that yields an answer —Ahem!

Cheers!


#5267

Hey John,
Let’s check some things…Your disks are formatted in exFAT right?Are you able to try saving your project to a 3rd different external drive (USB,SD,another SSD or whatever)? and check again?3rd is the lucky charm sometimes :stuck_out_tongue_winking_eye:
Any tech specs for these samples (bit rate etc.)?
Definitely not a normal behavior to start saving the samples again…


#5268

Well, as previously stated, all the samples were recorded and saved using the MPC, so the file format (sample rate and bit depth) is of Akai’s own design, whatever that might be. If I open the files on the computer and click on properties, they simply appear as .WAV files, averaging around 1MB in size, depending on the sample (let’s say roughly 5 seconds per sample), at a specified audio “bit rate” of 1411kbps, for whatever that’s worth.

All my storage devices are indeed formatted - exFAT - and I’ve had no issues with any of them otherwise. And yes, I have also tested this using several different drives at this point. The behaviour is always the same, as described above.

For the record, my MPC has always done this, and I was suspicious of it from day one; but it wasn’t until I started noticing noise accumulating in my samples that I became concerned about it. From there, it was relatively easy to determine that the corruption was somehow a result of the saving process, because I made a separate folder containing the original samples, as I captured them, from which I could then make a direct comparison to the duplicates stored in the program and project folders. And, now that I know what I’m listening for, I can demonstrate that the samples do become more and more degraded with every save, based on how many times the program has been saved, versus how many times the project has been saved, etc. Again, I say, every time the MPC overwrites the samples, it is essentially making a copy of a copy, so the gradual degradation does make sense in that respect (theoretically). That’s not to say that it’s normal, but it is plausible.

Cheers!


#5269

I think what might be happening here is party due to the way the MPC upconverts everything to 32bit audio internally. Somehow, repeated overwrites of the samples might therefore introduce redundant bitdepth conversions, which might end up creating artifacts in the sounds beyond a certain number of reconversions… (?)


#5270

To suspect this from day one maybe indicates a hardware issue all along?I’m curious…Maybe an issue with the board when mounting external drives?
Have you tried saving to the internal storage and check if it does the same?


#5271

I don’t know, it’s not like I had a precedent to go by. I mean, I thought it was odd behaviour, sure, but I had no reason to suspect that it was a hardware fault. Now, had I heard noise in my samples from day one, that would have been another story altogether; but the overwriting issue just seemed like lazy coding to me. Perhaps naively, I figured Akai must have their reasons, and that it was otherwise of no real concern.

At any rate, no, I have not yet tried saving anything to the MPC’s internal drive. Honestly, I was hoping to avoid mixing my stuff up with Akai’s mess; especially on a drive that I can’t access directly from my computer. Maybe I’ll try saving a dummy project to the internal, just to see how it behaves… Bah!

Thanks for helping, Yorgos.

Cheers!


#5272

Unfortunately, I wouldn’t know enough about that to speculate one way or the other. If support would just get back to me… Argh! I mean, corrupt files aside, you’d think someone at Akai would, at very least, be able to confirm whether or not saving a program or project should result in the files being repeatedly overwritten like this. Like, if it’s not supposed to be happening, if it does indicate a hardware fault, then I need to get it fixed or replaced ASAP. I’ve got work to do here, damn it!

Cheers!


#5273

The best way to get Akai’s attention, AFAIK, is via gearslutz, and especially adressing xparis001 directly


#5274

Thanks, tsutek.

Honestly though, I’m not going over there. Getting involved in yet another forum, especially gearslutz, really doesn’t interest me. I have too many online conversations to track daily as it is; never mind one as long-winded and volatile as the GS thread. Besides which, if there is something wrong with my MPC, I shouldn’t have to initiate a warranty claim in a public forum. I will continue, albeit possibly in vain, to try to get a hold of Akai through proper avenues. Hell, I’ll go through the dealer or one of my other sponsors if I have to. I have my ways. :wink:

Thanks again, one and all, for attempting to help me suss this out anyway.

Cheers!


#5275

By the way, in an effort to find other examples of my MPC’s behaviour, I took to watching a few tutorial videos from “mpc head” on YouTube. There’s one video in particular, wherein he covers the basics of creating and saving a drum program. In that video, he first makes a drum program from scratch, and shows you how to save it… As expected, his MPC (a Touch in this case) visually collects all the samples and writes them to the program folder. He then proceeds to make some changes to that program and resaves it… And his MPC, just like mine, can be seen collecting all the same samples - again - and indeed overwriting them in the program folder. He does this several times throughout the video, and it happens every time. So that much is consistent with what I’ve observed here. Now, just imagine that the same thing also happens every time I save a project, provided that I’ve shutdown the MPC between saves…

Cheers!


#5276

You could also give a try at the official AKAI MPC Live forum John:


As i recall two representatives Eliza and Nick are answering questions there…


#5277

Ha!

Ya, I’ve seen their “answers” there. Maybe if I fall on desperate times here… :wink:

Cheers!