Model Samples powering on issues

I bought model samples help, but I played a little and it doesn’t turn on anymore, I can’t turn it on

Hi, this will sound a bit basic but have you double and tripled checked that the power is firmly plugged in on both ends? I can’t think of much that would make the samples just quit working like that.

Also, hold down the Main Volume button (power) for a good few seconds to see if it resets and powers up as normal.

yes, I checked everything, everything seems to be fine on both sides, but it still does not turn on, how to be (((

does not show any signs at all, the column starts to hiss when I connect the adapter, disconnect the adapter, the column stops

Hmm, hissing doesn’t sound right to me. Maybe a blown fuse? Regardless, at this point I’d raise a ticket with support at They will be able to advise what needs to be done.

1 Like

yes hiss, you know, like noise from the speaker, yes, he bounced back there until they answered

One other thing to try. Hold FUNC while powering on. This is to access the start up menu for resets, upgrades etc. P48 of the manual. Worth a shot.

I tried it without results

Okay, cool. I guess you will hear back when support is back in the office tomorrow

A dumb question…have you tried a different outlet?

of course I did

1 Like

Just covering bases.

Perhaps the psu is toast. Bad wiring.
Do you have any of the same voltage and barrel you might be able to try?

I dunno. You’ll get sorted tho :+1:t6:


and it is possible that the fuse burned out inside it?

It’s possible for a PSU to short. I got a faulty one with my modular case.

Not saying that’s THE issue. But could be.