MIDI Thru plus?


#1

I hesitate to ask this because I feel like the answer is going to be stupidly obvious (i.e. ‘No’), but I can’t find an answer by searching.

I thought it would be fun to set up MIDI sequences from two sequencers into one device.

Set up is MPC midi out>OT midi in. OT midi Thru> volca kick midi in.

The volca kick is playing the sequence as it should from the MPC so that part is all good.

Is there any way I can also add midi data (CC notes with LFOs) programmed from the OT to also go out the MIDI thru to the kick? So when the kick plays a note that sound will be modulated by MIDI data coming from the OT (rather than the MPC)?

Or will the OT midi Thru only pass on data that comes from the midi in, and if so can that be configured differently?

Thanks


#2

No, the thru is echoing IN as you said, you’d have to Midi merge post OT, or wire/combine in another way - if an OT midi track is set up on the MPC channel and has matching CC assignments (if required) it may iirc pass the matching incoming data to out even if not recording - not sure how this might work out TBH as I have a few midi merge and thru boxes, easy enough to try


#3

As Avantronica says, if you setup a midi track to the same midichannel the mpc is sending, it will pass the midi data to the volca via the midi out.
It also works with the auto channel: set a mpc midi track to the same midichannel as octatracks autochannel, you can choose which midichannel to send by selecting the corresponding miditrack.


#4

Thanks folks. I guess to implement those ideas I wil need a midi merge box to combine the two midi outs (or one out and one thru). I have a Quadra thru but that does the opposite of what I need here.
My other thought just now is to see if I can record Midi data out from the OT to a track on the MPC sequence, then play that back along with whatever is programmed on the MPC. It’s not quite what I wanted to do (not ‘live’) but close.

EDIT- I think I just understood what you both suggested doing! It does look like the MPC receives midi data from the OT whilst playing it’s own sequence. So the set up is OT midi out>mpc midi in. MPC midi out to Volca kick. I think this is working.


#5

That can work too, but my setup is mpc out to octa midi in, octa midi out to my synths (via midi splitter) that way I can use the padperform mode to play chords to the octatracks arpeggio for example.
So if your volca is midichannel 14, setup a octatack miditrack to midi channel 14 and setup a miditrack channel 14 on the mpc. Check your midicannel configuration on the octatrack to be sure there are no conflicts.


#6

Oh great! I didn’t even think to try out instead of thru, I just didn’t think that would work :confounded:. Thanks, it works just like I wanted. I guess I learned something :hugs:


#7

Hi everyone!

I’m new on here and would like some help on a similar subject - I hope it’s not been answered above and I have been too stupid to see it.

Anyway, I have a OT and DN, a Kordbot (waited 12months, delivered 2 days ago) and MB33.

Prior to the Kordbot, midi was pretty simple: DN was master, midi out to OT, which in turn sequenced MB33.

Now I want to use Kordbot to play both DN and OT, with the MB33 still sequenced from OT. I don’t have midi splitter and would like to not get one if possible.

So… I imagine that if DN is still master, with midi-out from Kordbot to DN in, and DN out to Kordbot in, I can sync Kordbot to DN to use its arps, which are very good.

Midi thru then goes to in on OT, and OT midi out goes to MB33.

Question is: will OT receive clock and transport from DN and notes from Kordbot from DN’s midi thru?

I need more midi cables so I haven’t been able to put it to test yet, but before I bought them or something else I thought I’d ask if someone else had tried something similar.

Thanks in advance, and apologies if I’m being a bit thick.


#8

The DN thru will only echo what comes in - so you’d need to investigate whether the kordbot is repeating (or can be set to i.e. RX and Tx clock/transp) the incoming clock appearing at its In port (so it won’t be direct from the DN but a clone of sorts and it may or may not suffer as a result) - as the DN is taking kordbot notes IN then this should be appearing at the thru just fine


#9

I had a weird time working through this. The set up was working fine, all devices set to midi channel 9: MPC midi out> OT midi in, OT midi out > volca, with the audio from the volca going back into input AB of the OT and into a Thru machine. The OT was using MIDI track 2 set to channel 9 (in the playback/setup menu).

However whenever I swtiched away from MIDI track 2 (either to the audio tracks or another MIDI track), I’d lose the sound. In other words, it only worked when MIDI track 2 was the active track.

Eventually, after trying everything I could think of in the MIDI-Channel menu, I turned both the Auto and track 2 channels to OFF and hey presto! The sound was coming through regardless of which track was active on the OT.

I am completely confused as to why this setting works when intuitively it seems like either/both (auto and track 2) should be set to channel 9. I guess it has to do with the difference between receiving and sending MIDI data and/or conflicts?