MIDI Plays Free tracks won't play 'Direct'

Can also confirm, Happens to me too when following your steps.

1 Like

Thanks for checking, djenzyme & musicmajus! Looks like a bug. I’m on 1.25H. Maybe the problem crept in with this update - or are you guys on earlier OS?

Been over that section in the manual many times, invisible_acropolis. It doesn’t relate to the problem, as far as I can see, because I’m trying to use direct triggering, not quantized. (I’ve been using quantized triggering as a workaround, and there’s a problem there too - but that’s for another post!)

We would like to hear about the second problem.

I noticed that the triggering is not working correctly as well, it seems to trigger after 64 steps rather than the 128 that my pattern is set to. It’s fine though because you just have to press the relevant trig AFTER 64 steps have played but I don’t think it’s meant to work like that.

I just tested the 64 / 128 steps trigging thing. It works okay for me…

That is - if i set trig quant to 128/16 and I hit the trig during the first 64 steps, I don’t hear too soon - I hear it where you’d expect - at the beginning of the next full 128 step pattern.

There could be something different in your set-up that’s causing it maybe? I tested as per my example above but with T1 set to 64/16 and the master at 128, also tried with T1 at 64/16 but running at half speed, so that it took up the full 128 steps .

;My issue with trig quantise is similar though - just at the other end of the time scales 1/16 quant doesn’t seem to work as expected - but I have to check this more thoroughly - it’s probably me

OK, so in conclusion -

the thing that is broken is trigging MIDI tracks which are set to PLAYS FREE with trig quant set to DIRECT.


Yes I’m thinking something in my settings is affecting things, I’ve had a number of different issues in the last week or two, using 64 step 1/2 scale 128 master.

On the other hand, some things are clearly bugs that I am only just picking up on.

just noticing this - does this work with the latest OS? I’m still on 1.25D

It seems to work, but depends on the play mode and quantise settings, tricky to know what’s intended behaviour and what’s perhaps not working - a more frequent user who knows how it used to work may shed more light on this

did you get ‘direct’ to work? i thought too there might be a combo with which direct works. alas, i couldn’d find one.
everything else works just as expected…
(‘direct’ - as pointed out above - only plays the first 16th step and then stops right away)


There was this thread not so long back,


Also, I’m pretty sure I read in the manual that the MIDI tracks can only be triggered while the sequencer is running, the behaviour is different to the audio tracks. Maybe it wasn’t the manual but I read it somewhere

yep ’ looks like @Clancy concluded on the same issue…
… this looks like an easy bug to fix… should there be any bug fixes ever again

1 Like

Do you know if anyone has submitted a support ticket regarding this?

No I haven’t yet submitted a ticket on this. Last few time I looked into it it seemed like I was uncovering another bug. It’s also one that’s hard to pin down and explain / elimnate my own error / misunderstanding of intended behaviour, - but it’s related so I’m going to mention it here. Please let me know if I’m missing something or if it does seem to be another bug and maybe we can get these ironed out in the next (last?) update…

So - the DIRECT setting doesn’t work on plays-free midi tracks and I resolved to try to work with a quant setting. So, I set it to 1/16 as that is the nearest I could get to DIRECT in terms of musical flexibility.

Well, I found that I could NEVER get it to start when I wanted (and yes I’m aware that won’t be when I hit the button). Always a 16th late. I figured it could be my bad timing, so I slowed the sequencer right down and had a reference track playing every 16th note at a tempo that made it very easy to be sure that I was dropping the trig in the gap between the step I wanted it to start on, and the step before.

Doesn’t work, always a 16th late.

Worse still, this appears to be the case on AUDIO tracks too! arrgh!

So it seems that trig quant 1/16 and trig quant 2/16 behave exactly the same. They both behave the way you’d expect 2/16 to. So started testing the performance using 3/16 and it seemed even less predictable, with varying steps elapsing before the plays-free track would start.

That was around the time I ran into my 3rd hardware problem in 18 months and really lost the will to investgate further. I thought of using a separate sequencer to do the trigging, while providing master clock, just to get as a more accurate test but meh… Just over 18th months with my OT and 3 hardware failures and 4 previous confirmed bugs have left me pretty jaded!!:unamused:

Any confirmation, insights (or just pointing out how I’ve misunderstood!) very welcome

1 Like

unfortunately I can confirm all of the above. never been able to clearly pin point this but seeing it written down makes a lot of sense to me. can’t comment an audio tracks though.
seems like a major flaw to me. would anyone be able to confirm this with the latest OS?

edit: would an admin or the opener care to rename/add this thread to “…won’t play ‘direct’”?

1 Like

I edited the title

I’d be surprised if this wasn’t an acknowledged / submitted issue

Maybe @Ess can clarify this or comment on the background of the issue

but it certainly doesn’t surprise me that transport has to be active

cheers @avantronica
i also opened a ticket: #13769
thanks everyone


quick update: elektron has acknowledged this as a bug. no time frame for fixing it obviously. wonder what you had working @avantronica ?.. cheers

1 Like

i think the illusion it worked was short lived when i tried the Direct option, it did play ball quantised though - i can’t recall if play mode was significant, don’t think so

1 Like

nvmd then… I was silently hoping that i was just using it wrong (I would love this to work)