MIDI Clock Slave


#1

I am confused. I can to sync my Analog 4 MK2 and Rytm MK2 to my DAW (Renoise), with Renoise being my MIDI Clock Master and Rytm being selected as the Out Device so that when I press play on Renoise, the clock travels from Renoise to Rytm to Analog 4 to Analog Heat, and the pattern on Renoise moves along properly synced, though the BPM on Rytm tends to skip around a bit. But if I set Renoise as the MIDI Clock slave, with Rytm as the In Device or Heat as the In Device, no matter what I do, when I hit play on the Rytm, the clock won’t travel to Renoise. Everything else is synced up, from the Rytm to the Analog 4 to Heat (with the Heat MIDI Sync set to send and receive), but the pattern in Renoise won’t start/stop as it should if it is a MIDI slave. Any suggestions? Is the Analog Heat confusing Renoise? This should be simple.


#2

Don’t know or use Renoise. Wild guess:

Clock is one thing, midi transport messages (start/stop etc) is another. Perhaps Renoise needs transport messages to start the sequencer? There’s settings to send/recieve transport on the Analog Four and Analog Rytm.


#4

Okay thanks.


#5

In the Renoise manual it seems it should work without midi transport messages.

http://tutorials.renoise.com/wiki/MIDI_Clock

In the Rytm midi sync, are you sure you have “send midi clock” enabled and for midi out the correct USB/midi enabled?


#6

Renoise is so very cool … even though i could not understand it, love what Renoise is capable of.

seems that after a device is chosen in preferences for time clock transport, there then appears an option in the Transport Panel, and if this is not selected, then it still won’t work…

http://tutorials.renoise.com/wiki/Preferences#MIDI_Clock_Slave


#7

When you say Rytm temp skips around…is it like .5 to 1 bpm difference constantly fluctuating? If it is…its synced, dont worry about it. Test it, set a trig on the 1/4 on both devices and check it out.
Anymore than that…probably not.


#8

Yeah I have the rytm “send MIDI enabled”, output set to midi+usb, and I can even see realtime updates through the monitor page as an input device, yet the Renoise pattern will not react when i hit play on my Rytm. It makes no sense to me.

Oh wait, I just got it work! Apparently, you have to hit the button right next to BPM so that the clock symbol is highlighted white, and then it works just fine. Weird. So the solution really was simple all along. There’s probably a life lesson in there somewhere…Thx


#9

Got it to work as explained in answer to LarsErik. Thanks though much love


#10

Okay thanks. With Renoise as the master clock, the Rytm skips around quite a bit, like over 2 bpm, sometimes more than 5, and it’s constant, changing the whole feel of a song. This confused me because the prodigious Aaron Funk insisted Renoise has the best clock that he uses to sync his gear. Yet with Renoise as the slave and the Rytm as the master clock, the BPM does not skip at all. Oh well, now that Renoise as slave is working, it doesn’t matter so much but still seems confusing. I wonder why the BPM skips at all with Renoise as the master clock…


#11

DAW isnt the most stable clock apparently. Logic causes everything i have to display jumpy tempo. But its all in sync.
To avoid being bothered by it, i just dont have the tempo displayed while its playing :slight_smile:


#12

Haha hmm. Good to know. I might try that method out.


#13

Seriously though, there should be a method to accurately record from a DAW such as Renoise. I know it is possible. The way I get a perfectly maintained BPM is that I give the DAW (Renoise) enough patterns to cover the length of the song. Then I hit “render file to disk in realtime,” which starts to play the pattern and record on the DAW. With trained reflexes, I hit the play button on my synced machines (impossible to hit perfectly) then wait for the patterns to end and hit the stop render button on the DAW. This is a very stupid method that I only use because it can at least record the song, though imperfectly timed.

If I could have Renoise sync the start-stops with my Elektron gear so that a DAW rendering starts the Renoise pattern as well as the external synths, then my problem would be solved. You cannot use Renoise as a MIDI master and a slave at the same time, or else this might sync the start/stops. Anyways, there should be a way to record with the DAW as a MIDI slave to the machines, with the recording starting only when you hit play on the machine. That would also solve my problem. But it seems the answers I seek are out of reach at the moment.


#14

possibly try using Renoise linked to Ableton via Rewire and then Ableton synced to the clock/transport of the Rytm … perhaps the various section triggers in Renoise could be achieved via midi notes on a midi track in Ableton directed to Renoise.

or, you could maybe try exporting individual sections from Renoise, and then load them to a Live or an Octatrack and have that synced to the Rytm or vice-versa.

that then requires another hardware investment/manual-reading/learning. it could however be the missing key to your compositional ventures … or a sabotage, not sure. :joy:


#15

You were able to sync your DAW to the Rytm via USB? Is it an MK1? Can you run through all the settings?


#16

Over my head, but ty!


#17

It’s an MK2. Clock goes: Rytm --> A4 --> Heat–> Renoise. Since the clock of Renoise makes the tempo/BPM of the elektron units bounce around, I use Renoise as a slave to the Rytm clock. I still don’t know why Venetian Snares says that Renoise is the best clock for his gear. I’m definitely missing something,

Right now I’m mainly interested in having the DAW start the pattern on the Rytm. When I record, I do a realtime render of the pattern, but I have to manually play the Rytm myself.


#18

So what if you set the Analog Rytm like this (in the sync menu):

Clock Reveive - off
Clock Send - on
Transport receive - on
Transport send - on

Set your AR to the same BPM as your DAW project. DAW sends transport messages but doesn’t send midi clock, AR starts stops by transport messages from the DAW and is responsible for sending midi clock to all the other hardware involved.

Downside: BPM changes in a song doesn’t work of course.


#19

Thanks!! Will definitely try that.