Master length - change pattern

Hi. So, master length set to 64, when I change to pattern 2, it waits for 64 steps and changes.

But then, when I switch back from pattern 2 to 1, it doesn’t wait 64 steps. It only waits 16?

I have individual track lengths activated. But I don’t see a master length setting on pattern 2?

This is a setting in the pattern settings which I believe you activate via FUNC+REC either when in grid recordingode or when not in grid recording mode.

Alternatively, you can set this up in your project settings and tell it to apply to all the patterns. It’s a setting like “chain after x” with x being number of steps. It’s like the quantize function in Ableton where you can set it to global, bar, half note, quarter note, etc.

1 Like

[Function] + [Bank] to open Pattern Settings Menu.
Chain behaviour sets how a pattern behaves when a new pattern is cued.
[Function] + [Page] to change track length.

These settings are per pattern, so when you change to a new pattern, you’ll have to edit again (or copy the pattern).

There’s also a global setting for the whole project (Project menu -> Control -> Sequencer -> Chain after.
Then in the Pattern Settings Menu check the option “Use Proj. Set.”


Thank you. But I still don’t understand.
The manual is hard to grasp on this subject.

I would like all patterns to quantise to 16 steps, so the current page of trigs are always played out before changing pattern.

How so?

And if I set chain behaviour to “use pat. setting” and NOT “use prj set.”, will the settings on the project level be overruled?

Yes, then you have to set for each pattern.
Just dial in the steps you want.
Copy/paste makes it easier.

But this is only for the behaviour when changing patterns.

Under Chain Behaviour, when you enter 16/64, does it do what you want?

1 Like

I have set it to use “prj set.”, and in project settings I sat it to 16/16. Now it works as I want. Thank you so much!