Machinedrum unmute issue - is it just my unit?

I like to think I’m pretty experienced with grooveboxes, drum machines, etc. I have a good history with elektron gear. I used two monomachines for years, and now have an analog keys and a Machinedrum. I also have two electribes. My issue is this:

If I try to unmute a drum sound on the machinedrum, it WILL not trigger the sound when pressing exactly on the beat. If I press HALF a beat early to unmute - still no triggering of the sound. I have to press almost exactly an entire step prior to get sound. This totally messes with my live performances (ok, in my basement with a camera performance), but it makes it almost entirely unuseable to me. Is it just me? I’ve never ever seen anyone else complain of this issue, but it’s driving me crazy.

I have done some testing with my monomachine and can confirm that it’s not me - I can trigger sounds EXACTLY on the beat with that. Same thing is true of the EMX and ESX, the AK, the Spectralis 2, the RS7000… I mean, the list goes on. So is it my MD? Or is this universal and no one has mentioned it before??? Below is a link to my video demonstrating my frustration with the MD, and a comparison at the end with the MNM.

Bug confirmed. See below.

2 Likes

I can confirm that this happens with any kit at any time.

I can also confirm that the function button is not getting stuck (it goes immediately from - to black square when muting and unmuting.

I was on V 1.62 and have now upgraded to V 1.63.

I’ve made sure the self- test shows that everything is OK. It passed all tests.

Curiously - someone else has reported having the same issue I’m having (on youtube). So I must not be alone in this. I reached out to Elektron, hoping to hear back from them.

Thanks

Any other variables at play? Clock source (internal or external?)

Clock source can be either - it doesn’t seem to help.

Have you repeated my same experiment? My basic settings were:

Tempo to slowest possible (30 bpm?)

Part 1 to play on 1, 5, 9, and 13 (4 to the floor)
Part 2 to play on every beat.

Then try unmuting part 1 on the beat when it’s to be triggered. I think maybe doing it at this rate (30 bpm) would make it more obvious, unless your unit just doesn’t do this.

I notice that this also occurs in others units as well - you can see here the same thing is happening (https://youtu.be/2AmdD6mXImI?t=35m32s). It doesn’t ‘seem’ noticeable, but it’s still occurring.

Also - which version do you have? I have the MD mkii UW +drive, maybe there are differences in units?

Thanks :slight_smile:

Not in front of my MD right now but my quick test was as followed:

Track Len = 16.

I had two tracks (GND-SIN machines)

T1: 1, 5, 9, and 13 (PTC High)
T2: 1, 5, 9, and 13 (PTC Low)

And i slowed the tempo down to around 70bpm.

I’ve got the UW+ MK2

Is it only happening on Beat 1 / Step 1?

So if you mute T1 a few beats before it’s triggered and then unmute (on say beat 1) you hear it play immediately when unmuted?

I believe I was using a different machine, but I’m also not by my MD, lol. Track length 16, yes.

If you were to use your example and press unmute any time after beat 13 (or after any of the beats), you would definitely hear the next beat trigger, unless you were to press the button after beat 16 (which is not set to make a sound on your test).

One interesting thing is that if I MUTE after beat 16 and unmute within the same beat (beat 16), I will hear the next beat 1 trigger. And yes - this is true of whether I’m unmuting something at beat 1, 4, 7, or 9 - it doesn’t matter when/where it occurs.

Thanks for the feedback/help.

If you have a chance to test it at 30 BPM, with the same type of setup - I wonder what you’ll find. Maybe it just doesn’t affect other people. To be honest, I’m hoping this is a MD issue (that no one notices except me), because I want to be able to sell this some day and don’t want to have to disclose that mine has some funky glitch with it (I couldn’t of course sell it without letting someone know what was up with it, if there was a problem with my unit).

Upload your pattern + kit sysex and ill give it a test.

Bug confirmed

I was able to replicate this at 30 BPM

  1 X - - - X - - - X - - - X - - -
  2 X - - - X - - - X - - - X - - -
  3 - X X X - X X X - X X X - X X X
    0 1 2 3 4 5 6 7 8 9 A B C D E F

I have to unmute at least 2 steps before the trig.

In the above example I have to unmute on step 2 to hear the trig on step 4.
If I unmute on step 3 the trig on step 4 does not play.


I’ve been using the MD for so many years now. My brain must automatically compensates for this.

1 Like

I can also do a test later, but yes, it was always my impression that you have to unmute quite early on the MD.

Haven’t watched the video yet so you may have covered this, but it would be interesting to confirm if it also happens in mute mode when you cue & hold multiple unmutes and release the Function button.

Is it an issue at 80-140 bpm? Just wondering if it is isolated at slow bpm only.

Same behaviour with function release trick.

1 Like

I see the issue at 100bpm.

1 Like

I tried it, hard for me to say, it feels to me I am unmuting on the third to hear the 4th. Not the 2nd.

JustinValer - thanks for confirming. Unfortunately, I have high doubts that this would ever be fixed by Elektron (being that it’s their oldest machine and hasn’t been in production for some time).

finalform - as JustinValer noted - the same behavior occurs using function release. The only time I can do this without causing a delay is to use the Global trick, where you can set parts to be sent to outputs that are not in use. This mutes the sound, not the trigger, but would work if I really needed it.

Cosmic - I actually noticed this behavior at faster BPM, but wanted to have a way to demonstrate it to others. Doing so at fast BPMs would’ve made it difficult to showcase the issue, so I slowed it way down (I even considered slowing the video/audio down to make it as obvious as possible - but it seems what I’ve done has been effective enough). I always unmute on the beat and with all other gear, I’ve never had a problem, the sound triggers as expected. Very quickly I ran across this problem!

Strangely, I think muting works as expected. It’s just the unmute that doesn’t!

My feeling is it is by design, for MD it seems to me the step has to be muted or unmuted before the step starts. This design may have changed (improved) to mute - unmute before or during step for later models such as mnm. I haven’t tried it on my mnm to compare but can see how it could be disconcerting when using both machines together. It would be interesting to know Cenks opinion on this. I don’t think it would get fixed either as MD is legacy. I’m not overly bothered by it myself but that’s just me.

PS love your videos and music Midera :blush:

You could be right about the design. I am personally shocked that I’m the only one who noticed it (or at least, the only one who noticed it enough to complain - it’s what I do best I think!). It’s an interesting concept that, at least to me, does not work very well for live playing. I will almost entirely always activate the notes either too early or too late, especially if the BPM is fast enough, who can hit exactly 1/16th note early when BPM is above 130? Well, probably a lot of you can, but doubt I could.

And yeah - I 100% don’t think Elektron owes it to anyone to fix this bug. Just wanted to see whether it was just me or others. Like I said, peace of mind if I sell this.

Anyway - I appreciate all the responses/help.

And thanks Cosmic :slight_smile: that means a lot to me!

1 Like

Yeah, I feel like I first noticed it at normal tempos. Like >120 bpm. I was failing to bring the kick back in on the 1 in time, when on e.g. a Roland TR-8 it felt like I could unmute practically on the step and it would still sound.

1 Like