Machinedrum SPS1-UW X.08 Released [ Unofficial ]

Yes it does.

2 Likes

Cheers for the quick reply. Appreciated!

2 Likes

According to MCL_Documentation_4_2_0.pdf

MonoMachine Settings:

Upgrade your MNM to the latest MNMX OS.

MCL communicates with the MonoMachine using SYSEX messages, and will configure your MNM’s current global settings automatically.

So no new functionality on the Monomachine as yet other than the MegaCMD can set global setting to the Monomachine.

Sounds like I will be upgrading all my machines this weekend.

1 Like

Are conditional trigs for MnM with the MCL to be expected at some point?

Unnecessary if you own MCL, correct?

Just catching up to news of x.07, now that I’m looking to upgrade again I see Elektron came out with Transfer 1.5 along with the releast of Syntakt. Since I can’t use C6 on M1, and don’t know how to do a virtual machine, I am looking for the easiest and most reliable way to backup/upgrade/transfer samples.

But reading further, the official documentation says the MD is supported but only OS files, and not Projects/Sounds/Presets/Samples.

Then again over here, Elektron also says “*Please note that Octatrack, as well as legacy machines such as Monomachine, Machinedrum, and Sidstation are not supported by Transfer.”

Am I better off avoiding Transfer entirely and just sticking to SysEx Librarian?

There is a option in Transfer to use SysEx Transfer for legacy machines.

The named MIDI port Machinedrum is not part of the software and is my Audio MIDI Setup.

This software only seems to send so if you want backups you will need SysEx Librarian.

Tested by sending original patches to a Sidstation, worked no problem.

3 Likes

Does it transfer at turbo speeds w/ a tm-1?

I don’t have a TM-1 as my MD and MNM are plain vanilla non-UW versions. You can see the presets being loaded into the Sidstation one at a time for a 30KB file so fairly slow. Anyone uploading audio files via MIDI would need the TM-1 turbo speed.

Hi Justin, again, thx for this one and the work that has been put into updating the OS.

One question for you.
With the MD there is a machine called CTR8P, with this machine it’s possible to automate per step 8 selected knobs. I assume that you know that it’s possible to press record+play, and record automations directly into the sequencer if the knob is pressed down while turning. I have been working a bit with this feature over the years, but I was always held back by the resolution getting quite bad when pressing the knob, I know that this is a common feature of the MD, that it responds to knob turns with lower resolution on purpose, but in this instance this is not really the desired mode when rec+play has been pressed, that being said, it is fine when record+play has not been pressed. Do you think you could somehow change this? Meaning that when rec+play has been pressed (in record mode) we dont have to pres down the knob to actually record, or do you think you could change the resolution to be not jump this much (finer resolution), lastly it could also be that you hold down func+rec+play to record with fine resolution.

This is something that would make the MD much more on par with the newer machines and would totally change the way we can live record knob movements into the sequencer.

Thanks again from Denmark :slight_smile:

3 Likes

Or, while doing it via midi, as it takes 15min, just make a coffee. It’ll be ready when yer back. TM-1 is a luxury, but not needed.

Mine doesn’t seem to be recognized anymore. Not sure why

2 Likes

I would have to check on my machine but it should record knob movements without the need to press the encoder.

Edit: turns out you’re right, never noticed that in well over a decade with the MD :grinning:

Yeah, the problem is not so much pressing the encoder but rather that the resolution becomes low, or should I say, it jumps too much for a lack of better terminology. I am not sure if this is just a current software limitation or it’s actually due to some hardware limit

Hmmm. While I get the request, I bet some of us actually rely on this behavior. I, for one, would be thrown off by this change.

2 Likes

As far as I know it’s meant to be able to turn the dial quicker. It‘s odd though because the other machines on the md get recorded without the need to press the knobs.

2 Likes

My guess is the TM-1 disagrees with 64bit Mac OS

No matter tho. Midi is fine for me :slight_smile: …coffee.

TM-1 is supposed to be class-compliant, but it fails randomly on one of my two Windows computers. I think there must be some kind of low-level protocol bug that causes some computers not to recognize it.

However, I can get that computer to recognize the TM-1 every time by connecting it through a USB hub, so you might try that. I’m using one by Anker, but I’m guessing that just about any hub will do–what I imagine is happening is that the hub is recognizing the TM-1 and then presenting the correct protocol to the computer.

BTW I have one other MIDI device that this particular computer won’t recognize, and that device works if I go through a hub as well.

1 Like

Thanks for reply.

Tried hub before. A while ago as I got tired of going around back of my computer and the hub didn’t werk. Then, at some point it stopped werking being connected directly :thinking:

These usb-midi adapters work pretty well with MD.


I checked it recently.

It’s wild how well my M-Audio Uno 1/1 has worked all these years. I’ve had some generic adapters that were included in various things I’ve purchased and all have failed at basic sysex updates.

Can’t speak to the above device’s quality, of course. But at least the price of the reliable brands is minimally more than the off-brand.