MachineDrum problem

Hi, I recently got a MDUW+, and although I got the hang of it quite quickly, there are still many things I need to learn.
Yesterday something weird happened. I hadn’t turned it on for a while, and when I did, two tracks in one pattern suddenly wouldn’t play any sound. In Kit Edit mode, the tracks played sound but when I exited the edit menu, they went back to silent… They weren’t muted.
Soooo what I did is reload the last snapshot and it solved the problem.
BUT!!! Now I have lost my latest kit! It’s nowhere to be found! I tried different snapshots, but I cannot recover it.

Is there something I missed?!

Thank you

By loading a stored snapshot you erased what was in current memory. If you haven t stored that kit in any snapshot (or sysex dump) before doing this it s now gone forever.

If on the other hand you stored your working set including that saved kit to a snapshot, then reloaded that snapshot and the kit is not there, then somekind of bug or glitch happened.


“Snapshots”, in MD / MM terminology, is what is called “Project” in more recent machines.
In these are stored everything from Patterns to Kits.

Go slowly, it’s easy to overlook something with this machine.

Once you’re comfortable with it, you’ll still do some mistakes, but at least you’ll understand what you did wrong: that’s the main difference between someone that’s new to Elektron and someone that’s been using them for a long time, I guess :sweat_smile:

1 Like

Thank you!
I did have that kit saved but never found it again…
Gotta use that beautiful machine more often!