Logic Pro X Song Position Pointer issue with OT

I’m syncing Logic with OT and need to disable Song Position Pointer but my Logic Pro X preferences don’t display the allow SPP checkbox shown here. Can anyone help?
Thanks!


I think you need to enable “advanced” settings in the general preferences tab. I’m away from my computer so I’m unable to give a step-by-step, but you have to enable more advanced feature set.

Thanks for the reply to this obscure topic! Unfortunately, I tried this to no avail… unless there’s another ‘advanced settings’ section somewhere?

File: Project Settings: Synchronization: Mode dropdown box.

Is the screenshot with the checkbox from Logic 9?

Sorry for the delay. Back at my setup now to test some things out.

Re: Logic 9, I’m not totally certain. I was google searching for Logic X, but I may have ended up on a Logic 9 page accidentally. In Logic X it seems like all the mode options leave SPP active. I tried out the ‘pattern’ option but this too snaps me back to A01 while in arrange mode. Do your preferences show you any non-SPP mode by chance?

I can describe my use case, in case that helps. Recording project.
I’m trying to record my AK and AR via Overbridge while also recording OT and the synths sequenced by OT so that everything is synced in the recording and so that I can get everything through the AK’s effects at once. I also need to preserve the BPM changes used in the OT arranger. Keeping the Arranger in charge of program change was my goal, but it’s not working out.

I’ve now gotten most of the way there by offloading the tempo changes to Logic and reverting to manual pattern changes on OT. (I was trying to use the Arranger for simplicity’s sake). Turning the arranger off has now allowed me to navigate to different parts of the recording and press play without being sent back to A01 by SPP. However, nailing the pattern changes while recording is a bit high stakes.

To solve this, I think I’ll need to send both tempo and program change to the OT via Logic. That will be today’s test. I understand from other reading that this will likely disable pickup machines, but that may be ok for now.

I solved this issue by putting Logic in charge of program change (sending to OT, which sends to everything else) and creating an arrangement of program changes within a midi region on a blank software instrument track. It is important to send the program change early (I send it about 1 bar early) to avoid problems with machines not all changing together. Also, if you’re moving the playhead around in logic, try to start it from the beginning of a pattern rather than the 2nd 3rd or 4th bars. Pretty cool to have 12 tracks via overbridge before even turning on my audio interface. 20 track recording will be sweet. :slight_smile:

1 Like

Nice! I’m glad you were able to get it working. It’s too bad that you can’t do it all from the OT arranger.

1 Like