Logic 9 + Digitakt

Greetings, I’m a midi beginner, although plenty years in the game, I’ve never been near midi except to plug in a keyboard.
I can’t be waiting for Overbridge, so I’ve connected the Digitakt to Logic via midi. The plan is for Logic to house and run the long samples that exceed the sample capacity of the Digitakt. The 'takt, naturally has the foundation of the beat etc.

So, issue I’m now having is whenever I stop Logic via the Mac space-bar, it resets the volume of the Digitakt channels to 0 (as seen with the TRG button illuminated).

Any suggestions as to prevent that happening?


I can’t say for sure what’s happening but I’d try this:

Go into the Preferences MIDI section and under Reset Messages make sure none of them are checked.
Next go into Project Settings MIDI section and under General make sure the 3 Send After Loading Project boxes are unchecked. Then also in Project Settings/MIDI go to the Chase section and uncheck all of them…

Might work after that, and then you can re-enable things if you find you need them…

1 Like

From one Mike to another,
Thank you, followed your tip, so far so good, the velocities are remaining stable. Ahhh…


Thank you very much, Open_Mike!

Being the lazy bastard that I am, I just unchecked CC 4 (foot control), as this is what the manual says
the trig velocity is affected by. Problem gone!

Will keep an eye out for the other controls, who knows what kind of hell they might
be attempting to raise…

1 Like