Live setup crash - a delicious whodunit

Hey 'nauts,

I played a live show last night and had multiple crashes before bowing out. My Rytm MK2 would freeze, and stop sending midi to the rest of my gear. I would restart the machine, it would work again for 2 to 10 minutes or so, then freeze again.

The whole setup:
Macbook pro running Ableton Suite 10.1
APC40 MK2 launching the odd clip
Novation Launch Control XL midi control
Rytm MK2
ON my partner’s side:
Analog4 MK1
Digitone
Octatrack
The A4, Digi and Octa main outs were running into my Ableton via a Presonus Firestudio mobile, and the Rytm Audio was going through Ableton via Overbridge.

The mystery for me is that we had been practicing for months, and NEVER had any issue like this. I would run my rig at home with no issue, we would run our whole setup at the practice space with no issue.

A couple theories:

  1. The idea of “dirty power” was mentioned. Maybe there is something weird about the power at the venue? I have no knowledge in this area. Is “dirty power” a real concern?
  2. Overbridge is still too unstable for live performance? (Again, it was perfectly solid for months)
  3. We had swapped my cheap usb hub (which had been working fine) with an overhub usb hub, but I figured that would definitely be an improvement. I did get an error message in my Overbridge Engine control panel about the USB port not working, literally as we were about to start, but I just closed that error window and things seemed to be working ok. An odd issue, but possibly contributed to the Rytm crashing.

I realize these things are hard to diagnose, but I can’t really think about much else this morning, so would appreciate all your 2 cents. The whole experience made me pretty sad and embarrassed. I’m certainly planning on simplifying my setup. I keep coming back to it being a power issue, as this was the only variable in the scenario. But again, I don’t know anything about how that would contribute to the problem. Any thoughts / solutions / product suggestions (power stabilizer? battery?) would be appreciated.

I also lost my scarf, which is a bummer as it just started getting effing cold in Toronto.

Thank you all!

7 Likes

I feel your pain.
I’d think that the hub is likely to blame. It’s the only thing you changed. I believe I had some problems with this hub as well. You should definitely practice with this hub for a few days and see if anything wrong happens.

5 Likes

Thanks.
The other hub that I was using wasn’t even MTT. I thought surely the Overhub would introduce more stability. But I agree it is a likely culprit as it was only introduced the night before. What issues were you having with it? What hub do you use now?

1 Like

I can’t remember but I think I had a launchpad that would disconnect. I’m not home but I can give you the model of hub I’m using. It’s not particularly a fancy one but I’ve played hundred of shows with no problems.

1 Like

MTT doesn’t matter to your setup at all: the only audio over USB is the Rytm mkII, which is USB 2.

MTT or not is only an issue for connecting older, USB 1.x devices, and even then, only matters if you are sending audio.

5 Likes

maybe bad usb cables at fault…

1 Like

I think it was clearly your swapping of the hub.

When I perform, my last two or three rehearsals are with exactly the equipment I’ll bring to the venue. This includes everything down to the audio cables to the house, stands, my table light, and even my merch. I put all the other equipment in my studio out of the way to ensure I’m working with the live setup. The last rehearsal I start by packing it all up, and rehearsing the load-in. Then I rehearse the music, and after I run through packing it all up again. Now I’m good to go and know I have exactly what works for the set.

11 Likes

I had a similar issue with the Rytm Mk1 live. It’s RARELY if ever frozen on me practicing, but locked up live once. Even with just Digitakt+Rytm.

Maybe power… in my case.

1 Like

I’m claiming that!

Yes as others have said the hub is almost certainly the culprit.

1 nugget of wisdom for future reference, never change out any components of a working system just before a gig.

10 Likes

I have a friend that DJs with Traktor on a Mac and the last two shows I’ve heard her play it’s crashed and required a reboot of the Mac.

What I think the issue is is that she does sound check before the show, two or three DJs play before her, then when she’s up., her Mac has gone into a sleep or power suspend mode. I don’t think the Mac recovers properly from a suspend/sleep mode. I’ve advised her to reboot shortly before she goes on to test this but she hasn’t played since the last time this happened.

Just a thought but if you did do a sound check and had the system up for a long period of inactivity before you went on then perhaps the suspend/power settings might deserve some scrutiny. I could be way off though.

Just some thoughts…

2 Likes

Damn, that sucks. :frowning:

Probably Overhub indeed, as this is the factor that changed. Ideas:

  • USB 2.0 vs USB 3.0: Did you use the correct cable in the correct USB port?
  • Did you use it without an adapter? If so, you might have been pulling more power than your laptop provided. Try with a suitable adapter ( see Overhub PSU? )
  • Did you use it with an adapter? Some adapters are wrongly labeled, not providing the correct amperage for example. See Overhub PSU? again for more information.
4 Likes

where did you play in toronto?

I would suspect overbridge. it worked well for me too, I only gave it up because of the difficulty of syncing up prog ch, but it would also very occasionally give me quite a disastrous audio glitch.

also worth mentioning the rytm mk2 seems to be not as rock solid reliable as other elektrons. sometimes it just doesn’t turn on lol.

2 Likes

I would indeed investigate Overhub.

There are a bunch of threads about Overhub issues, Overhub PSU and even alternatives multi-transaction translator usb 3 hub.

1 Like

I agree, this is a good practice. We really thought the hub would not affect things… such a bummer.

Thanks darenager. I totally agree, I’m just so surprised that this little element could have caused an issue.

But wait, was the culprit USB, or power?? what even IS “dirty power”? Is there a way to clean it before it reaches our setup?

This is good advice. However I’ve always had my machine sleeping for minutes / hours or days before firing up the rig and it’s never been a problem before the show.

We closed the night at Frequencies - an excellent monthly series of all live electronic music in Kensington Market. Thankfully the room was mostly loving friends.

Pro tip - if you want every single person to give you a hug and say that things sounded great, try having these horrible crashes.

6 Likes

" “ Dirty power ” is an abnormality in the power quality that is being delivered to a system. These abnormalities can include low power factor, voltage variations, frequency variations, and surges. All electrical systems are based on a supply of power at a certain voltage and frequency."

I think you can get power line conditioners to address this. Maybe even an uninterruptible power supply (UPS) as any fluctuations should be buffered by they battery.

2 Likes

Thanks LyingDalai.
I am getting convinced that it was the Overhub. I will try to replicate the crash tonight at home. Alot of the past thread posts would report a consistent non-functionality. But my situation was more of an intermittent non-functionality. Still, it seems if my Rytm was plugged into a port with shitty soldering, the connection could go in and out as I observed.

My rytm mk2 froze the other night. It was before a band practice. It had been sitting in the cold for a few hours. Could it of been that?