Live, Overbridge, A4 & External USB Keyboard - Track 1 only

I’m having some real trouble getting this to work. The manuals are completely useless for this simple scenario, so I’d love to hear any tips.

All I’m trying to do is connect the Analog 4 via Overbridge to Live, and have an external USB keyboard control the A4.

So far I can get it so that Track 1 responds to the external keyboard, but changing the Track on the A4 does nothing - the external keyboard always triggers Track 1 only.

The manual reads that all you should have to do is change the track on the A4 and the external USB keyboard should control that track.

I have my keyboard setup to output on Midi Channel 9 - which matches the Auto channel in the setup.

Any clues?

you can play the other tracks by sending midi on the channels 2-4

From my keyboard? Nope, I only get sounds from Track 1 when on Channel 9. Any other channel makes no sounds at all.

This is how I have the MIDI setup in Live

Anything look wrong??

thats my setup here… if i play on one of the midi channels on the right, the corresponding track plays.
i think somewhere in the settings you can define the midi channel per track, but i think thats default.


Ahhhhh… I think I got it thanks @funkymogli

I had to set the Midi input on the track with the Overbridge VST to none, and add an additional MIDI track with MIDI from my USB keyboard and MIDI TO to the A4, and then choose a channel.

Still…seems weird having to do that, and that the VST doesn’t relay track changes on the A4.

jeah thats right… actually i never tried that, cause i did it like that before overbridge and never changed. if you want to play more than a voice over midi you will have to do it this way anyway :wink:

this thread actually has a even nicer solution: