LFO Fade + Q-perf


#1

This pertains to both Analog MKII machines

Since the A4 has multiple destinations per LFO, it benefits from mapping the ‘Fade’ param(s) to a macro to engage/ disengage depths (defaulting to +63 and setting a macro knob to modulate by -63 or vice versa).

This works swimmingly until you go to mute/ unmute said macro (via func + qperf) as the Fade param sticks to the muted state and requires an additional turn of the macro to re-engage the LFO(s) in question.


#2

This is interesting to me because I was using performance knobs the same way, to bring in/out LFOs (via the fade parameter). I didn’t notice this issue, but as I’m innately curious, I’ll try to check it out and see if I can think of any workarounds (though I imagine if there were any, you’d have already come up with them as you seem equally or more experienced than I).

I had a not completely unrelated question come up today. Is there a way to have a free running LFO but have it start at a certain place in the waveform? Say you have all 16 trigs playing notes, and LFO controlling filter for a fade in/out effect, but you want to make sure the sequence starts audible, at the peak of the wave.


#3

I believe enabling the LFO trig param (on the trig page) for the first trig of the sequence will have an affect on the starting phase point, but if no, I’d try setting the first trig’s LFO trig mode to TRG with the rest set to FRE.


#4

I just realized this is an A4 mkII only feature (I’m on mkI), however if what the qperf mute button does is bring all performance knobs back to a zero value, is there maybe a way to reverse engineer so that your LFO is ON by default and you set the performance knob to turn it off when you bring the value up? This would then bring it back to on when you hit mute. Not sure if that solves your issue. Can you be more specific about exactly what you are trying to achieve?


#5

I’d like the LFO’s to not be audible by default and to be able to mute/ unmute them via the q-perf mute button alone (no other knob twists required).

Currently I’m forced to waste more macro mod destination slots on depth knobs to have this functionality.


#6

Oh interesting, is this true for any performance knob parameter, that on muting/unmuting it has to be “woken up” via a knob - or does this seem to be particular to the LFO fade parameter? I find it strange that the values wouldn’t return all parameters to values set by perf knobs on unmuting!

Also thanks for your suggestion for my issue - unfortunately I also don’t want it to restart the LFO every time the sequence loops :confused:


#7
  1. This issue is exclusive to the fade param.
  2. Conditional trigs should work, no? (Ie. First (1st) or iterations (A:B))

#8

I’d consider it a bug then? Maybe worth pointing this @ one of the moderators/admins…

Problem w making it a conditional trig is there’s a note there that I DO want played every time the sequence repeats. I’ve tried hard to think of other workarounds, if I’m missing something obvious please do tell, and THANK YOU :smiley:


#9

You sure you can’t either micro-time a duplicate trig on either side to provide the note without a conditional trig or phase start point with?


#10

In this case all the trigs are in use, but that does get me thinking, maybe a potential workaround is using the arp… gonna try that!


#11

The moderators/admins here are the wrong audience, because this forum is not run by Elektron. You’ll need to head over to the Elektron website and report the bug there.


#12

I actually did this, when I first received the instrument about 8 months ago, and was told it was behaving properly, but as I recently was given information I know to be inaccurate regarding another issue, I figured I’d mention it here to see if anyone (including Simon or Olle) might have anything to add, should they stumble across it.


#13

Yes that’s interesting - not sure who told you that’s “working properly” :rofl:

If it’s literally the only parameter that does that, unless someone can explain a reason it was programmed that way, then it seems like a bug to me! To be fair though I’m not a programmer nor do I understand electronics very deeply.