Is there any way to turn off ALL external midi-control of the OT?

After I moved into a smaller place a while ago I had to size down my setup. The Prophet 12 has taken up the role of main-midi controller keyboard. And is therefore assigned to the auto-channel.

The problem is that some of the knobs on the prophet are muting tracks and changing parameters in the octatrack. I of course have turned all control to internal control only in the OT MIDI-menu. So why are these CC’s still affecting the OT?

1 Like

Recheck settings. OT can be set to ignore all incoming CC.
Had some trouble with it before…

It’s in the manual something like audio cc in from memory

1 Like

I’ve checked all the settings a million times. It’s in the MIDI-control menu. But they’re still getting through… Could it be something with my unit. It’s always been like this. But with my previous controller it didn’t matter.

1 Like

Proj-Midi-Channels

press and hold the down arrow to disarm autochannel.

then use the left/right arrow keys to navigate onwards to the Track midi channels;
employ the down arrow to decrement each channel to Off.

1 Like

They’re all off. Except the auto-channel… I need that on to use the P12 as a MIDI-controller.

Can somebody check if this is the same with all units?

Turn off all external control and then send CC 112 on the auto-channel to see if it mutes MIDI-track 1?

Midi > Control > CC IN uncheck.

2 Likes

Check the cc direct conect box, that will make sure the midi side won’t respond to cc’s…
Control/midi sequencer menu…

Make sure it’s checked (on)…

The other setting is for the audio side (audio cc in)…

2 Likes

Good to mention CC Direct Connect too.
Actually, midi tracks can be muted sending CC to midi tracks or audio tracks.

1 Like

Yeah. That’s the one. Direct connect stops the CC’s from affecting the OT. I’ve always kept that off because turning it on means CC’s received from the autochannel are sent to the MIDI-channel of any MIDI track you’re on. I assumed that was all it did…

Not quite sure what I’ll do, because with Direct Connect turned on, controlling and layering another synth with the prophet becomes a mess, anything I tweak on the prophet will be sent to the other synth as well which can easily destroy a patch. But I’ll figure something out.

I guess that’s the end of the thread. I hope there will be an OS update to fix this eventually. They could just put it in the same menu as direct connect and make it two boxes instead of one.

Thanks for all suggestions, and have a nice day :smiley:

2 Likes

could try keeping your two synths on midi tracks different to 1-8.

for example tracks 11 and 12.

then switching off Direct Connect.

that might work.

or, if Direct Connect does need to be on, perhaps don’t use auto-channel, but rather just have midi tracks 1-4 devoted to first synth and midi tracks 5-8 devoted to the second synth, with the appropriate midi channel setting for both sets.

then manually change the midi channel of the P-12 as required depending on whether it is to sequence first or second synth.

btw Direct Connect allows remote p-locking. hold a trig, move a dial on the external synth, hey presto parameter-lock achieved.

i hear the DSI keyboards have a very nice feel to them … going to be rocking an OB6 in about ten days or so, yay. after reading what people had to say about the amazing keyboard i went for that rather than the module version.

as regards midi sequencing, i use the OT sequencing for basslines on the se02, using the k25m keyboard on the se02.
but for chordal synth work, going to use a qy700 with the two midi input outputs on it as i think this might simplify the scenario.

1 Like

I’m a newb to OT but been using AR Mkii and DG for a few years so I think I have a feel for the way things work in this amazing instrument. However, OT has vastly more MIDI options and that’s one of the reasons why I traded in my Taylor 414CE at Alto music in Middletown. I’m totally blown away. But.

Like Dream-Synthesizer (DS) I’ve been struggling with this MIDI conflict. On my Virus TI I want to lock CC#113 which manages the Delay/send value. It also mutes midi track 2! Like you, DS, I’ve fiddled every config and got mixed results. Here is what ‘sort-a-works’

If I turn off auto channel in config, rotating the encoder on my TI (on multi 16) stops muting the track. Before I did all that I MIDI Learned that cc so it’s set on my FX2 page. Nice, but sheesh. When I flip that knob - guess what? It mutes midi track 2. So external MIDI on auto channel is not turning off my midi track 2, but the CC know on midi track one (channel 1) mutes the track. If I turn off mid channels as suggested somewhere in this thread that produced evil results.

Preferred solution:
When digging into the config section of the TI I came upon an option called ‘Soft Thru’. What that does, according to the TI Manual (rather a helpful form entry) is controls whether CC values incoming will be replayed at the MIDI OUT port (not thru). That is why the track continued to mute midi track 2 after turning off autochannel.

Good Hack
The first thing I tried was to use a MIDI router. I own several iConnectivity MIDI units : MIO4 and ICM4+. They provide an excellent MIDI router. With a computer while midi learn is being used, I can get MIDI bidirectional behavior. When jamming or performing I turned off the TI to OT route. then when I turn my CC #113 on the TI or on the OT track 2 does not get muted.

Requiring a computer kinda breaks the OT model, but I love the midi routing of the iConnectivity gear because it does solve many midi channel problems by the plethora of MIDI ports it provide in the unit. My plan is to get the MioXL (on board USB controllescoverer hub, network midi, 10 MIDI IN/OUT ports, rack mountable.

If anyone has solved this problem within OT alone, I’d love to hear the solution.

To disable incomming CCs controlling audio tracks :
Midi > Control > AUDIO CC IN unchecked
or MIDI > CHANNELS off for all

To disable incoming CCs controlling midi tracks :
CC DIRECT CONNECT on

You can also disable CC send from the TI and control it with OT midi tracks.

2 Likes