iOS camera troubles

Sooo, I recorded a video of a dj set using my phone yesterday. It’s actually the first time as I’m camera shy but I thought I’d give it a go.

To get a good recording, I recorded the audio through my Saffire interface via the computer while recording the video from the phone. Great in theory but it didn’t work as expected.

The problem is that when I went to sync the audio to the video in iMovie, the audio is perfect but the video starts to get more and more delayed the further it plays. By the end it’s a fair few seconds off. I’m seriously scratching my head as the video has audio already attached (that I detach and delete in iMovie), and that audio is in time with the video (but was from the phones mic). Also, seeing as both devices were recording the same audio, in theory they should be identical in timing.

I know a fair few of you guys on here make regular videos. Does anyone have any idea where I’m going wrong? Any help is appreciated! :slight_smile:

Edit: it’s not the bitrate, but maybe something else?

1 Like

Are you positive it’s not the bitrate? Double check your audio. Is the phone camera recording 44.1, but you’re recording in whatever app on your computer at 48? When you import them into iMovie, whatever the original was, it’s going to convert it to the project settings. I’m encouraging you to check on the original recording settings.

Alternately, you could be experiencing skipped frames when importing video. Double check your phone’s frame rate, etc, then try creating a new iMovie project with these exact settings (I don’t know if iMovie does this… I think you can in Final Cut)

I am not an expert on this… just giving you some places to maybe dig into.

Hey, thanks for the input! :slight_smile:

I tried converting the bitrate in wavelab and then imported that version to iMovie but still had the same results. if I line up the peaks between the imported audio and the videos audio track then it can be easily seen that the peaks drift out more every few seconds.

Not sure if it’s relevant but I just checked my phone and it recorded at 1080p 30 fps, there doesn’t seem to be any setting for the audio but it’s the whole video that drifts, not just the audio.

I’m baffled! :crazy_face:

Bitrate has no bearing on timing. Sample rate does. When you talk about 44.1 or 48khz that s sample rate/frequency.

If it s not that then indeed it could be that your iMovie’s project timing settings are different from the iPhone video you impoterd in it.


Words have meaning! haha. thanks for the clarity.

One thing I have discovered is that if you upload to YouTube I don’t know what magic happens but the sync issues go away…

I do this with really short videos though so this is not scientific by any means :rofl:

Yeah I get bitrate and sample rate confused quite often. i was referring to sample rate though. I tried reimporting the audio with adjusted sample rate to match but had the same result.

There was a difference between them originally though, 32bit 44100 for the phone and 16bit 48000 for wavelab.

sounds like you are dropping frames somehow. What frame rate is your iOS device set to in Camera Settings?

Do you have Live Suite? If So, what happens when you run the recorded audio as one track, and the video as another, and mute the video audio but render/export them together into one video?

The iPhone recorded at 30fps, I didn’t think to bump it up in advance but VLC tells me the audio is 32bit 44100k m4a.

That’s a good idea! I actually used Live to check if my audio was drifting. Didn’t think to try and load the video up. I don’t have suite just standard 9.7 but I think it supports video.

Thanks for the input, I’ll try this now :+1:

1 Like

Bah humbug it didn’t work, it probably would on a better computer though. It was worth a shot and a very good idea that I will probably use later down the line.

So, back to square one. Seems like I would need to record the audio direct to the phone to get round this problem. It still seems a bit weird to me though, if I google it, there aren’t many people with this issue so maybe I’m doing something wrong.

i get lots of line noise when recording from the decks so I much prefer recording to the computer so I can clean up the audio afterwards.

Maybe importing to iMovie is the problem but without more experience I have no way of knowing.

Maybe this is fate telling me not to bother lol :see_no_evil:

yea, and your saffire should be class compliant if it is one of the USB models, so lightning-usb camera adapter should get it done for you.

Look on the bright side, it sets you up for quality line input instagram videos as well :wink:

1 Like

I do have the CCK but unfortunately my interface is FireWire. I guess I’ll have to look into an alternative interface or maybe an iOS specific interface like the Roland:Go. The line noise is still an issue though.

I think you were right in the first place about getting dropped frames. I’m going to look into it a bit more, I have a feeling that the problem is importing into iMovie.

Thanks for the input!

check out the Zoom U-24.
2 in, 4 out, midi i/o. multiple power options. powerful headphone amp. low noise. affordable.

1 Like

Thanks I’ll take a look :slight_smile: in the meantime I may have found a solution that involves re-encoding the video, but it takes a while so I don’t know yet

Edit: well that didn’t work lol, I’ve literally wasted 2 days on this, time to move on. thanks for the input though it’s appreciated :slight_smile: I think maybe doing live videos isn’t for me atm

1 Like

@djenzyme Did you try asking on the Audiobus forum? People there post videos from their iPhone/iPads quite often.

I’ll have to check back there, that forum won’t even load for me at the moment. Good idea though thanks :+1:

I would say get a cheap webcam and record the whole thing on the computer, but right now with covid-19 having everyone working from home who is able, it appears they are sold out everywhere.

it’s actually taken 2 years for me to record myself mixing, now after 2 whole days of messing around trying to get it to work, I give up.

I have to say, props to the youtubers that make regular videos, there’s a lot more hassle than I realised

I’m glad to say I’ve finally fixed this problem :slight_smile:

I actually already sussed it last night but used the wrong settings, doh!

If anyone ever runs into this problem, the reason is the iPhone shoots ‘VFR’ video, but most editors use ‘CFR’ and when it is imported, the timing goes off. You can use a desktop app called Handbrake to convert the iPhone video to CFR to get round this issue.

Thanks for everyone’s input while I figured this out. I might actually get round to filming some Octatrack jams! :joy:


VFR = variable frame rate
CFR = constant FR

Yeah that could create bad issues… I recently had a hard time debugging glitches in an artist colleague s video Max patch. Turned out that the video s were recorded in a wide variety of formats, including some VFR…

1 Like