Invalid and inconsistent MIDI, possibly from OT MKII ? [resolved]

The Niftycase Modular has a built in Midi to CV module, however i’m having a hard time getting the gate to work properly with the Octatrack. Basically, the gate doesn’t ever trigger and it’s almost like the CV is being throttled. I.E. A CV is only triggered once every 1-2 seconds.

I thought maybe an issue with the niftycase, but I plugged in the USB Midi and fired up ableton and both CV and the gate worked as expected. Then I thought ok maybe the DIN port? But I plugged in my midi keyboard and both worked perfectly. Is anyone the OT with modular Midi-CV and can share some settings in the OT that I might be missing?

Here’s a video explaining the issue. I figured out something was wrong when I tried to sequence my modular and this happened. Any ideas?

The 2 byte invalid messages look identical to the valid ones. The 1 byte ones are missing the third parameter.

Weird. Missing notes?
Is the OT midi out directly plugged in the midi interface?

No Notes Off is normal because OT uses Notes On with Velocity = 0 instead. That’s probably something to consider with your midi to cv converter.

1 Like

looks more like a hardware issue, than ‘settings’

I think midi monitor allows you to see the bytes of the invalid messages , that would be interesting.
but the fact you’re also getting identical timestamps is very suspicious of a corrupt stream.

what I would do is simplify…
remove everything else thats not needed for test,
make sure no midi input to octatrack (midi loops)
turn clock off, also for now,
turn off midi output of the audio channels. (also check they are not on same ch. as your using for midi output)
all, so you know exactly what is being sent over the wire.

also make sure that the octatrack is NOT using turbo midi … it shouldn’t unless it negotiated it with something but who knows :wink:

then down to normal stuff, perhaps try a different midi cable, midi -> usb converter.

this is part of the MIDI protocol , all midi implementations are required to support this,
anyway, usb converters are usually dumb, they dont interpret messages they just repack them.
(as opposed to midi processors which have to unpack to be able to change them)

we are also not seeing this in the midi monitor above, as note with velocity =0.
(midi monitor has an option to choose if you display as note_on,vel=0 or to display as note off)
Id assume its those ‘invalid’ 2 byte messages are the note offs.

im intrigued by what those 1 byte ones are…perhaps corrupted clock messages.


in a (potentially) cheap Midi>USB device would be my guess

try to test with two normal devices DIN to DIN to test the OT output

it couldn’t be as only one DIN cable is attached - there are very few Turbo compatible devices anyway

Unfortunately though this isn’t always the case, I can’t recall which device it was, but I definitely remember this being an issue on a midi-cv device I was using some years back, I ended up contacting the manufacturer and the firmware was updated, I think it may have been Flame Clockwork but not 100% sure, as it was at least 8/9 years ago.

I’d be inclined to check with NiftyCase to see if their module does support velocity zero as note off, just to rule it out.


One other thing worth trying is to put another midi device between the OT and your cv converter, it could be a thru box or any other device with and in and thru, the reason I suggest this is because (I think) sometimes different midi inputs are very fussy about the current required to reliably trigger the optoisolator on their input circuit, I have had this problem before too, but adding a device in between as described solved it.

Edit: It must be a powered device, not one which draws power parasitically from the midi buss.


Just an incidental note: Turbo MIDI can be used with a single cable (for example, Squarp Pyramid to Elektron instrument) with a fixed Turbo speed. Bi-directional connection is only required for speed negotiation between two instruments.


ah, good to know :thup: edit: (see below though)

1 Like

@bighitbiker3 video shows a Komplete Audio 6. Im assuming this is the midi interface used - no?
I’d guess, he has tried with the midi keyboard he mentions in the OP.
so its a bit ‘odd’
at least for the computer test

the nifty has straight midi din, so thats ever more odd…
(Im assuming this is what the OP using in this case)

id be tempted to blame either the octatrack output din, or the cable…
what id really want to do is test the octatrack output with another synth with DIN input.

1 Like

I don’t see how this is to be interpreted as you do (apparently) need bi-directional connections between two modern Elektron devices to enable Turbo mode and the moment you remove one cable the Turbo connection drops (i’m talking DIN as USB is implicitly two way) - so if two Elektrons cannot hook up at 10x i don’t yet see how a third party device would offer a different experience.

I know we’re off-topic^

but i do think the op should try a different DIN-USB device if possible or test basic note out with a normal device or even just disable clock to see if the potentially cheap/broken usb midi device stops choking or losing data - i’ve seen this with sysex dumps and low quality al in one cable USB devices

2 mods beeing off-topic! :pl:

I’m about to test with my MKI and a midi monitor, I’ll post results after.

1 Like

if you have a midi loopback , can the OT negotiate with itself turbo midi?
also does the OT reliably drop out of turbo midi, if one side ‘disappears’

my suggestions, were mainly about how you might get into a weird state, which could appear to create a corrupt stream… which id expect turbo midi would do for a device that didnt support it.

Im not suggesting this is something that can easily happen, but life throws curve balls sometimes :wink:

Feel free to break this digression off from the actual topic. It’s been a long time since I bothered trying using TurboMIDI with bidirectional DIN cables because I only ever use it for data dumps between MD/MM and computer, but it is definitely possible.

Squarp implements it on Pyramid’s MIDI Out A with settings for fixed (not negotiated) speeds:


So I tested with OT MKI OS1.31, sending clock, with UM1G midi interface and Miditest software as monitor.

No problem, no lost Note On or Note On Vel 0, even playing fast with chromatic mode, or the fastest arp speed setting.

just the one moderator as it happens !

1 Like

if one side disappears it breaks - this (issue as described) seems more like what would happen with duff/cheap hardware - i doubt it’ll be the OT fwiw although the test case seems like a low ‘bandwidth’ test compared to funnelling screeds of sysex which was what i had noted cheap all-in-one usb/midi devices baulk at, it was never consistent wrt which data would drop

yes , but the nifty is also not working and that’s not using usb midi, it’s midi din.
So that would be two independent devices not working - could be, but seems unlikely.

of course could also be unrelated issues , hence why important to isolate/simplify things

1 Like

Ok so a couple updates. Turning off the clock has removed the invalid messages from the stream when hitting the notes, however there are still only sporadic note messages like the video above. It feels like it’s choking somehow.

I tried changing the cable, going thru the Rytm, and made sure Turbo was not negotiated for some reason. The Audio 6 is showing the correct messages for all my other gear using DIN input, including the Rytm.

What do you mean by this? I’m pretty sure it’s off but want to double check…

I’m relatively new to the OT and don’t have much work on it and would be fine with doing a factory reset if anyone thinks that’ll solve things. I already did and Empty Reset, but maybe there’s another step further…

1 Like

Simple test would be start with new empty project on OT (remember to save current project first) and just try a single track sending midi to your modular, no clock out from OT and no audio tracks. See if that works as expected.