How do you post the Soundcloud embedded player?

Can someone help…? I tried posting a song on the “Our Music” thread, but the soundcloud embedded player wouldn’t post… It works for other people, so I’m doing something wrong.

Here’s the embed code I’m using. I’ve removed the outer two carats here, <>, so you can see what I’m trying to embed:

iframe width=“100%” height=“166” scrolling=“no” frameborder=“no” allow=“autoplay” src=“https://w.soundcloud.com/player/?url=https%3A//api.soundcloud.com/tracks/435807384&color=%23ff5500&auto_play=false&hide_related=false&show_comments=true&show_user=true&show_reposts=false&show_teaser=true”></iframe

don’t worry about code., just use the plain link, the forum backend does the rest.x

https://soundcloud.com/xxxxxxxx/xxxxxxxxxk/s-xoxxxxw etc etc etc

1 Like

testing…

1 Like

perfect - thank you!

1 Like

testing too

I do not know what I am doing wrong here.

I posted the link - but the embedded player does not show up.

I went to your track on an iPhone and then clicked the Share button (a box with an arrow) and copied the link which showed up as a soundcloud dot app dot goo dot gl link. Also, I think there needs to be a return before the link (if there’s text above) and no spaces before or after on the line of the link itself.

1 Like

thanks, it’s working now

1 Like

Just testing

I get this weird half width thing if I do it from a phone - is alright if I get the link on a desktop though

1 Like

I’m in another discourse forum that also does the half width (or less) thing on mobile. I feel like it’s a platform problem.

Links in soundcloud.app.goo.gl don’t work well on Discourse.
That’s the link you get with “share” button.

So just hit “plus” button, then “copy”.
And there you go with the good old soundcloud.com link.

2 Likes