Flex Machine working like Thru & not recording

Greetings Elektronauts. This is the first time I’ve encountered this in my short time recording samples on the Octatrack. I can work Thru machines easy and have done a few recordings via Rec 1 on Flex but today I decided to record my Tempest going into A+B Thru Machine, so I changed it to a Flex and placed the recording trig on step 1. The track is T6, so I set the Flex Machine to R6 RECORDING 6 (Should I do select different here?). When I press FUNC+Rec 1 I have everything set accordingly: INAB:A+B/RLEN:MAX/TRIG:ONE2/LOOP:ON. The recorder just keeps going until I stop the entire track. Usually on TRIG: ONE2, the Recorder stops when pressings Rec 1 a second time? What am I doing wrong? I greatly appreciate the time and explanation to those that can. Thank you kindly :slight_smile:

I’m a bit confused what you mean here. What is the relevance of the Thru machine to the scenario?

When you say you’ve assigned R6 to a Flex machine on track 6, that’s right, but remember that the naming convention is only for convenience. You can assign recorder buffer 6 to any track you like.

Sorry if this is obvious- Can you double check that the active recording buffer is 6 (the red light is next to track 6 button while you record)? I wonder if it’s on track one so recording using the default recorder settings (Trig One)?

Do you have to hold Track 6 button while pressing REC1 to stop the recording? Maybe you meant that- I’m just thinking out loud!

“one 2” refers to manual recording. recorder trigs don’t require pressing the rec button to initiate rdcording, use rlen, which you’ve set at max. you can turn rlen down to any number of step numbers (16 for a 16 step recording etc)

also don’t forget to place a play trig if you want what you’ve rrcorded to play.

1 Like

Yes, I also usually find recorder trigs easier than manual. As long as I remember to remove the recorder trig once the sequencer starts, or make it a one-shot, or it will re-record every time the sequencer passes that step.

I should have mentioned I tried all 3 options. One, One2, Hold. It was ignoring my commands on One2 and Hold. Only Trigs worked. I’m going to try these suggestions and get back to you guys! Thank you!

That sounds suspiciously like it’s recording to a recording buffer set to Rec TRIG ONE rather than R6.

To record a thru machine complete with its fx and any plocks and things on the track you can use any of the 8 track recorders and set Src3 to the track # of the thru track, no need to change it to a flex. A flex track is used to playback the recorder buffers. All 8 track recorders operate independently of any machines assigned to the tracks, the recording sources can be the inputs but also any of the tracks using Src3…

You can achieve similar results by changing the thru to a flex assigned to the buffer of the same track number as you have done. This way your recording the inputs not combined with the fx of the track, which is useful if you want to manipulate the fx later and not have them backed into the recording…

As to why it’s not working without using trigs, what is your qrec setting?
And as pidgeo said with rlen max the recording will keep going until you manually stop it using one2mode. I believe there is a bug where you have to press track+rec twice to stop it on the latest OS, should be just once. For trig recording make sure your input source is locked by holding down the record trig and checking the right source is highlighted…