(Finally fixed!) Syncing a DAW with Overbridge & other external Midi gear


#1

I’ve been pulling my hair out with this one for a while—especially trying to sync DAW drums with Midi drums with RYTM drums. But, thanks to this thread (Moving from Octatrack to Push 2) I managed to finally fix my syncing woes with Overbridge, external gear and my DAW.

In short hear is how I did it, I have my RYTM act as a (kind of) Sync box for all my other gear. So my DAW controls the RYTM via OB and it sends the clock and transport. The RYTM receives this and via a Midi cable attached to it’s Midi Out port, sends it’s clock and transport onwards to other gear. In my case I have it running to an empty in on my iConnectMidi4+ which then distributes the midi info onwards.

This simple solution (which I didn’t even think was possible) has got everything dialed in perfectly.

To top it off, sequences seem to stay on the money whether I’m playing patterns from my MD/MnM or if I sequence them from Bitwig - they’re both in sync (I usually could only get one way or the other to work - even if at all).

Oh man, I am so happy right now!

I hope this helps anyone. And apologies if this is common knowledge :slight_smile:

OH/


Digitakt Overbridge enabled
#2

Cool that you have it fixed. I’ve tried a similar setup, but how do you record audio from other (non-OB) synths? If I record those thru my soundcard, then overbridge is in sync with soft synths but not with the other hardware synths.


#3

I’ll be tryin that this weekend, let me report back. EX/


#4

@SB-SIX

OK - had a play this afternoon. I just adjusted my Recording Offset until the incoming recorded audio is exactly on the beat. So now I can have Overbridge, live external gear, recorded external gear and soft synths all running in exact sync.

Well almost - if I have any external gear triggered by a midi clip (not its internal sequencer) then there is a very slight delay. This disappears if I use all external sequencers or all internal midi clips - mixing the two doesn’t work as well. But it is very slight and in reality it’s only noticeable on drums and I intend to always use external sequencers for those.

What is super cool, is when I use a Hybrid track in Bitwig (which essentially lets me use audio and midi in the same track). I can have a 4 bar loop and have it play both audio and the Elektron sequencer - when the play head goes over the audio it punches in and mutes the incoming Elektron audio and then as soon as the audio clip has played the Elektron sequencer unmutes and takes it from there.

I recently got Bitwig and have it finally set up and working incredibly well. I’ve owned Live for years and never had such great timing and alignment with internal and external gear. I also found Live very confusing as to what needed to be adjusted to try and sync things.

Good times.


#5

Thanks for the detailed info. I have bitwig too and absolutely love it.
What is the record offset you use? Is that the one in the audio preferences? And do you enable latency compensation or have it disabled? And are you also able to record seperate tracks from the rytm that stay in sync with the hardware synths? I’m very curious, sorry :slight_smile:
I’ve tried so many combinations but there is always one part that doesnt line up.


#6

So I set up Bitwig and my gear as outlined above (Bitwig triggering RYTM via OB and then Midi out of RYTM to transport start my other gear). I then adjusted the latency within each hardware instrument so it aligned with the OB reported latency (1450 samples).

I then made a recording like you suggested and the incoming audio was out. I used recording offset to fix that (-900 samples). Unfortunately that required a bit of trial and error as I don’t know if Bitwig displays the length in ms/samples of a highlighted audio region (like Live does).

After the recording was in sync I tried again - and here I noticed things were slightly out. But - it just required me to make small adjustments on the Hardware Instrument latency and everything synced into place.

I have Plug In Latency compensation and Audio Recording Latency Compensation both switched on.

(I’ve attached an example of how I have my A4 set up in Bitwig too in case that helps).

Hope this helps. Let me know if you need any more tips.

EX/

A4.bwproject (66.2 KB)


#7

Thanks OHEXOH! I finally got it right too! I had to setup slightly different. Maybe this can help someone else too:

  • I had to set my soundcard and overbridge buffer to 128 instead of 256
  • In the OB VST, I selected “song position” as sync mode. This was tighter than the other modes.
  • Like you said, you need to make hardware instruments for all individual non-ob tracks with added latency compensation
  • My midi clock comes directly from my soundcard. I could not get it right with midi clock from the AR

Now everything is in sync, during monitoring and during recording. Brilliant!


#8

Hi guys,

i have tried some advices I have found in this post, but it is still not sync as I wished…
I have the AR in OB mode, (Song Pos in vst), since DT is stil waiting for OB it is connected as External Gear to my ID14, then when I start play in Ableton it looks like it is not sync to my AR/DAW,
I have tried AR Midi out to DT Midi in, but still the same result.
I also have an Iconnect mio2, can it be useful in this case?
Im loosing my mind, if anyone can give me different options to try, it would be much appreciated,


#9

Have you gone into the AR Midi setup and made sure the transport recieve and send are checked?


#10

Unfortunately, I can’t help,you. I always had issues with Ableton and keeping everything in sync and it wasn’t until I moved to Bitwig did I finally get rock solid timing with all my midi gear.

I theory, my set up above should work for Ableton… but I don’t use it anymore to be able to try it out.

I know @William_WiLD seems to have it all running smooth from what I recall.

Oh/


#11

@OHEXOH i’m coming :slight_smile:

@weldeep Alright first of ALL what’s the computer we’re talking PC or MAC ? what’s the spec of it ?

DO you try the recommendations i done on the templates i made for Ableton ? (See the elektronauts descriptions in the file section… values i give can maybe help a bit)
https://www.elektronauts.com/files/397

For now i do not have any of MKI here but i succeed on every DAW to get something from OK (Ableton) to Nice (Bitwig) i must tell from what i’ve remember the first bars will not be perfect but it’s get better after…

There’s also nothing more easy and reliable than a dedicated solution to sync gears just because they give you knobs to advance or delay midi sync (talking about Innerclock, SND Acme, ERM Multiclock)

Then Overbridge comes in february 2018 and of course must be better and result in a better experience maybe more tight than ever.

Last but not least don’t try to get all in SYNC in one shot. Start only with the computer and its onboard soundcard (if deactivated because you have an RME or something like that : stick to PC + Soundcard) and you MAIN Elektron - Connect it via USB and stick to only that until it works. In overbridge panel only activate inputs master and deactivate all the others (start with the minimum to see what timing you can get) and then add things to complicate and see how it’s evolve.

Try the values i give :
Settings are Buffer at 64 on both Ableton Live and Overbridge if you have problem pass it at 128
Margin is at 50 (same if problem pass it at 75/100)
Template is 24bits - 48000 same in the Overbridge plugin

I’m here for the next to follow :wink:


#12

Really appreciate that @William_WiLD , I will give it a try tonight after work,

I use a macbook pro 15’ / 16go ram / 2015 / AUDIENT ID14 /

I will try your template, everything has always been working great with AR/OB and Ableton,
The issues is only since we can’t use OB for DT,
Should i connect the DT with his USB cord, or directly in MIDI into my MIO2 or AR,

i have adjusted the midi latency last time and i definitely see your point when you start a bit off timing and it gets better timing after few bars, but still not as good as you would expect.

Will give you update later tonight,

Thanks a lot :wink:


#13

Connect your Digitakt to Analog RYTM, Pass the sync from AR to DT (at the same time as your OB Session)
AR : Send Sync and Transport
DT : Receive Sync and Transport

But try first with only the Macbook + Elektron connected by USB (disconnect all of your other equipment.)
Get your sync with the least equipment connected firstly. Macbook + AR + DT (By USB and Midi between AR and DT)

  • Deactivate Ableton Midi compensation (It is found under Options in the top menu bar of Ableton Live)

  • DISABLE USB MIDI
    Preference MIDI

  • Don’t use Midi Delay in Ableton
    2Zx85

  • Set your Overbridge Plugins and Pannel according to the Manual. Don’t forget 24bits - 48000Hz

  • Try the values i give :
    Settings are Buffer at 64 on both Ableton Live and Overbridge if you have problem pass it at 128
    Margin is at 50 (same if problem pass it at 75/100)
    Template is 24bits - 48000 same in the Overbridge plugin

@weldeep THEN TELL ME HOW IT IS :wink:


#14

Has anyone got the Analog Four and RYTM sync’d with Maschine using OB? If so, what were your settings?


#15

Thanks @William_WiLD ,

Here are some feedback, sorry for the delay, took me a bit of time to get back on this case,

Macbook + ID14
Analog Rytm = Usb to Computer / Midi Out Sync to Digitakt Midi IN
(CLOCK/TRANSPORT SEND / RECEIVE ON)
Digitakt = Audio Output to ID14 input
OB/ABLETON = 64 Buffer
OB = 50 Margin
ABLETON - 48000

Here we go, it was getting a bit better, but then I forgot I had to turn off the Ableton Midi compensation and it sounds so much better synced now.

Base on KICK/BASS on AR - OH/SNARE on digitakt,
I felt there was a small little gap when I layered both machines kicks, but I tried quickly and did not choose two good kick that could fit together.
But from now I can finally Record/Jam on the fly both machines together.
Hopefully the new OB will get those two synced really tight.

Thanks again for your help guys, great community here :wink:

@William_WiLD and btw thank for lots of threads you covered that I did not need to ask anything


#16

U welcome :wink:


#17

As Hannibal from the A-Team says, “I love it when a plan comes together”! Thanks @William_WiLD for helping out!!