Error updating to 1.20. Made several attempts

I’m getting “Oops something went wrong” messages when updating to 1.20. I have used both MacOS Ventura and Windows 11 systems.
I have also tried the legacy method, through Global Settings > System, etc. just to receive the same message.

BTW, I am using the original USB A Elektron cable that came with the unit.

Sometimes doing a factory reset would clear the error message until I restart again. Any suggestions?

1 Like

Me too. This has been occurring since 1.10 actually, and 1.20 did not fix it.
Everytime I boot the device after some time, I’m getting this error.
I need to wait 30s for it to boot correctly.
But if I power it off and restart one hour later, same problem.
I’ve tried multiple factory reset, re-installing the 1.01 version, then installing 1.10 or 1.20 and it’s still there.

For now, I’m sending my unit back after discussing with Elektron support.
Crossing fingers this can be solved quickly, I was really hoping the 1.20 update would fix this issue.

I just sent a ticket to Elektron support. I will see what they have to say about it. I didn’t have this issue when I updated to 1.10.
I guess they will have to fix the installation bug in a new immediate release. Or replace the unit; it is just a few months old.

Upgraded to 1.20 seemed to go fine but only got the sy swarm and no sy raw machine

Did you, uhh… did you try tracks 9 through 11?

3 Likes

Same here.

“Oops something went wrong” happened to my brand new unit. Updated to 1.10 a few days ago and 1.20 via Transfer on an M1 Mac w/Monterey today. Tried a factory reset, got the oops error again. Rolled back to 1.10, everything was fine, upgraded again, oops error…

Left it a couple of minutes while typing a support email. Planned to roll back to 1.01 but tried another reboot and it worked. Ran an empty reset - good, then a factory reset - all good.

Lost my project, gotta be vigilant and backup before updating.

I got this error too and restarted it twice but it didn’t go away. Then I unplugged the USB and restarted again, and it booted fine. So at least for me, it didn’t like the USB connection on first boot (connected fine after that).

1 Like

Yup my mistake.

2 Likes

Nevermind, turned it off after an hour or so of playing, turned it back on after 5-10 minutes and “Oops”

I don’t think it’s normal that a good number (and keeps growing) of users are experiencing this problem.
Any chance at Elektron releasing a new bug free version of the firmware update?

I had a similar issue with my launch day Syntakt that was never resolved via furmware reinstalls or a trip to Elektron’s service center so I got a new one.

Same error to me. I will send support ticket