DT MIDI channels controlled by MIDI?


#12

whats the point of being able to assign a channel to each MIDI track then?
im just trying to figure this out.

get get all the data…i just cant send it to the MIDI tracks no matter what i do.
[why am i still trying? :confused: ]


#13

You assign a channel so you can control an external midi instrument. You’re assigning channel out, not channel in. Channel in is only whatever you’ve selected for auto channel, and whichever active midi track is selected.


#14

do you have this werking with USB…i cant [taking your direction]
im trying with MIDI cables right now.

thanks for helping by the way


#15

Yes. DT midi is set to USB and Midi. I have a midi track in Ableton outputting midi channel 14 (my DT auto channel) to the DT. I have a bass line on it with a soft synth. I want to record midi clip (32steps) to a track on the DT to play my Minitaur without a computer later. DT is slaved to ableton. I select midi track 1, record enable, and go for 2 bars. It’s now on the DT miditrack 1, outputting midi channel 1 and passing through to the moog, receiving on channel 1.


#16

ya not werking

i have auto channel now set to 10
midi A set to 10
DN sending channel 10 CC 71 [which should control VAL2 on DT MIDI track A]

doesnt werk

i just have filters there to make sure all that goes thru is just what i want.

i have MIDI track A selected.


#17

Do you have Val 2 in DT midi A enabled? (Mine is not infront of me, but I’m pretty sure you have to turn each knob “on” )


#18

ya VAL2 is enabled in the DT

VAL1 is controlling sample start
VAL2 is controlling tune

i want MIDI track 2 on the DN to control VAL2 on the DT.
i tried having another MIDI track in the DT do it. i tried setting up a external MIDI track in Logic to control it. nothing affects the VAL controls.


#19

I’ve hit a wall in my mind’s eye. I don’t know when I’ll be able to be back at my studio desk.


#20

Thanks. I was actually told that midi external midi not controlling VAL params in midi tracks was a bug.
It was supposed to be fixed with the last OB beta. But it doesnt seem to be werking for me.


#21

sorry to bump, but I think I have stumbled upon the same problem… did you make it work somehow? :frowning:


#22

I submitted a ticket, it was confirmed.
Ill cautiously assume it being werked on.


#23

shit, this sucks balls.
oh well, hope they fix it soon


#24

Hi everyone! I need a little help with a MIDI controller assignment… I would say I’m fairly experienced with this, but I can’t figure out what I’m doing wrong.

My setup: Faderfox UC4 [MIDI OUT] > [MIDI IN] Digitakt [MIDI OUT] > [MIDI IN] Octatrack

My goal: controlling parameters on the Digitakt (done) and also a few other parameters from the Octatrack…

Now, I know that if I wanted to control the OT without any other configuration I would need to use DT’s THRU, but then again, that way I wouldn’t be able to send transpose/tempo control to the OT (and I don’t think I should need a merger for what I’m about to explain).

So what I expected to do (and I’ve remember doing with the OT in the past) is mapping a MIDI CC on a DT track, so I can control the DT, and the DT would control the OT…

in this case, I’ve mapped the OT crossfader - and it works fine when controlling the OT from the DT… but for some reason I can’t get the DT to recieve MIDI from the controller on it’s MIDI tracks. (it’s receiving MIDI on the audio tracks just fine)

my MIDI CH config:
DT audio tracks: 1 - 8
DT Midi tracks: 9-16
DT AutoCH: 9
OT audio tracks:9-16
OT AutoCH: 9

I’ve tried pretty much all channel combinations… and I don’t understand if I’m missing something…

for example: I’ve mapped one knob on Track H on the DT to the correspondent CC for OT’s crossfader (#48), on CH9. I move the enocoder, the OT responds as expected.
Then I map the controller to the exact same control… MIDI CH 9, CC 48… no luck.


#25

Ill check later. But i think mapping the VAL params is broken at the moment. (If CC48 is a VAL param. Im not near my boxes)


#26

When reading the manual carefully receiving of CCs on the MIDI tracks is nowhere mentioned (neither for recording them, nor for realtime re-transmission). You can only program them on the tracks or use the encoders to send them.

So I’ll guess it’s not even a bug, but simply not implemented yet.


#27

It was supposed to be fixed in one of the updates, which i was pretty stoked about. But it didnt werk.
Thats when i made the ticket.


#28

yeah I just assumed it would work since it’s a reasonable feature, and the Octatrack has it.
as @phaelam mentioned, it appears to be a feature that was implemented, but it’s not working yet.


#29

Itll be worth the wait :slight_smile:


#30

update: I made a ticket myself, was told that it was working on 1.11b6
I updated (was on 1.11b4), still no luck. they told me it worked when sending MIDI from Ableton, and that there might be something wrong with my controller… so I did some tests with Ableton, with the same results.
I supplied some video evidence from the tests I did, and I have yet to get a response - I’ll let you know if I get it sorted out.


#31

weird…the reason I made my ticket was…it was said in the last update that that issue had been addressed.

I ran tests. reported exactly what happened. they did the same and confirmed my findings…that it was intact still broken.

so fingers crossed that it will be addressed in the next update. not a deal breaker…but definitely would be nice to have werking.