DT bug reports - OS 1.02

ah, even though i own the other elektron gear and they have similar interface i would never guess it in this situation. Imp/Exp is not a nested menu hence this doesnt make sense. You also have direct access to either the pattern menu or the imp/exp menu so this is a interface issue imo

yer i found a new one for 600 euro but still not sure I want to commit right now considering the issues. great price though.

when not using the midi tracks it seems to be pretty stable. I think once they fix the midi implementation it should all be fine - i believe they are aware of this and working on it.

Assuming that overbridge is still to be released for DT i expect some significant fixes and improvemnts

1 Like

yer there is still that small concern in the back of my head…what if there is an inherent hardware issue that cannot be resolved with firmware. unlikely, but still a small risk. I am very risk adverse.

So far mine seems pretty stable although I am not interested in DAW integration, so I can’t comment on any issues WRT. I had a couple of crashes, ome when doing a transfer, and one when trying to select all then copy samples, the transfer app also seems to be a bit picky as to whether it will recognise the DT on my computer.
Win7, the device manager sees the DT fine, as does C6 but the transfer app does not always, resulting in a few swearing, unpligging and rebooting cycles.

I’m not 100% convinced of some of the UI choices, sure these are down to personal preference, but so far it seems too easy to accidentally change sample, navigation is sometimes a little inconsistent, and some of the graphics could do with a tweak. The audio editor is ok, the loop scheme is a bit weird, the browser is similar to (analog) Elektron machines so if you are a fan of that (I’m not, I prefer the OT browser) you will probably like it.

Overall though all things considered its not a bad little machine, nowhere near the Octatrack but that is no bad thing in my book., I like them both for different things.


30 posts were merged into an existing topic: Digitakt out now!

Imp/Exp is a submenu of the pattern menu. It does make sense, as it’s consistent with the settings menu (which, as far as I can tell, is the only other nested menu on the machine right now)

Pressing FUNC+[…] is basically a shortcut which says “open the pattern menu and navigate to the import/export submenu”.

Pressing just […] says “if the menu is not visible, open the pattern menu in the state it was in the last time you opened it”, where imp/exp is one of the options. If you press the button while it’s open, it does “hide the menu but remember the nested submenu state you were in”

To go up in the navigation hierarchy, press the NO button. Press it repeatedly to fully navigate out of a menu - three times is the deepest nesting I know of.

It’s logical - adapt to it. Pretty sure this will not get fixed :wink:


Got it, I didn’t see it there at the end of the patterns menu. I’m fine with it now that I know but a good interface should not need so much back and fourth. Until you responded I was restarting my machine to get it back. A good interface is driven by users. If we can’t figure it out easily its probably not ideal.

I would remove the impor/export as a sub menu from patterns since you have direct access to it by fn + … I don’t see how its logical that once toggled fn + … and … take you to the same place. counterintuitive interface

Personally I think in this case it hinders rather than helps workflow, it seems redundant to have the imp/exp in (in effect) 2 places, the shortcut makes it very simple to get at, so I do not see the need to have it in the pattern menu as well, given that it creates a bit of extra menu diving on what is a direct and simple machine.

I agree though that it is unlikely to be changed, and that it is not really an issue once you get used to it, still the decision seems a bit daft - I totally get your point about exiting a menu then returning where you left off when returning to the menu, although I’m not so sure that it is a real need when the shortcut is already there in this particular case, and imp/exp does not really come under the scope of pattern management jobs.

1 Like

^ Damn newbs :wink:

They are different samples.
For example say I sample a few bass sounds from my Minibrute, I have noticed that sometimes they sound like the weight of sound has been lost… I A/B it with the original right after sampling and sometimes it sounds very close to the original and sometimes not.
I do check the meter to ensure Im not clipping when recording the sample.

I also understand that something will get lost when sampling to 16 bit but just wondering why results seem to be inconsistent… also wondering if anyone else has notice this? or maybe I’m just doing something wrong on my end :innocent:

Can anyone else reproduce this:
When recording with nothing attached to inputs/or no volume coming into them, the sampler window records white noise!
I discovered this today trying to do a threshold recording, I set my threshold and while I was getting ready to record the whitenoise triggered the threshold recording and started recording. thinking it must be from my ipad, I unlugged the inputs on the digitakt, and discovered the same thing happens with nothing connected.
Here’s a video:

You’re recording silence, or actually, the noise floor. When this gets auto-normalized, it’s going to be close to white noise.


that does make sense… .
But it should’t trigger the threshold?!

odd thing with p-lock memory:
there’s 72 slots for p-locks - if you create more than that, the machine says “lock mem full”. But you can still add additional p-locks, at least the UI doesn’t complain… but, you then cannot save the pattern, it says “save error”.


:thinking:I don’t think I’ve mentioned audio over USB, and I’m not sending anything over USB when this happens.

mine does the same
it looks silent until you actually start recording with no leads plugged in , and with a lead plugged in (although the other end isnt plugged into anything) , it then records static for no reason.

internal recording seems silent , seems fine when recording actual internal sounds too.

… just had some hours with my new familiy member - standalone really nice, sound and tweaking capabilities perfect!


DAW integration (Cubase 9pro) makes no sense for the moment, DT crashes all the time when using one or two midi tracks. I didn’t come further than using 3 tracks for more than 30 sec. Worse - I have no clue at which point it happens, but it’s everytime the same result: DT runs its pattern but doesn’t react on anything - exept restart.

BTW - midi-setup in cubase shows in- and out-port as ‘Digitakt in1’. And Midi-Monitor shows messages only on one (active) channel, even if there were three. Trying to use Cubase’s local midi-filter to separate the channels causes a crash at once.

Hope there will be an OS 1.1 or 1.2 soon :slight_smile:

installed today 1.02 … first it was running nicely with midiclock … i did some midi recording from my keyboard and played some external synths … all great .

but then after 2h suddenly some midi notes dropped out, then a moment later all midiout was quiet and few seconds later the whole machine froze

from then on it happened every few minutes or even after a few seconds … without external clocking it’s all working nicely

i reported this to elektron again with as many details as possible - i hope they can track it down and find a real solution
i’m starting to get a bit pissed … sure i can use the machine , but without midi-sync it’s more or less playing around and testing


maybe not a bug… but a mistake…
i think at elektron it will be understood what I want to explain
just something to optimize…